none
new-cluster static address was not found on any cluster network RRS feed

  • Question

  • Hi guys,

    Recently my 2 node cluster got into some issue one of my node was not able to start up. I tried running start-custernode -forcequorum

    but i got error Start -

    start-clusternode: the system cannot find the file specified.

    No solution found. So i went to the other node which still with the cluster and remove the cluster.

    Removing of cluster is fine no issue. However i face another problem the moment i wanted to recreate the cluster.

    The error shown was -

    New-Cluster: Static address 'x.x.x.x' was not found on any cluster network.

    If anyone know what going on please let me know. Thanks.


    Friday, August 16, 2019 9:50 AM

All replies

  • What do you mean when you say "removing of cluster is fine"?  

    You should not have been removing anything.  At this time, it is difficult to tell what you have done to your environment.  It may be easiest to destroy your existing cluster and rebuild it.  If you are able to get one node up in its current situation, you may be then able to get the other node in, but it is pretty difficult to know what status your system is currently in.  Running a cluster validation report against the cluster would help us understand, but no guarantees on getting it back.


    tim

    Friday, August 16, 2019 1:20 PM
  • i mean there were no error on removing.

    Sadly both nodes are currently down and still trying figure out what does the error means.

    I am on using windows 2016 server core. 

    I did not dare to remove the window feature and reinstall as i remember i had few times not able to get the cluster command back (Mean i ran tons of cluster command like get-cluster) on my other server after reinstalling the feature. And the only way fix was to reformat the server.

    Friday, August 16, 2019 1:31 PM
  • It sounds like you are not very familiar with troubleshooting clusters.  You might be best served by opening a case with Microsoft to help someone step you through a recovery process.

    So you removed the failover cluster feature from one node of the cluster?  Did you evict that node from the cluster before removing the feature?

    What sort of error messages are you getting when you run the cluster validation wizard against the hoped for nodes of the cluster?


    tim

    Friday, August 16, 2019 1:40 PM
  • Hi Tim,

    Yes i am pretty new with cluster troubleshooting. I do wish i can call them directly for help right now...

    I tried on vm sometime i get that issue whether the cluster has been removed or the node has been evicted.

    Saturday, August 17, 2019 7:07 AM
  • Anyway i just manage to get the event log from C:\windows\cluster\report.

    i saw the following error:

    The description for Event ID 1069 from source Microsoft-Windows-FailoverClustering cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    Window Insider Service
    Cluster Role
    Generic Service

    Saturday, August 17, 2019 8:48 AM
  • "I do wish i can call them directly for help right now..."

    You can always call Microsoft for assistance.

    Or, if you have the time, you can start over from scratch and follow one of the many tutorials available online.


    tim

    Saturday, August 17, 2019 1:25 PM
  • Hi,

    How are things going on? Just want to confirm the current situation.

    Please feel free to let me know if you need further assistance.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, August 21, 2019 9:58 AM
    Moderator
  • Hi,

    Was your issue resolved?

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, August 29, 2019 8:11 AM
    Moderator