none
Hyper-V R2 MMC not connecting

    Question

  • Hi

    I just downloaded Hyper-V R2 and have it set in a workgroup mode.  I enable every option on the menu system for enabling remote management.

    Since I am in a workgroup, I have my user on Windows 7 and a local admin user on hyper-v to have the same name and passwords.  to help with the authentication.  On windows 7 I managed to find RSAT and unhide the Hyper-v management console.

    I have full RDP access to the server.  However, when I try to connect via the Hyper-V MMC, I get the following error:

    "Cannot connect to the RPC service on computer <Hyper-V Server>. Make sure your RPC service is running.

    I have verified that the RPC service is running on the Hyper-V server.  I tried running HVADMIN but I get an "Access is Denied" error.

    Any suggestions?

    Monday, September 21, 2009 10:33 PM

Answers

  • MS just got back to me.

    Hyper-V R2 already has all the necessary features to enable remote management (option 4) - its new in R2

    On the server run this one command:

    netsh advfirewall set all profiles state off

    Then I had to go to my desktop

    The problem was actually my Windows 7 PC

    1) Goto run: dcomcnfg
    2) Plus out Component Services -> Computers -> my computer
    3) Right click on the My Computer in the left pane and select COM Security
    4) Under edit limits for access permissions, click on Anonymous and allow Remote Access

    Then I was able to connect to the Hyper-v manager!

    • Marked as answer by Alphatech4 Tuesday, September 22, 2009 3:52 PM
    Tuesday, September 22, 2009 3:52 PM

All replies

  •    There are lots of problems with setting this up. See this blog entry about hvremote, which should sort it out.

    http://blogs.msdn.com/virtual_pc_guy/archive/2009/08/11/updated-hvremote-tool.aspx

    Bill
    • Proposed as answer by Brian Borg Tuesday, September 22, 2009 3:22 AM
    Tuesday, September 22, 2009 12:16 AM
  • MS just got back to me.

    Hyper-V R2 already has all the necessary features to enable remote management (option 4) - its new in R2

    On the server run this one command:

    netsh advfirewall set all profiles state off

    Then I had to go to my desktop

    The problem was actually my Windows 7 PC

    1) Goto run: dcomcnfg
    2) Plus out Component Services -> Computers -> my computer
    3) Right click on the My Computer in the left pane and select COM Security
    4) Under edit limits for access permissions, click on Anonymous and allow Remote Access

    Then I was able to connect to the Hyper-v manager!

    • Marked as answer by Alphatech4 Tuesday, September 22, 2009 3:52 PM
    Tuesday, September 22, 2009 3:52 PM
  • MS just got back to me.

    Hyper-V R2 already has all the necessary features to enable remote management (option 4) - its new in R2

    On the server run this one command:

    netsh advfirewall set all profiles state off

    ...

    This also resolved the connection issue that I'm having but I'd rather not have the firewall on the server disabled. I used the Remote Admin option of sconfig to enable all three remote options. There must be something missing. Does anyone have any ideas?

    TIA

    -Mike
    Monday, November 09, 2009 1:55 AM