Error 1079 Can't Start Service


  • Just rebuilt my 64 bit Dell T605 with Server 2008. It's my personal 
    development machine so I installed a Creative SB X-Fi sound card. I can't 
    start the Audio Services because of error 1079 "The account specified for 
    this service is different from the account specified for other services 
    running in the same process". Going through all the other services (both 
    required and dependent for audio service) I find they are all assigned the 
    Local System account and with the "Allow service to interact with desktop" 
    check box unchecked. All the required services are running before trying to 
    start audio. What am I missing? I can't figure this out.
    Frank Fox
    Hendersonville, Tennessee
    Thursday, September 24, 2009 1:09 PM


All replies

  • Hi

    Have you logged in as the user or admin who is the member of local admin group while starting this service?

      Try with local admin may work for you....

    If its not working

    Try the below link also


    Rajesh J S
    • Marked as answer by frankvfox Thursday, September 24, 2009 1:42 PM
    • Unmarked as answer by frankvfox Thursday, September 24, 2009 1:43 PM
    Thursday, September 24, 2009 1:25 PM
  • Rajesh,

    Thank you for the quick response. I followed that link a couple of days ago to no avail.

    I am the Administrator and only user on my machine.

    I should mention I'm not running a domain, rather my and my wife's laptops are all in the "Workgroup" workgroup with the server. Might this have an affect?

    Thursday, September 24, 2009 1:47 PM
  • Hi

    That will not affect....

    Is the there any Error event ID..??
    Please post the event ID with error message... So that we can help you to solve the problems..

    Rajesh J S
    Thursday, September 24, 2009 2:32 PM
  • Rajesh,

    I am preparing the appropriate screen shots for your perusal. I'll email them to you as I get them. They will be the status and properties screens for all the required services.


    Thursday, September 24, 2009 2:40 PM
  • Rajesh,

    Please send me an email address which will reach you. I sent two to and they failed.

    • Proposed as answer by Fredkzn Monday, September 30, 2013 6:15 AM
    • Unproposed as answer by Fredkzn Monday, September 30, 2013 6:15 AM
    Thursday, September 24, 2009 3:53 PM
  • HI

    We will try our level best to solve your problem ASAP.

    Rajesh J S
    Thursday, September 24, 2009 5:26 PM
  • Hi Frank,

    Thanks for the Mail with screen shots.

    After looking to those screen shots...

    The services should run under local system account.

    Go to these services properties, click on log on tab then check the local system account (Don't select allow these services to interact with desktop)

    Reboot the system.

    Please try this and let us know the updates, so that we can proceed further on the same.

    Regards Rajesh J S
    Friday, September 25, 2009 1:24 AM
  • Hi Rajesh, 

    i have a question regarding the issue.

    how are you determining that the services should start in desired user account <either local system account or network account >

    the reason is most of the services do not require such a high priviliged account to run the service, its the developer who decides what access is required to run his service either he mentions

    a) local service account

    b) network account.

    the above one are commonly used.

    are these services interactive services ?

    Please understand that local system account inherits the security context of SCM

    sainath !analyze
    Friday, September 25, 2009 2:08 AM
  • Hi Sainath,

    These services are windows audio services and creative audio services.

    Which I have checked in my couple of systems and its configured to local system.

    If you provide oyur email ID, I will forward the screen shot, so that we can work together to solve the issue.

    Thanks for the above awareness to me....


    Rajesh J S
    Friday, September 25, 2009 3:24 AM
  • Hi Frank,

    Any update on the problem?

    Rajesh J S
    Saturday, September 26, 2009 4:32 PM
  • Rajesh,

    I was away to upstate New York this weekend at a neighborhood reunion entitled "South Troy Against The World" and met many old friends from 40 or more years ago. It was great fun.

    I have all the required services started and all but Remote Procedure Call logs on as Local System Account. The Properties dialog box is greyed out and locked into the Network Service Account. Accordingly, I can't change any of the RPC properties. Therefore I'm still getting Error 1079 trying to start the Audio service.


    Monday, September 28, 2009 4:16 PM
  • Hi Rajesh,

    Where have you gone? Please see my earlier response dated 9/28.

    Thursday, October 01, 2009 1:15 AM
  • Hi Frank,

    Apologies for delayed reply.


    Please go through this link and assign the appropriate account to the service. It will work for you…



    Waiting for your reply…



    Rajesh J S
    • Proposed as answer by Rajesh J S Friday, October 02, 2009 7:42 AM
    • Marked as answer by David Shen Monday, October 05, 2009 10:02 AM
    Thursday, October 01, 2009 7:34 AM
  • Hi Rajesh,

    My daughter interrupted our dialog by prematurely giving birth to my first male grandchild on Tuesday. Everybody is okay (thank goodness).

    I had a registered copy of RegistryBooster 2009 on my other machine before the recent nearby lightning strike so I'm in contact with Uniblue as how to proceed acquiring 2010. I'll let you know if that works.

    Thursday, October 01, 2009 3:57 PM
  • Hello Frank

    Please try the following settings to resolve your issue..

    goto services.msc ->windows audio ->click on logon 

    Under  log on - I typed in

    NT AUTHORITY\LocalService

    then the password.

    And restarted it - I hope it works! Otherwise i think you have reinstall the operating system only to resolve this issue.

    Deva --Self-trust is the first secret of success.
    • Proposed as answer by Devaraju K Thursday, October 01, 2009 7:45 PM
    • Marked as answer by frankvfox Friday, October 02, 2009 2:06 PM
    • Unmarked as answer by frankvfox Friday, October 02, 2009 2:07 PM
    Thursday, October 01, 2009 7:33 PM
  • Hi Deva,

    Where have you been all my life!?

    It worked!

    Many thanks to all who offered suggestions but especially Deva!

    Thank you very much.

    • Marked as answer by frankvfox Friday, October 02, 2009 2:10 PM
    Friday, October 02, 2009 2:10 PM
  • :)- Cool ...... You are most Welcome!!!


    Deva --Self-trust is the first secret of success.
    Friday, October 02, 2009 5:20 PM
  • Thank you very much Devaraju. Worked here too!
    Thursday, April 11, 2013 4:32 PM
  • Hi Deva,

    After trying to fix my sound I came across your fix.  After weeks of trying it is finally working!  You are a legend.  I had problems after updating my apple iTunes software I read to uninstall everything to do with apple and reinstall.  I have done all this and now it wont let me reinstall iTunes it comes up with a conflict with Bonjour.  Do you have any help with this??  I have tried numerous things through apple help with no luck.

    With Thanks & Regards


    Friday, October 10, 2014 11:50 PM