Network connectivity issues


  • Since I first setup this network I have been having issues, so I will start with the basics

    Network - 192.168.13.x/

    .1 Untangle Firewall 7.2

    .2 Windows 2008R2 Server, DC, Exchange 2010, Forefront for Exchange

    .3 Windows Home Server

    .100-150 Windows 7 Clients and 2 windows xp

    All attached to domain, Home server set for common shares

    When I installed the Windows 2008 server it had ip6 on there as I needed it for Exchange 2010 install, I have since disabled it following kbs, since I installed it, I have had numerous networking issues, most commonly is the drops in connection, be it from a network share, or RDP.  It will just drop the connection, can not reconnect until 15 sec to 30min before it lets me back in???  This is for the wireless and LAN connections, does not matter on the client, Home server, outside remoted in or whatever.  I will connected to a network share, like public directory and it will die, saying directory not available, yet I can ping and even RDP in... or I can on RDP and the connection will die, yet I can still use the network share.

    I am almost ready to rebuild this server, but as it is the only DC, I dont want to reset up every client.  Are there any ideas I can try?

    Thanks in advance,


    Monday, May 10, 2010 5:34 PM

All replies

  • Before rebuilding the server and starting over I would replace the network card or add a second and disable this one.

    I have seen faulty network cards cause the most odd ball network connectivity issues.
    Try replacing the ethernet cable also.


    Dont forget to check the server logs for errors.


    Tuesday, May 11, 2010 6:54 AM
  • The server has an Intel S3420GPLC MB, it has two onboard Gigabit NIC's,I have tried both with the same results.

    Changed the Network cable - no resolve

    Different Switch - No resolve

    Figures I can not log in at the moment.... so I will have to access it locally again, I will get that to you ASAP on any errors...  Do you care which log?  I will look at both.


    Wednesday, May 12, 2010 7:57 AM
  • Question 1.  You mentioned the Untangle server, version 7.2 (latest). Since you mentioned this, is this between your firewall and the first ethernet switch (like a normal setup)?  Bridge mode or routed mode?

    Question 2. Are your connections all on the same network (Don't want to take any assumptions)?

    Question 3. If this is all internal on the same network and same switch, then untangle does not really come into play here. It sounds like you have two servers.  Are the connection issues with either of the servers?



    Thursday, May 13, 2010 8:21 PM
  • Sorry I did not get back asap, I had my firewall go down, so I needed to get that all upgraded.

    Response to question 1) I feel the Firewall has nothing to do with it, originally I had a Symantec Velociraptor as the FW, then replaced to an Untangle FW, it is in Routed Mode.  I had these issues before.

    Response to question 2) Same network yes.

    Response to question 3) When you say servers, I have 3: Win2008r2 (DC/Exchange2010/DNS/WINS), Windows Home Server, Untangle.  I only have the issue when connecting to the Win2008r2.  I can stay online either RDP or in a shared folder on the WHS.  But I can not on the Win2008r2.

    I will list the errors/Warnings I am getting on the DC, I have not been able solve these yet;
    Error: Event 8193 VSS
    Volume Shadow Copy Service error: Unexpected error calling routine RegOpenKeyExW(-2147483646,SYSTEM\CurrentControlSet\Services\VSS\Diag,...). hr = 0x80070005, Access is denied.
    Initializing Writer
    Writer Class Id: {f08c1483-8407-4a26-8c26-6c267a629741}
    Writer Name: WINS Jet Writer
    Writer Instance ID: {da86793c-74b6-47aa-923b-b49cebe98351} </p></span>
    Error: Event 36888 Schannel
    The following fatal alert was generated: 10. The internal error state is 1203.
    Error: Event 4337 Wins
    The WINS Server could not initialize security to allow the read-only operations.
    Warning: Event 1014 DNS Client Events
    Name resolution for the name cdn-microupdates.cloudmark.com timed out after none of the configured DNS servers responded.
    Warning: Event 10154 Windows Remote Management
    The WinRM service failed to create the following SPNs: WSMAN/GAEA.awrenscorner.net; WSMAN/GAEA.
     Additional Data
     The error received was 8344: %%8344.
     User Action
     The SPNs can be created by an administrator using setspn.exe utility.
    Warning: Event 10020 DHCP-Server
    This computer has at least one dynamically assigned IPv6 address.For reliable DHCPv6 server operation, you should use only static IPv6 addresses.
    Warning: Event 12 Time-Service
    Time Provider NtpClient: This machine is configured to use the domain hierarchy to determine its time source, but it is the AD PDC emulator for the domain at the root of the forest, so there is no machine above it in the domain hierarchy to use as a time source. It is recommended that you either configure a reliable time service in the root domain, or manually configure the AD PDC to synchronize with an external time source. Otherwise, this machine will function as the authoritative time source in the domain hierarchy. If an external time source is not configured or used for this computer, you may choose to disable the NtpClient.
    Warning: Event 27 e1qexpress
    Intel(R) 82574L Gigabit Network Connection
     Network link has been disconnected.

    This only has 2 warnings and not during anytime I am connected to the machine

    I have Forefront Protection 2010 for Exchange Server on this server and it is constantly erroring during downloading updates... But I was having the original issue before installing Forefront Server on this machine.

    Monday, May 24, 2010 1:05 AM
  • Hi Gents,

    i have almost the exact same situation with one of my 2008 r2 DC's. i have two identical hardware and OS and patch level DC's replicating and one exchagne 2010 box. server A is the backup DC and is the one with the same syptoms as you are having with ping and RDP and shares but server B which is primary is 100%.

    I have tried everything from changing lan cards, cables, switch ports and so on all with no luck, also tried disable all kinds of setting on the lan card it self with nothing changing.

    Installed windows updates and reliability patches from windows updates, installed updated drivers and firmware but nothing. read up on another topic


    and tried the recommends there but nothing. if you managed to get this sorted out yet any heads up would be great.



    Tuesday, June 01, 2010 1:32 PM
  • No one has any ideas on how to deal with the above listed errors?  Since I enabled the other NIC and use both, everything seems to work better, at least I have not been disconnected.

    But my error logs are filling up with WINS and other errors.  I have read that you do not want to have Dual NICs on a DC, but I dont know how to make it work without having both enabled.

    Friday, June 04, 2010 5:16 PM
  • Thanks for the response, i also tried to use two nics but it did the same, even if i teamed them...

    I am also pretty stuck on this one... will be attempting the DFS setup as mentioned in the above link and will post update once tested.

    Have a good one and keep cracking

    Monday, June 07, 2010 9:47 AM