none
Maximum VM Memory

    Question

  • I'm setting up a test environment using an older server and Hyper-V Server 2008 R2 to produce and test some VMs.

    The hardware is nothing formidable, dual core Xeon and 8GB of memory, but I was under the impression that it should do fine for testing at most 1 or 2 VMs at any given time.

    The problem what I am having is that if I go into Hyper-V Manager and create a new VM, the "Assign Memory" page of the wizard will not allow me to allocate more than 2GB of RAM to the VM.

    What am I missing?
    Tuesday, December 22, 2009 2:43 AM

Answers

  • In Hyper-V Manager UI, the limit when assigning a memory to the VM is determined by the amount of physical memory the connected host has. There maybe some issue of memory reporting from the host side.

    Does this host have any form of specific memory architecture such as NUMA?

    Can you try to start a VM created by Powershell configured with more than 2 GB of memory on the problematic host?
    Serdar Sutay [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, December 22, 2009 8:10 PM
    Owner

All replies

  • What else is running on the server?

    Do you have any paused virtual machines?
    Tuesday, December 22, 2009 4:11 AM
    Moderator
  • Hi,

     

    I have a normal desktop computer only has 6GB’s memory and I have tried to assign 4GB’s memory. I suspect that there are some programs/applications eat up your memory. Please restart the Hyper-V Server computer to check whether you get the same issue.

     

     

    Best Regards,

    Vincent Hu

     

    Tuesday, December 22, 2009 5:34 AM
    Moderator
  • I've restarted the computer and that didn't help. The host machine only has a stock install of Hyper-V Server 2008 R2. There can't be any other applications running.

    I'm running Hyper-V Manager from another computer. The "Assign Memory" page of the wizard says in the instructions at the top that I can assign up to 2096MB of memory. However, I can find no reason why I should be limited like that.
    Tuesday, December 22, 2009 6:20 AM
  • Just to be sure, I double checked and with no VM's running, there is only about 500MB of system memory in use.
    Tuesday, December 22, 2009 7:30 AM
  • I was just thinking, does it make any difference that when I first installed Hyper-V server, there was only 2 GB of physical memory? I wanted to get things up and running and didn't wait for the other memory to come in. So, the machine was upgraded from 2 GB to 8 GB later on.
    Tuesday, December 22, 2009 7:43 AM
  • Hi,

     

    Please use script to create a virtual machine to check whether you can get it:

     

    Hyper-V How To: Create a VM using Script

    http://blogs.technet.com/tonyso/archive/2009/08/20/hyper-v-how-to-create-a-vm-using-script.aspx

     

     

    Best Regards,

    Vincent Hu

     

    Tuesday, December 22, 2009 7:44 AM
    Moderator
  • Ok, I can create a new VM via PowerShell. I can also modify the memory of an existing VM. This even shows up if I open the settings in Hyper-V Manager. The memory tab still says I can only allocate up to 2046, but as long as I don't touch that text box and trigger the validation, I can save the settings dialog.
    Tuesday, December 22, 2009 8:20 AM
  • Hi,

     

    Glad to hear that you can create a new virtual machine using PowerShell script.

     

    By the way, I suspect that there are some issue with your Hyper-V Manager on the client computer, so I would like to confirm the version of your client computer and the version of the Hyper-V Manager on the client computer.

     

    In addition, if possible, please try to create a new virtual machine on another client computer to check whether you get the same issue. Please check whether there are any errors in Event Viewer of the client computer and the Hyper-V computer. If you don’t have another physical computer, you can use the following workaround:

     

    1.    Create a new Windows Server 2008 R2 virtual machine.

    2.    Install Hyper-V Manager console inside the virtual machine.

    Command: dism /online /enable-feature /featurename: Microsoft-Hyper-V-Management-Clients

    3.    Remote desktop into this virtual machine, use the Hyper-V Manager of this virtual machine to manage the Hyper-V host.

     

     

    Best Regards,

    Vincent Hu

     

    Tuesday, December 22, 2009 8:44 AM
    Moderator
  • In Hyper-V Manager UI, the limit when assigning a memory to the VM is determined by the amount of physical memory the connected host has. There maybe some issue of memory reporting from the host side.

    Does this host have any form of specific memory architecture such as NUMA?

    Can you try to start a VM created by Powershell configured with more than 2 GB of memory on the problematic host?
    Serdar Sutay [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, December 22, 2009 8:10 PM
    Owner