I have Windows 7 Enterprise running on server, but still no /multimon


  • I have Windows 7 SP1 Enterprise at work, and I'd like to connect using the dual monitors I have at home. (running Windows 7 Professional, upgraded to Windows 7 Ultimate)

    I tried mstsc.exe /multimon.  I tried making sure "Use all my monitors for the remote session" was checked.

    I only ever get 1 monitor.

    mstsc.exe /span does work across 2 monitors... but that's lame.

    • Edited by sbauer23 Sunday, February 05, 2012 6:41 PM
    Saturday, February 04, 2012 9:51 PM

All replies

  • Hi,


    You may check the following options.


    To use Remote Desktop Multimon feature, you must:

    1.       Connect using the Remote Desktop Client 7.0 (mstsc.exe) available initially on Windows 7/Windows Server 2008 R2.

    2.       Enable Multimon using one of the three methods described below:
    a. Click “Use all monitors for the remote session” in the client (mstsc.exe) window.
    b. Use the “/multimon” switch on the mstsc.exe command line.
    c. Add “Use Multimon:i:1” to the RDP file.

    3.       Connect to a computer running Windows 7 or Windows Server 2008 R2.


    Please refer to the link below for detail information.

    Using Multiple Monitors in Remote Desktop Session


    Technology changes life……
    Monday, February 06, 2012 9:37 AM
  • Yep... tried all that.. still nothing.

    Like I said, the computer I want to connect to is running Windows 7 Enterprise, I'm running Windows 7 Ultimate.  I checked the "Use all monitors for the remote session" check box, and I've run mstsc.exe /multimon.  I still only get 1 monitor.

    Wednesday, February 08, 2012 1:31 PM
  • Hi,

    1. Do you by chance have Limit maximum number of monitors group policy setting configured on the target PC?

    2. What is the monitor configuration on your home PC?  Resolution, etc.

    3. When connecting to your work PC from home, are you re-connecting to an existing session, for example, you were logged on at the physical console when you left work, or are you starting a new session?

    4. On the target PC, please check the following logs for warnings/errors/etc. that may be related to this issue, especially those that appear around the time you connect to it remotely:

    Event Viewer\Windows Logs\Application

    Event Viewer\Windows Logs\System

    Event Viewer\Applications and Services Logs\Microsoft\Windows\TerminalServices-LocalSessionManager\Operational

    Event Viewer\Applications and Services Logs\Microsoft\Windows\TerminalServices-RemoteConnectionManager\Operational



    Wednesday, February 08, 2012 5:26 PM
  • 1. nope, group policy editor says it's "not configured".  Administrators around here agree, it's not a policy they would enforce.

    2. 2 monitors, both 1920x1200

    3.  I've tried both ways, connecting to exsting session, logging off that session, and then trying again.  Still didn't work.

    4. I see nothing in the logs that suggest anything abnormal is going on.

    I appreciate the help though!

    Thursday, February 09, 2012 4:42 PM
  • Hi

    Did anyone find a sloution here.

    Have exact same problem.


    Monday, February 13, 2012 3:50 PM
  • Hi,

    not a real solution for multimonitor but here is what i do to create a large desktop spread over both monitors at home.

    First open remote desktop and set the resloution NOT on ful screen. I save this setting and close remote desktop.

    Then I open default.rdp in my documents and set the resolution:

    desktopwidth:i:xxxx     (line 3)



    That is the sum of both of my monitors. (Desktopheight should be the height of the monitors of course, both the same)

    I save and close this text document, open again remote desktop and connect without opening the options.

    Works for me but if there's a way to realy use multimonitor I would like to learn how!

    Greetings Robert

    Wednesday, February 15, 2012 8:07 AM
  • I can get /span to work, which sounds like it does what you are suggesting (one big screen).

    But as a developer, I really need multiple screens.  moving editors, debuggers, etc around one screen is a hassle.  I started using winsplit revolution which lessens the pain a little since I can place apps in certain spots, but I still don't get why /multimon doesn't work.

    Wednesday, February 15, 2012 1:07 PM
  • Hi,

    Do you have a Server 2008 R2 server with RDSH Role Service installed that you could connect to from you home PC as a test?  If not do you have another Windows 7 Ultimate/Enterprise machine you could connect to from your home PC as a test?  You could use a trial version of Server 2008 R2 running in a VM if necessary for your testing.

    Do you have another workstation/laptop with dual monitors that you could use to test connecting to your Windows 7 Enterprise work PC?

    I am hoping by testing different combinations you could narrow down the source of the problem as being the home or work PC.


    Wednesday, February 15, 2012 4:29 PM
  • yes we do as a matter of fact. :)

    I can confirm that around here, any Windows 7 enterprise client I tried to connect to with /multimon failed to give me multiple monitors.

    I can also confirm that any Windows 2008 server that I tried to connect to SUCCEEDED to give me multiple monitors.

    I connected from same Windows 7 client.

    Wednesday, February 15, 2012 6:50 PM
  • Hi,

    1. Please verify that MaxMonitors is not set in the target Windows 7 Enterprise PC's registry, if it does exist it needs to be greater than 1:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

    MaxMonitors     REG_DWORD     0x00000004

    By default it should not exist.

    2. Please update the video driver on the target Windows 7 Enterprise PC, restart, and then test to see if you are able to see both monitors in your remote session.  If updating the video driver does not fix the issue, please temporarily switch the video driver on the target PC to Standard VGA Graphics Adapter, and then test again.  Although the video driver for your hardware is not used for remote connections it can affect the proper operation if it is faulty.

    I tested connecting to a default Windows 7 Enterprise as well as Windows 7 Ultimate from a Wiindows 7 Ultimate machine with 2 displays and it worked every time.  This (as well as other info you provided) leads me to the obvious conculsion that there is something unique about your Windows 7 Enterprise PCs that is stopping multi-mon from working.



    Monday, February 20, 2012 7:20 AM
  • I can confirm that there is no HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp MaxMonitors in the registry.

    Installing new drivers for the NVIDIA Quadro FX 580 drivers did not make a difference, nor did switching the video driver to Standard VGA Graphics Adapter.

    I really appreciate the advice though.  I've tried a few other Windows 7 Enterprise machines around here, and I can't get any of them to work with multimon.  The 2008 servers work just fine though.

    Monday, February 20, 2012 2:24 PM
  • Hi,

    Does the target PC have SP1 installed?  It is not a requirement, just trying to think of anything that may be different from my testing.

    Do you have any other remote access software loaded on the target PC?  Specifically software that allows someone to access the PC remotely like PCanywhere, GoToMyPC, VNC, etc.  Sometimes these can interfere.

    Do you have any other third-party software loaded on the target PC that may be causing this issue?  For example, monitoring software like SpectorSoft?  It is a long shot but I would also recommend temporarily removing any security/antivirus/antimalware/firewall software, restarting, and then test to see if the issue is resolved.  I doubt the antivirus/security type software is causing this issue, however, I have seen antivirus cause so many different strange behaviors over the years it is worth a try.

    Please try to think of any special software that is loaded on the target PC, something that most companies do not have/use.

    How was Windows 7 Enterprise installed on the target PC?  Was it a clean install, upgrade, etc.

    If the above does not help I think you should open a support case with Microsoft PSS.  If this turns out to be a bug or they are unable to fix the issue they will likely refund the support fee.  In my experience the multi-mon feature "just works" unless the target PC has limited the maximum monitors or does not meet the requirements.



    Monday, February 20, 2012 2:57 PM
  • I do have SP1 installed.

    There is no other remote access software installed.

    We have trendmicro anti-virus, but I don't really have a way of turning this off.

    I'm not sure how Enterprise was installed. I suspect that the computers came with Windows 7 pro, and were upgraded to Enterprise.

    Thursday, February 23, 2012 2:33 PM
  • nope... Turns out these machines came with Enterprise... so there was no upgrading...  sigh
    Thursday, May 17, 2012 6:01 PM