none
RPC Service is unavailable but is running in the services

    Question

  • Hi -

    I'm having a problem were my DC's not running correctly because DNS doesnt start, and a whole lot of domain controller related issues are popping up - cant edit GPO's etc...

    When you manually try to start the dns server service it says that the RPC service is unavailable, but it is running...

    Any ideas?

     

    A

    Monday, November 08, 2010 6:31 AM

Answers

  • Hello AntsZA,

    According to the MPS report, I found that the external DNS address might cause the problem. You can refer the following article which can tell you why using a public DNS server for AD doesn't work. You can try to remove the public DNS servers from MegaCube-DC and configure it as "FORWARDERS" on the DNS server properties in the DNS management console. After changing the IP settings run ipconfig /flushdns and ipconfig /registerdns and restart the netlogon service or restart the domain controller.

    Active Directory and Its Reliance on DNS, and using an ISP's DNS address
    http://msmvps.com/blogs/acefekay/archive/2009/08/17/ad-and-its-reliance-on-dns.aspx

    ====================================
    Adapter : Local Area Connection
            Adapter ID . . . . . . . . : {A19E0A70-57AA-4BA9-884B-8C5E09A38F68}
            Netcard queries test . . . : Passed
            Adapter type . . . . . . . : Ethernet
            Host Name. . . . . . . . . : MegaCube-DC
            Description. . . . . . . . : Intel(R) 82575EB Gigabit Network Connection
            Physical Address . . . . . : 00-15-17-EC-25-64
            Dhcp Enabled . . . . . . . : No
            DHCP ClassID . . . . . . . :
            Autoconfiguration Enabled. : Yes
            IP Address . . . . . . . . : 10.10.10.10
            Subnet Mask. . . . . . . . : 255.255.255.0
            Default Gateway. . . . . . : 10.10.10.253
            Dns Servers. . . . . . . . : 10.10.10.10
                                               168.210.2.2

    [WARNING] The DNS entries for this DC are not registered correctly on DNS server '0.0.0.0'. Please wait for 30 minutes for DNS server replication.
    [WARNING] The DNS entries for this DC are not registered correctly on DNS server '10.10.10.10'. Please wait for 30 minutes for DNS server replication.
    [FATAL] No DNS servers have the DNS records for this DC registered.
    ====================================

    Brent


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Wednesday, November 10, 2010 1:42 AM
    Moderator
  • Ants,

    This is almost sounding like it may be a malware issue. Not sure at this point, but try running the free tool at www.malwarebytes.com just to eliminate this possibility. You can also run the Microsoft MRT:

    The Microsoft Windows Malicious Software Removal Tool helps remove ...Nov 9, 2010 ... Microsoft releases a new version of the tool every month. ...... first open the log file for the cleaner tool (%Windir%\Debug\Mrt.log). ...
    http://support.microsoft.com/kb/890830

    Afterwards, let's try another strategy...

    Do you have another Windows server you can run DNS on? It doesn't have to be a DC. Since this box DNS service is not running, you can use another.

    • Create the MegaCube.local and _msdcs.MegaCube.local zones
    • Delegate the "_msdcs" zone under MegaCube.local to itself
    • Set both zones to allow updates.
    • Set the DNS address on your current DC to this server.
    • Run ipconfig /registerdns
    • Restart the netlogon service
    • Wait about 10 5- 15 minutes, check the zones to see if the SRV and other records populated
    • Also check the Event log on the DC.

    Also, is there any AV or security software installed on the DC? You may want to uninstall them at this point to help towards diagnosing and fixing this thing.

    Ace


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

     

     

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    Friday, November 12, 2010 2:37 PM

All replies

  • start reading from here

    http://support.microsoft.com/kb/171781

     


    http://www.virmansec.com/blogs/skhairuddin
    Monday, November 08, 2010 6:43 AM
  • Hello,

    any firewall between them? The make sure ports as listed here are open for AD:

    http://technet.microsoft.com/en-us/library/dd772723(WS.10).aspx

    If this isn't the case you have to provide more inforamtion about the amount of DCs, OS versions and SP/patch level and ofr starting at least an unedited ipconfig /all from the DCs and on workstation if used to modify domain settings or GPOs.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Monday, November 08, 2010 6:43 AM
  • There is only one DC running Windows 2008 STD - SP1

    Ipconfig /all list -

    C:\Users\Administrator>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : MegaCube-DC
       Primary Dns Suffix  . . . . . . . : MegaCube.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : MegaCube.local

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) 82575EB Gigabit Network Connecti
    on
       Physical Address. . . . . . . . . : 00-15-17-EC-25-64
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::889b:b43b:cacc:c757%10(Preferred)
       IPv4 Address. . . . . . . . . . . : 10.10.10.10(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 10.10.10.253
       DNS Servers . . . . . . . . . . . : ::1
                                           127.0.0.1
                                           168.210.2.2
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 8:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.{A19E0A70-57AA-4BA9-884B-8C5E09A38
    F68}
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

     

    Workstations use a DHCP from the network and have the DC listed as their first DNS server.

    Syed Khairuddin Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals - I have tried that - didn't work.

     

    A note - All was working fine until another technician installed crystal reports for our accounting system, he rebooted and this is when the trouble started - i have also tried to uninstall crystal but it didnt change anything?

     

    A

     

    Monday, November 08, 2010 6:53 AM
  • Hello,

    first remove the ISPs DNS server 168.210.2.2 from the NIC and use only the domain internal DNS, in your case 10.10.10.10. Also configure the real ip address as DNS on the NIC and not the loopback ip 127.0.0.1.

    After this run ipconfig /flushdns and ipconfig /registerdns and restart the netlgon service or reboot the server.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    • Proposed as answer by KR Anand Saturday, May 11, 2013 11:52 AM
    Monday, November 08, 2010 7:02 AM
  • Did all that now, but dns server service still cant start - fails with Error 1722: The RPC server is unavailable

     

    A

    Monday, November 08, 2010 7:12 AM
  • Here's a dcdiag print:

    C:\Users\Administrator>dcdiag

    Directory Server Diagnosis

    Performing initial setup:
       Trying to find home server...
       Home Server = MegaCube-DC
       * Identified AD Forest.
       Done gathering initial info.

    Doing initial required tests

       Testing server: Default-First-Site-Name\MEGACUBE-DC
          Starting test: Connectivity
             The host 526766f2-a259-4f7b-a68a-4a4fe8aed68f._msdcs.MegaCube.local
             could not be resolved to an IP address. Check the DNS server, DHCP,
             server name, etc.
             ......................... MEGACUBE-DC failed test Connectivity

    Doing primary tests

       Testing server: Default-First-Site-Name\MEGACUBE-DC
          Skipping all tests, because server MEGACUBE-DC is not responding to
          directory service requests.


       Running partition tests on : ForestDnsZones
          Starting test: CheckSDRefDom
             ......................... ForestDnsZones passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... ForestDnsZones passed test
             CrossRefValidation

       Running partition tests on : DomainDnsZones
          Starting test: CheckSDRefDom
             ......................... DomainDnsZones passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... DomainDnsZones passed test
             CrossRefValidation

       Running partition tests on : Schema
          Starting test: CheckSDRefDom
             ......................... Schema passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... Schema passed test CrossRefValidation

       Running partition tests on : Configuration
          Starting test: CheckSDRefDom
             ......................... Configuration passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... Configuration passed test CrossRefValidation

       Running partition tests on : MegaCube
          Starting test: CheckSDRefDom
             ......................... MegaCube passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... MegaCube passed test CrossRefValidation

       Running enterprise tests on : MegaCube.local
          Starting test: LocatorCheck
             ......................... MegaCube.local passed test LocatorCheck
          Starting test: Intersite
             ......................... MegaCube.local passed test Intersite

    Monday, November 08, 2010 7:23 AM
  • Hello,

    please check the following article:

    http://support.microsoft.com/kb/839880

    You installed DNS server during dcpromo i assume, with AD integrated zones? Also check the event viewer for errors and post them complete here.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Monday, November 08, 2010 7:46 AM
  • That is also one of the problems, i cant open event viewer - Service is stooped and times out when you try and start manually...

     

    A

    Monday, November 08, 2010 8:00 AM
  • Hello,

    start the DC in DSRM(F8 during boot) and try to open the event viewer that way.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Monday, November 08, 2010 8:21 AM
  • Hello AntsZA,

    Also check the following files to see if there are older IP address related records.

    C:\windows\system32\drivers\etc\hosts
    C:\windows\system32\drivers\etc\lmhost

    Brent
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, November 08, 2010 8:24 AM
    Moderator
  • I'm not on site atm, so i'll try the event viewr in dsrm when i'm there later this week.

    as for the system32\drivers\etc\...

    There is no wierd entries in there.

     

    lmhost is empty and hosts:

    127.0.0.1       localhost
    ::1             localhost

     

    Any other suggestions would really help

    A

    Monday, November 08, 2010 8:32 AM
  • Hi AntsZA,

    Please collect MPS report and upload it to our workspace below for further research.

    How to collect an MPS report:

    a)     Download the proper MPS Report tool from the website below. Microsoft Product Support Reports http://www.microsoft.com/downloads/details.aspx?FamilyID=CEBF3C7C-7CA5-408F-88B7-F9C79B7306C0&displaylang=en

    b)     Double-click to run it. If the requirement is not met, please follow the wizard to download and install them. After that, click Next, when the "Select the diagnostics you want to run" page appears, select General; Internet and Networking; Business Network; Server Components; click Next.

    c)     After collecting all log files, choose "Save the results". Choose a folder to save the <Computername> MPSReports.cab file.

    For your convenience, I have created a workspace for you.  You can upload the information files to the following link.  (Please choose "Send Files to Microsoft")

    Workspace URL: (https://sftasia.one.microsoft.com/ChooseTransfer.aspx?key=e328cab0-cad0-4490-aaef-e115f0531b59)

    Password: 6#pMuccrvZ

    Note: Due to differences in text formatting with various email clients, the workspace link above may appear to be broken.  Please be sure to include all text between '(' and ')' when typing or copying the workspace link into your browser.

    Brent


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, November 08, 2010 8:42 AM
    Moderator
  • Thanks,

     

    File sent.

     

    A

    Tuesday, November 09, 2010 9:00 AM
  • Hello AntsZA,

    I received it and will give you feedback after researching.

    Brent


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, November 09, 2010 9:41 AM
    Moderator
  • Thanks alot.

     

    A

    Tuesday, November 09, 2010 10:15 AM
  • Hello AntsZA,

    According to the MPS report, I found that the external DNS address might cause the problem. You can refer the following article which can tell you why using a public DNS server for AD doesn't work. You can try to remove the public DNS servers from MegaCube-DC and configure it as "FORWARDERS" on the DNS server properties in the DNS management console. After changing the IP settings run ipconfig /flushdns and ipconfig /registerdns and restart the netlogon service or restart the domain controller.

    Active Directory and Its Reliance on DNS, and using an ISP's DNS address
    http://msmvps.com/blogs/acefekay/archive/2009/08/17/ad-and-its-reliance-on-dns.aspx

    ====================================
    Adapter : Local Area Connection
            Adapter ID . . . . . . . . : {A19E0A70-57AA-4BA9-884B-8C5E09A38F68}
            Netcard queries test . . . : Passed
            Adapter type . . . . . . . : Ethernet
            Host Name. . . . . . . . . : MegaCube-DC
            Description. . . . . . . . : Intel(R) 82575EB Gigabit Network Connection
            Physical Address . . . . . : 00-15-17-EC-25-64
            Dhcp Enabled . . . . . . . : No
            DHCP ClassID . . . . . . . :
            Autoconfiguration Enabled. : Yes
            IP Address . . . . . . . . : 10.10.10.10
            Subnet Mask. . . . . . . . : 255.255.255.0
            Default Gateway. . . . . . : 10.10.10.253
            Dns Servers. . . . . . . . : 10.10.10.10
                                               168.210.2.2

    [WARNING] The DNS entries for this DC are not registered correctly on DNS server '0.0.0.0'. Please wait for 30 minutes for DNS server replication.
    [WARNING] The DNS entries for this DC are not registered correctly on DNS server '10.10.10.10'. Please wait for 30 minutes for DNS server replication.
    [FATAL] No DNS servers have the DNS records for this DC registered.
    ====================================

    Brent


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Wednesday, November 10, 2010 1:42 AM
    Moderator
  • Thanks for the help -

     

    I have tried this, but without the system reboot, but did not work. I have made the changes and will only be able to reboot tonight. Will let you know ... Hope this works.

     

    A

    Thursday, November 11, 2010 8:55 AM
  • Hello AntsZA,

    Does DNS records for this DC register collectly in DNS servers after DC reboot?

    Brent
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, November 12, 2010 3:50 AM
    Moderator
  • Hi AntsZA,

    Did you remove the 168.210.2.2 address as Brent suggested? If you haven't done so, please do so. This is an important step to resolving this.

    Once you've done that, check DNS to see if a record called 526766f2-a259-4f7b-a68a-4a4fe8aed68f._msdcs.MegaCube.local exist in DNS.

    If not, manually create a CNAME for it.

    • Right click _msdcs.megaCube.local,
    • Choose New Alias (CNAME)
    • In the Alias name field, type in 526766f2-a259-4f7b-a68a-4a4fe8aed68f
    • In the FQDN target box, type in MegaCube-DC.MegaCube.local
    • Then run ipconfig /registerdns
    • Restart the netlogon service.
    • If need be, restart the machine.

    Let us know how it works out. Also provide an updated ipconfig /all.

    Regards,
    Ace

     


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

     

     

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    • Edited by Ace Fekay [MCT]MVP Friday, November 12, 2010 7:09 AM clarified how to create the necessary missing _msdcs CNAME for the DC
    Friday, November 12, 2010 7:03 AM
  • Hi -

     

    Thanks for all the help so far, but this did nothing ... I still can start the DNS service, auto or manually.Ace - The main problem as far as i can tell is that i can access the DNS configs because the DNS server doesn't want to start, so i can't create the CNAME record...

     Please see updated ipconfig /all

    C:\Users\Administrator>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : MegaCube-DC
       Primary Dns Suffix  . . . . . . . : MegaCube.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : MegaCube.local

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) 82575EB Gigabit Network Connecti
    on
       Physical Address. . . . . . . . . : 00-15-17-EC-25-64
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::889b:b43b:cacc:c757%10(Preferred)
       IPv4 Address. . . . . . . . . . . : 10.10.10.10(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 10.10.10.253
       DNS Servers . . . . . . . . . . . : ::1
                                           10.10.10.10
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 8:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.{A19E0A70-57AA-4BA9-884B-8C5E09A38
    F68}
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    C:\Users\Administrator>

     

    Regards,

    A

    Friday, November 12, 2010 8:19 AM
  • Don't mean to be rude,

    was there any event log triggered when you attempt to start DNS server manually or any error system failure events during boot up.

    you should have event like 140 in your event log. :http://technet.microsoft.com/en-us/library/dd349625(WS.10).aspx 

    http://technet.microsoft.com/en-us/library/dd391963(WS.10).aspx

    another though:

    have you consider using DNSCMD to reset the dns server setting, assuming you have key in some error setting to it in the initial setup.

    Friday, November 12, 2010 9:32 AM
  • No prob, any help would be good :P

     

    I do get a error when i try to start the DNS server service manually:

    Error 1722: The RPC server is unavilable - Even tho it's running...

    And i cant open the Event viewer either, i get a error when i try to start the Windows Event Log service: it says that it times out - even after a couple of hours the service is stuck on "starting" but doesn't ever start.

    I'm realy lost here?

     

    A

    Friday, November 12, 2010 9:51 AM
  • Ants,

    This is almost sounding like it may be a malware issue. Not sure at this point, but try running the free tool at www.malwarebytes.com just to eliminate this possibility. You can also run the Microsoft MRT:

    The Microsoft Windows Malicious Software Removal Tool helps remove ...Nov 9, 2010 ... Microsoft releases a new version of the tool every month. ...... first open the log file for the cleaner tool (%Windir%\Debug\Mrt.log). ...
    http://support.microsoft.com/kb/890830

    Afterwards, let's try another strategy...

    Do you have another Windows server you can run DNS on? It doesn't have to be a DC. Since this box DNS service is not running, you can use another.

    • Create the MegaCube.local and _msdcs.MegaCube.local zones
    • Delegate the "_msdcs" zone under MegaCube.local to itself
    • Set both zones to allow updates.
    • Set the DNS address on your current DC to this server.
    • Run ipconfig /registerdns
    • Restart the netlogon service
    • Wait about 10 5- 15 minutes, check the zones to see if the SRV and other records populated
    • Also check the Event log on the DC.

    Also, is there any AV or security software installed on the DC? You may want to uninstall them at this point to help towards diagnosing and fixing this thing.

    Ace


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

     

     

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    Friday, November 12, 2010 2:37 PM
  • Hi,

    This is solved my problem.

    Thanks

    Saturday, May 11, 2013 11:53 AM