Windows Server 2008 R2 Rdp Connection Issue RRS feed

  • General discussion

  • hello,

    first of all some specs:

    HP Server

    Windows Server 2008 R2 SP1 with HP Tools installed, no anitvirus, no firewall

    We've get some troubles to connect to the server via rdp after remove nic teaming from hp networkmanagment tools.

    after configure the single nic we cant connect to the server.

    rdp is active to accept connection, i tired to deactivate and activate again, same problem no connect

    show via cmd qwinsta the rdp-tcp listener is in ther

    show via cmd netstat-aon, but there is no listening port on 3389

    I know that's the problem, but how can i fix this that the rdp-tcp listener makes a listening port?!


    i will be happy when anybody can help me!




    • Changed type Bruce-Liu Monday, July 11, 2011 9:51 AM
    Friday, June 17, 2011 8:15 AM

All replies

  • Can you verify on this machine in registry that default RDP port wasn't modified, please?

    Open regedit on that server and go to


    and check entry named "PortNumber"

    is it 3389 (default) or modified? If it's changed you can set it up as the old value (value is entered in HEX mode, you need to change it to DEC) and reboot server. Then check if you hav a connection.

    Regards, Krzysztof
    Friday, June 17, 2011 8:23 AM
  • no it's 3389, but i've tried to change to 3390 but still the same problem, when i want to connect to 3390.. then i set it back to 3389 and after reboot no connection and no listening port 
    Friday, June 17, 2011 8:37 AM
  • Hm, can you try to re-registere RDP dll from command-line

    regsvr32 remotepg.dll

    if this doesn't solve problem, extract "termdd.sys" file from %WINDIR%\Driver Cache\i386\sp*.cab where * is the latest version of that file

    Then copy this extracted file to %WINDIR%\SYSTEM32\DRIVERS and reboot server.

    Additionally please check if you have no errors in event log.

    Similar problem was discussed on

    You may wish to read it.

    Regards, Krzysztof
    Friday, June 17, 2011 8:51 AM
  • regsvr32 remotepg.dll, no change


    %WINDIR%\Driver Cache\i386\sp*.cab where *   can't find folder and/or cab on the 2k8 server


    and in the eventlog there are no errors...


    and this file termdd.sys is in %windir%\system32\drivers\

    i only found also termdd.sys @ C:\Windows\System32\DriverStore\FileRepository\machine.inf_amd64_neutral_a2f120466549d68b

    but i can't copy to %windir%\system32\drivers\ access denied

    now i've been able to copy the termdd.sys, but after reboot the problem still exists
    Friday, June 17, 2011 9:32 AM
  • Just a test : Stop/restart the Spooler service and check if port 3389 starts listening?
    Please remember to click “Mark as Answer” on the post that helps you. This can be beneficial to other community members reading the thread.
    Sunday, June 19, 2011 11:57 AM