none
Add Roles - The specified package is not valid Windows package. Error: 0x800f0805 - Windows Server 2012 RRS feed

  • Question

  • Hello. We have a Server with Windows Server 2012, which we need to install the FTP Server Feature.
    Well ... For both the Graphical Interface and PowerShell, we have the same error ...
    Remember that by PowerShell we tried to install in the following ways:
    Install-WindowsFeature Web-FTP-Server
    DISM / Online / Enable-Feature / FeatureName: Web-FTP-Server / All
    DISM / Online / Enable-Feature / FeatureName: Web-FTP-Server / All / LimitAccess / Source: E: \ sources \ sxs



    And in all of them, the error is:
    The specified package is not valid Windows package. Error: 0x800f0805

    What we have tried to do:
    PS C: \ Users \ Administrator> sfc / scannow
    Beginning system scan. This process will take some time.
    Beginning verification phase of system scan.
    Verification 100% complete.
    Windows Resource Protection did not find any integrity violations.

    PS C: \ Users \ Administrator> Dism / Online / Cleanup-Image / ScanHealth
    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384
    Image Version: 6.2.9200.16384
    [========================== 100.0% ===================== =====]
    No component store corruption detected.
    The operation completed successfully.

    PS C: \ Users \ Administrator> Dism / Online / Cleanup-Image / CheckHealth
    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384
    Image Version: 6.2.9200.16384
    No component store corruption detected.
    The operation completed successfully.

    PS C: \ Users \ Administrator> Dism / Online / Cleanup-Image / RestoreHealth / Source: E: \ sources
    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384
    Image Version: 6.2.9200.16384
    [========================== 100.0% ===================== =====]
    The restore operation completed successfully. The component store corruption was repaired.

    PS C: \ Users \ Administrator> Dism / Online / Cleanup-Image / RestoreHealth / Source: E: \ sources \ sxs
    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384
    Image Version: 6.2.9200.16384
    [========================== 100.0% ===================== =====]
    The restore operation completed successfully. The component store corruption was repaired.

    PS C: \ Users \ Administrator> Dism / Online / Cleanup-Image / RestoreHealth /Source:E:\sources\Install.wim
    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384
    Image Version: 6.2.9200.16384
    [========================== 100.0% ===================== =====]
    The restore operation completed successfully. The component store corruption was repaired.


    Errors I saw in DISM.log and CBS.log:

    DISM.log
    Failed to load the provider: C: \ Users \ ADMINI ~ 1 \ AppData \ Local \ Temp \ 3 \ 3246DA5A-44D4-474D-A2B6-61B03EFBC148 \ PEProvider.dll. - CDISMProviderStore :: Internal_GetProvider (hr: 0x8007007e)
    Failed to get and initialize the PE Provider. Continuing by assuming that it is not a WinPE image. - CDISMProviderStore :: Final_OnConnect
    Failed to load the provider: C: \ Users \ ADMINI ~ 1 \ AppData \ Local \ Temp \ 3 \ 3246DA5A-44D4-474D-A2B6-61B03EFBC148 \ IBSProvider.dll. - CDISMProviderStore :: Internal_GetProvider (hr: 0x8007007e)
    Failed to get the IDismObject Interface - CDISMProviderStore :: Internal_LoadProvider (hr: 0x80004002)
    Failed to load the provider: C: \ Users \ ADMINI ~ 1 \ AppData \ Local \ Temp \ 3 \ 3246DA5A-44D4-474D-A2B6-61B03EFBC148 \ Wow64provider.dll. - CDISMProviderStore :: Internal_GetProvider (hr: 0x80004002)
    Failed to load the provider: C: \ Users \ ADMINI ~ 1 \ AppData \ Local \ Temp \ 3 \ 3246DA5A-44D4-474D-A2B6-61B03EFBC148 \ EmbeddedProvider.dll. - CDISMProviderStore :: Internal_GetProvider (hr: 0x8007007e)
    Failed opening package @Foundation. - CDISMPackageManager :: Internal_CreatePackageByName (hr: 0x800f0805)
    Failed to get the underlying cbs package. - CDISMPackageManager :: OpenPackageByName (hr: 0x800f0805)
    The specified package is not valid Windows package. - GetCbsErrorMsg
    Failed to open the Foundation package. - CDISMPackageManager :: OpenFoundationPackage (hr: 0x800f0805)
    The specified package is not valid Windows package. - GetCbsErrorMsg
    Failed to open the Windows Foundation Package as a fall back. - CPackageManagerCLIHandler :: Private_ProcessFeatureChange (hr: 0x800f0805)
    Failed while processing command enable-feature. - CPackageManagerCLIHandler :: ExecuteCmdLine (hr: 0x800f0805)

    CBS.log
    IT: --- Initializing Trusted Installer ---
    IT: Last boot time: 2019-07-09 18:55: 49,868
    Starting TrustedInstaller initialization.
    Ending TrustedInstaller initialization.
    Starting the TrustedInstaller main loop.
    TrustedInstaller service starts successfully.
    In startup processing required, TrustedInstaller service was not set as autostart
    Startup processing thread terminated normally
    Starting TiWorker initialization.
    Ending TiWorker initialization.
    Starting the TiWorker main loop.
    TiWorker starts successfully.
    Universal Time is: 2019-07-10 18: 04: 02.278
    Failed to find a matching version for servicing stack: C: \ Windows \ winsxs \ amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.2.9200.21913_none_62fd475869f47e9b [HRESULT = 0x80070490 - ERROR_NOT_FOUND]

    offline servicing, using stack version from: C: \ Windows \ winsxs \ amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.2.9200.21913_none_62fd475869f47e9b \ cbscore.dll
    Loaded Servicing Stack v6.2.9200.21913 with Core: C: \ Windows \ winsxs \ amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.2.9200.21913_none_62fd475869f47e9b \ cbscore.dll
    00000001 @ 2019/7/10: 18: 04: 02.358 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @ 0x7f8da496389 @ 0x7f8daa898ca @ 0x7f8daa44de4 @ 0x7f6122ed1df @ 0x7f6122ed95c @ 0x7f8f3871b15)
    Could not load SrClient DLL from path: SrClient.dll. Continuing without system restore points.
    00000002 @ 2019/7/10: 18: 04: 02.436 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @ 0x7f8da496389 @ 0x7f8daae6258 @ 0x7f8daaa7729 @ 0x7f8daa44f57 @ 0x7f6122ed1df @ 0x7f6122ed95c)
    NonStart: Set pending store consistency check.
    Session: 30750537_3674927684 initialized by client DISM Package Manager Provider.
    Not able to find an installed package from moniker: @Foundation [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]
    Failed to resolve package from moniker [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]
    Failed to OpenPackage using worker session [HRESULT = 0x800f0805]


    Would anyone have any idea how to solve the problem?

    Thankful.

    Thanks for the comprehension.

    Wednesday, July 10, 2019 6:18 PM

All replies

  • Hi,

    As you are using "DISM / Online / Enable-Feature / FeatureName: Web-FTP-Server / All / LimitAccess / Source: E: \ sources \ sxs"

    So make sure the feature package exits in sources folder at first.

    Try to add features with DISM by referring the link and check the issue again.

    http://blogs.technet.com/b/joscon/archive/2010/08/26/adding-features-with-dism.aspx

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Joy-Qiao Thursday, July 11, 2019 3:01 AM
    Thursday, July 11, 2019 2:46 AM
  • Hi. Yes, the Feature Package exists in Source. I gave a Dism / Image: C:\test\offline /Get-Features after mounting the image and the available Feature appeared.

    I have already tried installing the FTP Server in all the ways that DISM has. I used as a base:
    https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/enable-or-disable-windows-features-using-dism

    https://systemscenter.ru/waik.en/html/cd254ef0-ad4f-4d6f-8ea1-48a8b378a1b8.htm

    Do you have any ideas?

    Thank you

    Thursday, July 11, 2019 1:53 PM
  • Hi,

    Try to install the latest update package KB 4507464 from Windows update catalog to check if the services available to added.

    https://www.catalog.update.microsoft.com/Search.aspx?q=4507464

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 12, 2019 6:40 AM
  • You are advising that the update can not be applied. See screenshot below

    Friday, July 12, 2019 2:45 PM
  • Hi,

    Please run command "winver" to check the existing system build number.

    Also, please make sure you have installed the latest SSU (KB4504418) on your system. If not, download the SSU from Windows update catalog and then install KB4507464 to check again.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Saturday, July 13, 2019 11:15 AM
  • You are again advising that the update can not be applied. See screenshot below.
    Monday, July 15, 2019 5:02 PM
  • Hi,

    Thank you for your reply.

    If we have installed those update package, it will not applicable to your computer. We could use command line "wmic qfe list" as administrator to get the installed update package.

    Please also check if any related error message occur in Event Viewer\Windows logs\setup, system.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Joy-Qiao Sunday, July 21, 2019 2:35 PM
    Sunday, July 21, 2019 2:33 PM
  • After execute:

    C:\Windows\system32>wmic qfe list
    No Instance(s) Available.

    In Event Viewer i noticed several different Kb's entries with this same message

    "Initiating changes for package KBxxxxxxx. Current state is Absent. Target state is Absent. Client id: CbsTask."

    Monday, July 22, 2019 5:00 PM
  • Hi, 

    The event log shows installed package is not exist on system. Read again about your issue, I recommend to repair component store of your system with the link below:

    https://docs.microsoft.com/en-us/windows/deployment/update/windows-update-resources

    Also, try to check the following steps:

    Run System Update Readiness Tool .

    Disable firewall and antivirus temporarily.

    Perform a Clean Boot  and manually update again.

    Bests, 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Joy-Qiao Monday, July 29, 2019 1:43 AM
    Thursday, July 25, 2019 11:36 AM
  • Hi,
     
    Haven't received your message a few days, was your issue resolved?
    I am proposing previous helpful replies as "Answered". Please feel free to try it and let me know the result.
    If the reply is helpful, please remember to mark it as answer which can help other community members who have same questions and find the helpful reply quickly.
    Bests,

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 29, 2019 1:43 AM
  • I didn't solve it. I did everything, but the error persisted.
    I then installed a new server and transferred to it the services that were running on the one with the problem.
    • Proposed as answer by Joy-Qiao Tuesday, July 30, 2019 1:00 PM
    Monday, July 29, 2019 9:41 PM
  • Hi,

    Thank you for your feedback.

    Your transfer action might be a good idea, and it would be very useful for other customers.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 30, 2019 1:00 PM