Server 2012 R2 Setup does not recognise that ADPREP /FORESTPREP and /DOMAINPREP has been run on a BDC


  • I have done an in-place upgrade of the PDC emulator on my domain from Windows Server 2008 R2 to Windows Server 2012 R2. I ran ADPREP /FORESTPREP and /DOMAINPREP on the PDC before I started (with the BDC up and running) and there was no issue with the upgrade. The ADPREP verification returned no errors.

    Moving on to the BDC (also Windows Server 2008 R2) and I got the ADPREP needs to be run error ( I thought I might try running ADPREP on the BDC, but ADPREP said it had already been run and there was nothing to do.

    So, I shutdown the PDC emulator and tried the upgrade on the BDC again and got a different error "Setup cannot determine if Windows Server 2012 R2 ADPREP ... exists on this domain controller" ( I think this one is a symptom of the BDC not being able to contact the PDC, so is probably a red herring.

    Given that the AD schema is in place on the BDC I'm at a loss as to why the installer is not identifying it. Any help would be handy.

    • Edited by Warren T Void Tuesday, November 05, 2013 10:46 AM Error correction.
    Tuesday, November 05, 2013 7:08 AM

All replies

  • BDCs don't exist in Active Directory - those were for NT.   Active Directory employs a multi-master replication capability, so there is not a hierarchy that a BDC implies.

    You point to an article about updating from a 2000 or 2003 AD. is the article to upgrade from 2008 to 2012.  So, did you use the adprep from the 2012 media or from the 2008 media?  Are you sure all your FSMO roles were on the server on which you ran adprep, as it needs to be run on the DC hosting specific FSMO roles for different upgrades.

    .:|:.:|:. tim

    Tuesday, November 05, 2013 9:56 PM
  • Yeh, OK. I'm old. Sue me. PDC and BDC still works for me.

    The article references I included above are embedded in the error messages from the 2012 R2 installer. I wasn't using them as references for the upgrade.

    The PDC emulator was upgraded with all FSMO roles assigned to it.

    ADPREP I used was on the 2012 R2 DVD. On the PDC emulator ADPREP made a significant number of AD schema changes for both the forest and domain. These were propagated to the secondary as evidenced by the fact that ADPREP found nothing to do and the verification returned no errors.

    Tuesday, November 05, 2013 10:44 PM
    • Proposed as answer by Yan Li_Moderator Thursday, November 07, 2013 1:18 AM
    • Unproposed as answer by Warren T Void Thursday, November 07, 2013 2:55 AM
    Tuesday, November 05, 2013 11:32 PM
  • Well, if it is supposed to or not, and I suspect not, it didn't run automatically. The installer stopped with instructions to run ADPREP manually because I had not run ADPREP before starting the in-place upgrade on the master.

    Whether or not ADPREP runs automatically is not relevant to this problem. The problem is that ADPREP is happy with the schema on the secondary DC but the installer is not recognising that the AD schema is current.

    Wednesday, November 06, 2013 12:04 AM
  • Hi,

    You can query Active Directory to determine the schema version as shown below.  Replace “dc=domainname” with your information:


    dsquery * cn=schema,cn=configuration,dc=domainname,dc=local -scope base -attr objectVersion


    The PowerShell version below does not require any customization:

    Get-ADObject (get-adrootdse).schemaNamingContext -Property objectVersion


    The table below shows Active Directory schema versions.

    Windows 2000 Server 13
    Windows 2003 RTM, SP1, SP2 30
    Windows 2003 R2 31
    Windows 2008 44
    Windows 2008 R2 47
    Windows Server 2012 Beta 52
    Windows Server 2012 56
     Windows Server 2012 R2


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, November 07, 2013 1:42 AM
  • Thanks Yan Li,

    This is a useful step along the way, but it is not the answer. Using your information I have been able to determine that the operations master is running version 69, while the secondary is still running version 47. So although the two servers were happily synchronising before I ran ADPREP from the Windows Server 2012 R2 installation DVD on the master and although no errors were reported, the schema on the secondary was not updated.

    Now when I run ADPREP from the installation DVD on the secondary, it claims that the schema is current so the secondary can't be updated locally either. It does no good trying to update the secondary with the master turned off because ADPREP won't proceed due to an inability to contact the master.

    I can't run dcpromo on the secondary to take it out of the picture and upgrade it due to the schema mismatch, so I think I'm probably going to have to force remove it from the domain and rebuild it.

    At the moment the secondary is simply turned off since it can't contribute anything useful.


    Tuesday, November 19, 2013 3:33 AM