none
Shutdown event tracker keeps appearing after installing KB4490481 and an unexpected shutdown RRS feed

  • Question

  • After an unexpected shutdown the shutdown event tracker keeps appearing after a logon, even when a reason was provided.

    This occurs after installing KB4490481 (April 2, 2019) for Windows Server 2019

    Does anyone else suffer from this?

    Tuesday, April 9, 2019 10:23 AM

All replies

  • Hi,

    KB 4490481 has been replaced by KB 4493509. Please update windows server 2019 to KB4493509. Then check the issue again.

    If the issue persists, you could uninstall the KB4490481 or disable the shutdown event tracker.

    Disable Display Shutdown Event Tracker for user login only?

    https://social.technet.microsoft.com/Forums/en-US/4a7ca9d1-ebb7-48a1-b8b3-b4a4c911fc5c/disable-display-shutdown-event-tracker-for-user-login-only?forum=winservergen

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 11, 2019 4:50 PM
    Moderator
  • Issue still persist in KB 4493509

    Unexpected shutdown notification is no longer appearing after the following setting using a GPO:
    Computer Configuration > Administrative Templates > System > "Display Shutdown Event Tracker" = Disabled

    This setting will disable the shutdown tracking for a system for expected and unexpected shutdowns.

    Friday, April 12, 2019 8:56 AM
  • Thanks for sharing us.

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 6, 2019 2:57 PM
    Moderator
  • Got the same issue on all of my VMs apart from my second DC. Hopefully they'll resolve this soon as I don't want to disable the shutdown event tracker completely in case it is actually an unexpected shutdown.

    Bizarrely for me this doesn't even appear just after reboots but also whenever I log onto an affected server

    Saturday, May 18, 2019 10:45 AM
  • Same issue here as well.  I do not have that particular KB installed, but I am on Windows Server 2019 Datacenter (17763.503).  Maybe just that the issue is also in a different cumulative update?

    Find this post helpful? Does this post answer your question? Be sure to mark it appropriately to help others find answers to their searches.

    Sunday, May 19, 2019 1:21 PM
  • We are having this issue, too. We are using Windows Server 2019 Standard (.437).

    To my knowledge, we are not seeing it on Windows Server 2016 Standard.

    Friday, May 24, 2019 5:32 PM
  • Yes same issue for us on Server 2019.
    Monday, May 27, 2019 3:53 AM
  • Yes same issue for us on Server 2019.
    Same issue here on Server 2019 Standard (10.0.17763.503).
    Friday, May 31, 2019 8:25 AM
  • I had this problem, the solution is to clear all the values (like DirtyShutdown, LastAliveStamp, TimeStampInterval) in the following registry key:

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Reliability

    At the next reboot the problem should not be popping up, unless there is another dirty shut down.

    Monday, June 3, 2019 9:36 AM
  • So point of clarification.  When you say "Clear all values", Do you mean delete the "DirtyShutdown" etc. entirely or just the values of them like setting 1 to 0?

    Find this post helpful? Does this post answer your question? Be sure to mark it appropriately to help others find answers to their searches.

    Thursday, June 27, 2019 1:56 PM
  • You can safely delete all the values mentioned, for example, my system has the following values, DirtyShutdown, DirtyShutdownTime, LastAliveStamp, TimeStampInterval, LastComputerName

    They will be recreated as needed. You can make a backup of the registry entry if you want.

    • Proposed as answer by mlavie58 Saturday, July 6, 2019 5:28 PM
    Thursday, June 27, 2019 2:16 PM
  • I did create a backup export for the registry key.  I tested with just removing the "DirtyShutdown" and "DirtyShutdownTime" and that worked, no message on reboot.  I did not do the others including "LastAliveStamp", as the value was the same on bad computer as it was on good computer.  

    Find this post helpful? Does this post answer your question? Be sure to mark it appropriately to help others find answers to their searches.

    Thursday, June 27, 2019 2:23 PM
  • This worked for us as well. Ours was popping up anytime you would log in to the server too not just after restarts.
    • Edited by torrybis Thursday, June 27, 2019 3:20 PM
    Thursday, June 27, 2019 3:06 PM
  • Thank you! I had a Hper-V host crash a month or so back, and since then everytime i logged into that host and any VMs that were o that host at the time have been repeatedly showing this..

    Works a treat!

    Craig Wilson

    Blog: https://blog.gattancha.co.uk

    Friday, July 5, 2019 7:17 AM
  • @Alexandru Lapugean

    Thanks! This was driving me CRAZY!

    mlavie

    Saturday, July 6, 2019 5:29 PM
  • The message disappears if you logon to the server with the predefined local Administrator account (SID 500) and answer the message.
    • Proposed as answer by pob579 Friday, September 6, 2019 11:55 AM
    Friday, August 16, 2019 9:41 AM
  • It would help if you read the initial issue...
    Thursday, August 22, 2019 6:41 PM
  • Maybe my answer was to short.

    I had the same issue. While searching for a solution I found this thread.

    The message box what requests the reason for a system crash appeared again and again, even if I answered it as Domain Admin. This is a sign that there is something wrong with the permissions to write in the system. Maybe the patch in question changed something in the behavior of admin accounts.

    It seems that only the predefined administrator account has the permission to write the answer to this message box in the system.

    If you meant, the original question was only who had the same issue, ok, in this case my answer had should be only "me too". ;)

    Friday, August 23, 2019 7:19 AM
  • Dear Ms. Barbara,

    your solution is just simply perfect!

    Thanks.


    --- When you hit a wrong note its the next note that makes it good or bad. --- Miles Davis

    Friday, September 6, 2019 11:56 AM
  • This seems to be an issue specific to Windows Server 2019 with the registry permissions for the Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Reliability key.

    After examining the permissions for that registry key on both Windows Server 2016 and Windows Server 2019, I see that Server 2016 gives full control to our DomainName\Administrators group, whereas Server 2019 only gives full control to that server's LocalServerName\Administrators group.

    This explains why only the local Administrator account on Server 2019 has the ability to set the DirtyShutdown value to 0.

    Hopefully Microsoft can fix this with an update, as I'd hate to manually have to adjust this value across multiple servers every time a dirty shutdown occurs.

    Saturday, September 7, 2019 10:31 PM
  • Barbara mentioned this thing...

    --- When you hit a wrong note its the next note that makes it good or bad. --- Miles Davis

    Monday, September 9, 2019 11:14 AM
  • Yes, but now we need in detail, where the problem is. The question is, it's a bug or a feature.
    Monday, September 9, 2019 11:27 AM
  • "The question is, it's a bug or a feature"

    OK, coming from Microsoft... that's too funny

    Wednesday, September 25, 2019 2:45 PM
  • Yes same issue for us on Server 2019.
    Monday, October 7, 2019 4:48 PM
  • I had this problem, the solution is to clear all the values (like DirtyShutdown, LastAliveStamp, TimeStampInterval) in the following registry key:

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Reliability

    At the next reboot the problem should not be popping up, unless there is another dirty shut down.

    Thank you. That was driving me barmy, it was even coming up for end users on an RDS deployment regardless of the Group Policy Setting to disable it.

    Happened with every login too, rather than an actual shutdown/reboot event. 

    • Edited by Duke McAwesome Wednesday, October 9, 2019 2:28 PM some words
    Wednesday, October 9, 2019 2:27 PM