none
windows.edb file size is too large

    Question

  • Hi,

        "windows.edb" file size is too large in Windows Server 2003. Please suggest some ways to delete or shrink the size of the file. It is located in "C:\Documents and Settings\All Users\Application Data\Microsoft\Search\Data\Applications\Windows".

         I think, its because of windows desktop search. Please help.

    Tuesday, June 14, 2011 5:13 AM

Answers

  • you can try: From the Indexing Options Control Panel, click Advanced, and then under Index location, clickS elect new. (assuming you have windows search installed on the machine)

    • Marked as answer by geek_jumper Monday, June 20, 2011 8:31 AM
    Tuesday, June 14, 2011 6:49 AM

All replies

  • you can try: From the Indexing Options Control Panel, click Advanced, and then under Index location, clickS elect new. (assuming you have windows search installed on the machine)

    • Marked as answer by geek_jumper Monday, June 20, 2011 8:31 AM
    Tuesday, June 14, 2011 6:49 AM
  • Hi,

     

    It is the Windows Desktop Search making this database file (Windows.edb). It is created after indexing the folders you searched in and used to speed up the local searches.

     

    You can refer to FZB’s suggestion to change the location where the index is stored. If you would like to delete this file on C drive, please turn off the indexing service first.

     

    Hope this helps.

     

    Regards,

    Bruce


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, June 15, 2011 7:39 AM
  • Note that disabling the indexing service can cause problems, like not finding mail in outlook search, and not finding files in the search charm of windows 8.

    If you have a 2nd drive and don't like the size on your C: drive, then moving the index database location might be a good solution.  Normally windows.edb is about 1-2GB per 100K items indexed.  I'm assuming that if people have that much stuff to index, they probably have a big enough place to stick the file. 


    Shawn

    Thursday, May 2, 2013 3:15 AM
  • wrong assumption: my HDD is 240GB and my index is now 45GB ... 
    Monday, August 11, 2014 3:40 PM
  • Microsoft has a fix for this problem

    http://support2.microsoft.com/kb/2838018

    To resolve this issue, install update rollup 2836988 for Windows 8 and Windows Server 2012. For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
    2836988 Windows 8 and Windows Server 2012 update rollup: May 2013

    Note This update is preventative, but not corrective. To reduce the size of a Windows.edb file that is already affected by this issue, you must rebuild the search index after you install this update.


    Wednesday, October 1, 2014 4:21 PM