none
Home Page URL GPO not applying until policy refresh RRS feed

  • Question

  • Hello all,

    I am having a problem where clients aren't displaying the home page that I am specifying in a GPO. The clients have IE 9 and I am setting the home page using the "Home page URL" setting in URLs/Important URLs in user configuration. I have two GPOs that specify this setting and it is working in one of them but not in the other, and I'm not certain why it isn't working.

    If I do a "gpupdate /force" after logging in, the home page changes to the one that I've specified. Furthermore, the home page setting then works correctly for the same user on subsequent reboots: if I change the home page, it's changed back on reboot. I thought that perhaps there was some sort of delay in processing occurring when I log in (synchronous vs asynchronous processing), so I enabled "always wait for the network at computer startup and login," but that did not resolve the problem.

    Gpresult indicates that the GPO is applied. RSOP also shows that the specific policy is enabled and set to proper home page. Furthermore, other IE policies such as Favorites and Links apply successfully.

    Since the Home Page URL setting is working ok in one GPO but not the other I thought that perhaps another setting or policy might be overriding it, but I can't see anything that would be causing a conflict. Does anyone have any ideas as to what might be going on? Thanks!

    Thursday, November 10, 2011 7:05 PM

Answers

  • Hi,

    One GPO is working fine, do you mean that the GPO applied with no issue, another GPO only apply after refreshing?

    I would like to confirm that whether the homepage overwriting the homepage you set  is the Initial IE branding homepage. If so, please disable external branding via GPO. Initial IE branding was overwriting policy values, when the profile was created. Enabling NoExternalBranding stops the initial branding, setting the policy configurations in the first logon.

    User Configuration\Administrative Templates\Windows Components\Internet Explorer \Disable external branding of Internet Explorer

    Please also try the workaround, the best thing would be to deploy via GPP create a registry key that update:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    “Start Page”=” http://microsoft.com

    Best Regards,

    Yan Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by bshwjt Friday, November 11, 2011 6:55 AM
    • Marked as answer by patissiere Friday, November 11, 2011 5:55 PM
    Friday, November 11, 2011 5:35 AM
    Moderator

All replies

  • Hi,

    One GPO is working fine, do you mean that the GPO applied with no issue, another GPO only apply after refreshing?

    I would like to confirm that whether the homepage overwriting the homepage you set  is the Initial IE branding homepage. If so, please disable external branding via GPO. Initial IE branding was overwriting policy values, when the profile was created. Enabling NoExternalBranding stops the initial branding, setting the policy configurations in the first logon.

    User Configuration\Administrative Templates\Windows Components\Internet Explorer \Disable external branding of Internet Explorer

    Please also try the workaround, the best thing would be to deploy via GPP create a registry key that update:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    “Start Page”=” http://microsoft.com

    Best Regards,

    Yan Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by bshwjt Friday, November 11, 2011 6:55 AM
    • Marked as answer by patissiere Friday, November 11, 2011 5:55 PM
    Friday, November 11, 2011 5:35 AM
    Moderator
  • Thank you; that did the trick. I had disabled first run customization, but didn't know about branding and how it worked. I appreciate your help!
    Friday, November 11, 2011 5:58 PM
  • You are welcome, I am glad the information could help you with the issue.

    Have a nice day!

    Best Regards,

    Yan Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, November 14, 2011 1:04 AM
    Moderator