none
Can Not Find An Accelerated OpenGL Mode RRS feed

  • Question

  • I have a Hyper-V VM running Windows 8 that I use to test games on, but when I open the game I get an error saying that it can't find an accelerated OpenGL mode. I tried using the RemoteFX 3D Video Adapter feature, and even upgrading from Windows Server 2008 to 2012. I tried running it outside the VM on the server and it worked but it will not work in the VM. Is there a way to fix this?
    Saturday, September 8, 2012 6:49 PM

Answers

  • Hi,

    The RemoteFX 3D video adapter enables 3D capabilities to a user connecting by using Remote Desktop Connection (RDC). A RemoteFX 3D video adapter can be added as a device to a virtual machine, which provides a Windows Display Driver Model (WDDM) driver with support for DirectX 9.0c.

    http://technet.microsoft.com/en-us/library/ff830364.aspx

    Based on my research, RemoteFX has poor support for OpenGL. Microsoft has some criticisms for nVidia and AMD here but also freely admits in the same video that the lack of OpenGL support boils down to the virtual graphics driver Microsoft chose to write for RemoteFX. DirectX 9.0c applications should theoretically work in RemoteFX. With some caveats; Microsoft doesn’t consider things like video games or AutoCAD to be “primary use cases” for RemoteFX. It was designed specifically to offer “the full Windows experience” over a remote connection.

    Best regards,

    Monday, September 10, 2012 4:12 AM
    Moderator