none
SearchOCR.ADMX error after installing Win10-1803 ADMX templates

    General discussion

  • I've already submitted this to MSFT via Feedback and resolved my issue for now, so this is basically informational for anybody coming across the same thing and searching for a resolution.

    After installing the Win10-1803 GPO Templates, I'm presented with the below error:

    Resource '$(string.Win7Only)' referenced in attribute displayName could not be found. File \\SysVol\...\Policies\PolicyDefinitions\SearchOCR.admx, line 12, column 69

    I searched the folder on my PC where the files were installed. There's no SearchOCR.admx file in the new download, but there is an ADML file. After reinstalling the old and new ADML files, I found that the old file has a line for Win7Only, where the new one doesn't.

    After reverting to the Win10-1511 SearchOCR template files, it's working normally again.

    Monday, May 7, 2018 2:51 PM

All replies

  • I am having this issue as well. I still have the SearchOCR.admx from 11/14/2015 in my PolicyDefinitions folder. The .adml file in en-us was updated in 5/3/2018 version though. I reverted to 1511 and error fixed for now. Thanks.

    Brian Hoyt

    Monday, May 7, 2018 5:59 PM
  • In German Version too:

    Die in der Eigenschaft "$(string.Win7Only)" aufgeführte Ressource displayName konnte nicht gefunden werden. Datei \\........\SearchOCR.admx, Zeile 12, Spalte 69

    I removed "SearchOCR.admx" from \PolicyDefinitions for now
    • Edited by tidoo Tuesday, May 8, 2018 7:25 AM
    Tuesday, May 8, 2018 7:18 AM
  • I have this too. Previous 1709 has no such file name as SearchOCR.admx.

    MCSE Mobility 2018. Expert on SCCM, Windows 10 and MBAM.


    • Edited by yannara Tuesday, May 8, 2018 10:05 AM
    Tuesday, May 8, 2018 10:02 AM
  • Experiencing the same issue here too. As OP mentioned, reverting to 1511 version of SearchOCR files gets rid of the error.
    Tuesday, May 8, 2018 12:03 PM
  • Same here,

    reverted to previous version of the template.

    Tuesday, May 8, 2018 1:50 PM
  • I manually edited the "...\en-US\searchocr.amdl" file and added the value from the previous version.  Search for these lines about line 25 (if you are not wrapping lines):

          <string id="OCR">OCR</string>
          <string id="OCREveryPage">Force TIFF IFilter to perform OCR for every page in a TIFF document</string>

    then add the line given below between them:  

          <string id="OCR">OCR</string>
          <string id="Win7Only">Microsoft Windows 7 or later</string>
          <string id="OCREveryPage">Force TIFF IFilter to perform OCR for every page in a TIFF document</string>

    ...and no more errors!  I am no expert so I don't know if this could cause any issue , but I don't think so as it is just to localize the variables into the language of choice.


    Find this post helpful? Does this post answer your question? Be sure to mark it appropriately to help others find answers to their searches.

    Tuesday, May 8, 2018 6:45 PM
  • I manually edited the "...\en-US\searchocr.amdl" file and added the value from the previous version.  Search for these lines about line 25 (if you are not wrapping lines):

          <string id="OCR">OCR</string>
          <string id="OCREveryPage">Force TIFF IFilter to perform OCR for every page in a TIFF document</string>

    then add the line given below between them:  

          <string id="OCR">OCR</string>
          <string id="Win7Only">Microsoft Windows 7 or later</string>
          <string id="OCREveryPage">Force TIFF IFilter to perform OCR for every page in a TIFF document</string>

    ...and no more errors!  I am no expert so I don't know if this could cause any issue , but I don't think so as it is just to localize the variables into the language of choice.


    Find this post helpful? Does this post answer your question? Be sure to mark it appropriately to help others find answers to their searches.

    Good find.

    Fixed the issue for me as well. :)

    Wednesday, May 9, 2018 12:33 AM
  • Good one, it fixed my issue. In addition, I'm getting <g class="gr_ gr_190 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins replaceWithoutSep" data-gr-id="190" id="190" style="background-animation:gr__appear_critical 0.4s forwards;color:#000000;text-transform:none;text-indent:0px;letter-spacing:normal;font-family:Verdana, Geneva, sans-serif;font-size:12px;font-style:normal;font-weight:400;word-spacing:0px;border-bottom-color:transparent;border-bottom-width:2px;border-bottom-style:solid;display:inline;white-space:normal;orphans:2;widows:2;background-image:url("data;base64,phn2zyb4bwxucz0nahr0cdovl3d3dy53my5vcmcvmjawmc9zdmcnihdpzhropscxmdaljybozwlnahq9jzewmcunpgogidxsaw5lig9wywnpdhk9jzaunzunihgxpsc0jyb5mt0nmtawjscgedi9jzewmcunihkypscxmdaljyb0cmfuc2zvcm09j3ryyw5zbgf0zsgtms41lcatmi41kscgc3ryb2tllxdpzhropsczjybzdhjva2utbgluzwnhcd0ncm91bmqnihn0cm9rzt0ni2zjntq1nccvpgo8l3n2zz4k"):;background-repeat:no-repeat;background-size:calc(100% + 1px) 100%;background-color:#ffffff;font-variant-ligatures:normal;font-variant-caps:normal;-webkit-text-stroke-width:0px;text-decoration-style:initial;text-decoration-color:initial;">couple</g> of other errors too, still trying to figure it out, any help much appreciated

    1. Policy element 'AutoUpdateSchEveryWeek', referenced in presentation 'AutoUpdateCfg' could not be Found

    2. Policy element 'Lbl_GhostPreference_Enum', referenced in presentation 'Pol_EnableWorkFolder' could not be found

    Wednesday, May 9, 2018 3:47 AM
  • Thanks!
    Wednesday, May 9, 2018 2:21 PM
  • Glad it is helping you guys.  Please don't forget to mark helpful and/or as answer if applicable.  ;-)

    @Karths16, sorry I don't have any idea how to help with that one.  May need to start another thread to get attention. 


    Find this post helpful? Does this post answer your question? Be sure to mark it appropriately to help others find answers to their searches.

    Wednesday, May 9, 2018 2:59 PM
  • Good find.

    Thanks!

    Wednesday, May 9, 2018 4:01 PM
  • Fixed for me also! Thanks!
    Thursday, May 10, 2018 1:43 PM
  • I thought my Win10 RS4 would have the file, but neither SearchOCR.admx nor SearchOCR.adml is there for some reason.

    However, Win10 RS5 (17666) does have them. So I looked at the hash for RS5's SearchOCR.adml and compared it to the same file provided in the template download. They're the same. Therefore, RS5's SearchOCR.admx should be its match, and it's working for me in testing on a Server 2016 domain.

    For anyone who wants it, or just wants to look in it, here it is.

    Sunday, May 13, 2018 6:32 PM
  • Delete all the PolicyDefinitions folder and add the new templates from version 1803, no bug has been detected this way, which is the correct way to upgrade the GPO.
    Tuesday, May 15, 2018 5:51 PM
  • Delete all the PolicyDefinitions folder and add the new templates from version 1803, no bug has been detected this way, which is the correct way to upgrade the GPO.

    I disagree. How about office templates? Or any other....

    MCSE Mobility 2018. Expert on SCCM, Windows 10 and MBAM.

    Tuesday, May 15, 2018 7:44 PM
  • > I disagree. How about office templates? Or any other....

    Organize your templates in "source folders". One for each template source you have (Operating System, Office, possibly Adobe or Firefox...). Then update the source folders, delete existing templates in PolicyDefinitions and re-populate from your source folders.

    Wednesday, May 16, 2018 11:24 AM
  • The SearchOCR.admx are not packed in the new PolicyDefinitions and so i deleted this file and the SearchOCR.adml.
    If Microsoft doesen't published it, i think it's not longer needed.
    For me that works.

    Thursday, May 17, 2018 2:20 PM
  • So i have done a little digging on this... the SearchOCR.ADMX file is only installed in the PolicyDefinitions folder if you have the "Windows TIFF Ifilter" option installed. If you have ever dont this on an old version of windows and then copied it accross to the Policy Definitions folder then this will be an old version of the file as it wont be updated using the ADMX/ADML bundel that Microsoft publishes. 

    While editing the ADML file will fix the problem, you are only fixing it for one language. My recommended fixes is to either 1. Delete the SearchOCR.ADMX file if you dont use any of the policy settings or 2. Install Windows TIFF Ifilter on a computer running Windows build 1603 (server or workstation) and copy that SerchOCR.ADMX file into the central store. 

    Hope it helps... 


    Alan Burchill (MVP)
    http://www.grouppolicy.biz

    @alanburchill

    Monday, May 21, 2018 12:13 AM
  • https://www.grouppolicy.biz/2018/05/how-to-fix-searchocs-admx-error-after-upgrade-to-windows-1803-admx-files/

    MCSE Mobility 2018. Expert on SCCM, Windows 10 and MBAM.

    Monday, May 21, 2018 5:23 AM
  • Made into a KB article now, too.
    Tuesday, May 22, 2018 6:31 AM
  • Hello,

    I was facing exactly the same issue. Your solution fixed the issue for me as well! Thanks!

    Adamo

    Thursday, June 7, 2018 9:13 AM
  • Adding that line of code to the SearchOCR.adml file worked perfect.

    Thank you!

    Monday, June 18, 2018 8:41 PM
  • Worked for me as well. Thanks a lot!

    BR

    bernd

    Friday, June 22, 2018 9:45 AM
  • Worked for me too.

    Thanks for posting the workaround

    Wednesday, June 27, 2018 2:01 PM