none
Group Policy Preferences > Control Panel Settings > Internet Settings > Security > Allow Active content to run in files on My Computer

    Question

  • Here's my situation.

    Server: Windows Server 2008 Enterprise SP1
    Client: Windows XP SP3 and Windows Vista SP1

    I've disabled Group Policy Preferences > User Configuration > Control Panel Settings > Internet Settings > Security > Allow Active content to run in files on My Computer (Uncheck)

    But when I applied the policy domain wide gpupdate/force, this particular settings is still ticked on all client machine XP SP3 and Vista SP1 with CSE installed.

    Check in Group Policy Result and it shows the settings as disabled but for client computers, it's still enabled.

    Unchecked the settings manually from client machine's IE did gpupdate/force and it will auto apply back the settings once policy refreshed.

    I've block inheritance for this particular Organizational Unit, so it won't take any other policies in my domain. Even enforced it too.

    RSOP.msc on client machine, couldn't show preferences settings. Only mean for me to check if preferences is applied is using Group Policy Result.

    This policy is applied to computers and users in the particular Organization Unit with inheritance blocked to it.

    Hope someone could shed some light on this.

    Other IE preferences such as homepage URL using this policy worked fine. Only the Allow Active content to run in files on My Computer don't work. I also have no other polices set for IE in my domain.
    Friday, May 29, 2009 3:03 AM

Answers

  • Hi,

    Please try the following suggestions to narrow down the cause of this issue.

    Open GPO, navigate to:

    [Computer Configuration/ Policies / Administrative Templates / System / Group Policy / Drive Maps Policy Processing]

    Set the properties to enable:
    -"Allow processing across a slow network connection"
    -"process even if the Group Policy objects have not changed"

    Navigate to:
    [Computer Configuration/ Policies / Administrative Templates / System /Logon]

    Enable "Always wait for the network at computer startup and logon".

    Find the GPP Internet Settings, double-click to open the Properties of the policy, switch to Common tab, check the following option:

    "Run in logged-on user's security context (user policy option)"

    Also, please make sure the Policy is Green. If it’s red, it would be ignored. For your reference:

    http://blogs.technet.com/gpguru/archive/2008/11/19/red-green-gp-preferences-doesn-t-work-even-though-the-policy-applied-and-after-gpupdate-force.aspx

    If the issue persists, please help to collect the following information for research.

    1.    On DC, open GPMC.MSC, collect a copy of Group Policy Result for one of users. Please use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the file and then give us the download address.
    2.    On clients, run "gpresult /v C:\gp.txt" and upload the file to Skydrive.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, May 29, 2009 10:54 AM
    Moderator

All replies

  • Thanks in advance to your replies.
    Friday, May 29, 2009 3:05 AM
  • Hi,

    Please try the following suggestions to narrow down the cause of this issue.

    Open GPO, navigate to:

    [Computer Configuration/ Policies / Administrative Templates / System / Group Policy / Drive Maps Policy Processing]

    Set the properties to enable:
    -"Allow processing across a slow network connection"
    -"process even if the Group Policy objects have not changed"

    Navigate to:
    [Computer Configuration/ Policies / Administrative Templates / System /Logon]

    Enable "Always wait for the network at computer startup and logon".

    Find the GPP Internet Settings, double-click to open the Properties of the policy, switch to Common tab, check the following option:

    "Run in logged-on user's security context (user policy option)"

    Also, please make sure the Policy is Green. If it’s red, it would be ignored. For your reference:

    http://blogs.technet.com/gpguru/archive/2008/11/19/red-green-gp-preferences-doesn-t-work-even-though-the-policy-applied-and-after-gpupdate-force.aspx

    If the issue persists, please help to collect the following information for research.

    1.    On DC, open GPMC.MSC, collect a copy of Group Policy Result for one of users. Please use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the file and then give us the download address.
    2.    On clients, run "gpresult /v C:\gp.txt" and upload the file to Skydrive.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, May 29, 2009 10:54 AM
    Moderator