locked
environment variable in DFS folder path RRS feed

  • Question

  • Hi, is it possible to use an environment variable (i.e. %USERNAME%) in DFS folder path? I want to publish a personal folder to users on DFS. So I created a namespace and DFS folder with path i.e. \\server\share\%USERNAME% and then I mapped the namespace to users via GPO preferences. Unfortunately system refuses to translate the variable %USERNAME% to a real user name so the share is not available to users. Is it a way to resolve it? Thanks

    Tuesday, November 5, 2013 11:17 PM

Answers

  • Hi.

    Well first of yes you can, BUT in group policy preferences dont use %username% but %LogonUser%.

    At first I thought that you wanted \\domain.local\dfs\homefolder => \\fileserver\%username%. That you can't do, due to the fact that the DFS translation is done in the MUP service.



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. Even if you are not the author of a thread you can always help others by voting as Helpful. This can be beneficial to other community members reading the thread.


    Oscar Virot


    • Edited by Oscar Virot Wednesday, November 6, 2013 9:52 AM typo in url
    • Marked as answer by Edo Duda Wednesday, November 6, 2013 3:47 PM
    Wednesday, November 6, 2013 9:45 AM

All replies

  • Hi.

    Well first of yes you can, BUT in group policy preferences dont use %username% but %LogonUser%.

    At first I thought that you wanted \\domain.local\dfs\homefolder => \\fileserver\%username%. That you can't do, due to the fact that the DFS translation is done in the MUP service.



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. Even if you are not the author of a thread you can always help others by voting as Helpful. This can be beneficial to other community members reading the thread.


    Oscar Virot


    • Edited by Oscar Virot Wednesday, November 6, 2013 9:52 AM typo in url
    • Marked as answer by Edo Duda Wednesday, November 6, 2013 3:47 PM
    Wednesday, November 6, 2013 9:45 AM
  • Thank you for explaining the problem. Now I know it is not possible.
    Wednesday, November 6, 2013 3:49 PM