WDS: EFI BIOS won't PXE boot into EFI mode


  • I need to be in UEFI mode when PXE booting from WDS, but device comes up in BIOS mode.  I am using latest Win 2008 Server R2, fully patched.  The board manufacturer insists that the 'Legacy PXE option ROM' is capable of PXE booting into UEFI mode, but I have doubts.  For testing, I am using a x64 boot.wim and install.wim extracted from a recent Breckenridge (Windows Storage Server) DVD.  How do I know I'm not in UEFI mode? 

    When booting PXE/WDS:

    1. Windows setup is not able to create a partition greater than 2TB on a 3TB drive.

    2. In \Windows\Panther\setupact.log I see:

                Callback_BootEnvironmentDetect: Detected boot environment: BIOS

    When booting from a DVD (I have two choices in BIOS for DVD device, one specifies 'UEFI')

    1. Setup creates a full size (2794 GB) GPT drive partition on a 3TB drive.

    2. In \Windows\Panther\setupact.log I see:

                Callback_BootEnvironmentDetect: Detected boot environment: UEFI

    In both PXE and DVD boot, I specify drivers when setup presents the 'install drivers' button, so that the full size 3TB is displayed.  Diskpart shows the following after PXE installation:

    DISKPART> list disk
     Disk ### Status  Size Free Dyn Gpt
     -------- ------------- ------- ------- --- ---
     Disk 0 Online  2794 GB 0 B
     Disk 1 Online  482 MB 0 B
     Disk 2 Online  465 GB 0 B
    DISKPART> select disk 0
    Disk 0 is now the selected disk.
    DISKPART> list part
     Partition ### Type  Size Offset
     ------------- ---------------- ------- -------
     Partition 1 Primary  100 MB 1024 KB
     Partition 2 Primary  60 GB 101 MB
     Partition 3 Primary  1987 GB 60 GB


    Apparently setup did not detect UEFI, and created an non-GPT disk.  I thought maybe there was something I had to specify on the WDS side, but found nothing in the GUI.  I did find options in wdsutil to display and set a 'default boot program' for specific architectures (my target architecture is x64).  WDSUTIL /get-Server /server:SVR.Foo.local /show:Config shows:

    Boot Program Policy:
     Known client PXE prompt policy: OptOut
     New client PXE prompt policy: OptOut
     Allow N12 for new clients: 
     Architecture discovery: Enabled
     Reset boot program: No
     Default boot programs:
      x86 - boot\x86\
      x64 - boot\x64\
      ia64 - boot\ia64\bootmgfw.efi
     Default N12 boot programs:
      x86 - boot\x86\pxeboot.n12
      x64 - boot\x64\pxeboot.n12
      ia64 - boot\ia64\bootmgfw.efi

    So I tried changed the default boot program for x64 to (using WDSUTIL /set-Server /BootProgram:boot\x64\bootmgfw.efi Architecture:x64), to look like:

    Boot Program Policy:
     Known client PXE prompt policy: OptOut
     New client PXE prompt policy: OptOut
     Allow N12 for new clients: 
     Architecture discovery: Enabled
     Reset boot program: No
     Default boot programs:
      x86 - boot\x86\
      x64 - boot\x64\bootmgfw.efi
      ia64 - boot\ia64\bootmgfw.efi
     Default N12 boot programs:
      x86 - boot\x86\pxeboot.n12
      x64 - boot\x64\pxeboot.n12
      ia64 - boot\ia64\bootmgfw.efi

    But I got the same result (Setup cannot configure > 2TB partition, setupact.log shows 'BIOS' boot environment).  Am I missing something?  Should this work?



    • Edited by Dave N S Friday, April 15, 2011 4:00 PM
    Monday, April 11, 2011 10:51 PM

All replies

  • Hi Dave,


    If you are installing Windows to an EFI-based computer, you must enable EFI mode in the computer's firmware in both attended and unattended installations. You must boot to 64-bit EFI-mode preinstallation media (64-bit Windows PE in EFI mode or 64-bit Windows Setup in EFI mode). You cannot install Windows to UEFI-based computers in BIOS mode. (For more information about switching modes, see your EFI firmware documentation.)


    For more information, please refer to the following article:



    Tim Quan

    • Proposed as answer by Darren Mac Thursday, May 22, 2014 9:31 AM
    Wednesday, April 13, 2011 7:11 AM
  • Hi Tim,

    > If you are installing Windows to an EFI-based computer, you must enable EFI mode in the
    > computer's firmware in both attended and unattended installations.

    I tend to believe this, but have thus far been frustrated in finding out from BIOS and board manufacturers how to do this with PXE.  There is no explicit setting in the BIOS to explicitly enable EFI.  We are able to accomplish EFI mode when booting from DVD or loading EFI drivers from a USB stick, but that won't work with PXE (no local media to load drivers from).

    > You must boot to 64-bit EFI-mode preinstallation media (64-bit Windows PE in EFI mode
    > or 64-bit Windows Setup in EFI mode).

    We are successfully doing exactly that with DVD, and then using the same x64 PE Image (boot.wim) from the DVD extracted to WDS.  Apparently this preinstallation media supports both EFI and BIOS without changing anything.  As shown in the logs quoted in original post, it is apparently detecting the environment it was booted in.

    > You cannot install Windows to UEFI-based computers in BIOS mode. (For more information
    > about switching modes, see your EFI firmware documentation.)

    Which seems to be the root of the problem - the documentation doesn't address exactly how to do this with its PXE 'legacy option ROM' .  Do you have any examples from *any* firmware how to PXE-boot in EFI mode?  Even if for a different BIOS, it might be instructive.


    Wednesday, April 13, 2011 5:34 PM
  • I'm going to post a reply here merely so that I can follow the topic.


    I'd like to let you know that you're not the only person who is having problems with this. This is one of the few things left for me that I simply cannot seem to solve.


    I've read alot of articles and documentation, as from my understanding; the wds server will serve the pxe client with a bootprogram that will/should determin the capabilities of the client, and let it pxe boot into x86 or x64 architecture but more importantly if the system is efi capable (not very uncommon with server hardware these days, many intel mainboards and about every sandy bridge mainboard out there) it should load the uefi winpe image.

    However I've tried many things, at first I thought it was my highly customized setup that would prevent this from working but also a new vanilla server 2k8r2 with wds will not follow this logic, instead it will always continue to boot into the regular "bios" winpe.

    I have also tried to manually partition the disk per gpt specifications for windows 7/server and then apply the image with imagex. This part works fine without problems. But as soon as I use bcdboot to apply the bootmanager to the system partition that the OS should boot from, it will return an error since I did not boot into efi mode, preventing me from doing it this method.

    Just like Dave, I am able to successfully to install windows in efi mode if using the dvd and simply start the entry in the mainboard's boot menu for "EFI - Optical Drive" (something like that at least, differs for every brand).


    I tried this on many different systems, and a wide range of NIC's, I even flashed one of my Intel NIC's with a EFI firmware, which still yields the same result.


    Kind regards,

    Stephan Schwarz. 

    If you one of these posts answered your question or issue, please click on "Mark as answer". If a post contained helpfull information, please be so kind to click on the "Vote as helpful" button :)
    Friday, April 15, 2011 12:35 PM
  • I'll give this a gentle bump since I'm still curious regarding this topic.
    If you one of these posts answered your question or issue, please click on "Mark as answer". If a post contained helpfull information, please be so kind to click on the "Vote as helpful" button :)
    Friday, April 29, 2011 9:57 PM
  • Maybe I have a solution.

    I'll post two, I know the second one works, but the first may also work.

    1. During the pxeboot, I saw that the client machine was first loading pxeboot.n12, instead of, so I tried to modify the default n12 boot programs, with

    wdsutil /set-server /n12bootprogram:boot\x64\bootmgfw.efi /architecture:x64

    The next time I tried to boot via pxe, I saw that the client had downloaded bootmgfw.efi, but didn't go any further, since my lan card doesn't support efi. If anyone has a lan card with EFI support, I think it'll be worth a try.

    2. Since I couldn't boot in EFI mode via PXE, I created a discovery image, you may use this:

    (I used copype.cmd amd64 c:\winpe in Step Two, the x86 winpe.wim doesn't have support for EFI)

    In Step Six I added the winpeshl.ini in both System32 and SysWow64, but I think the latter is not needed.

    I also reformatted my USB flash drive, but I don't think it was necessary, it was already fat32.

    I plugged the USB flash drive in the client and chose UEFI... (ASUS motherboard)

    Once the discovery image was booted, I checked the setupact.log and found that the installer was running in EFI mode.

    I'm sorry for my english.

    Wednesday, August 10, 2011 8:29 PM
  • I tried the first method you mentioned way back, I couldn't get it to work and again it's not a setting I can have as default since not all our x64 machines are uEFI.

    While I'm able to do this with either usb flash disks or optical media for the time being, I still need to actually be able to do this over the network instead. I found a possible work around, but haven't been able to test it due to the complixity and additional research required.


    Kind regards,

    Stephan Schwarz.

    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCC.
    Wednesday, August 10, 2011 9:33 PM
  • The PXE ROM is most likely sending down the wrong architecture option in the PXE packet being sent on the network. You can review RFC 4578 to see a list of architecture options here: For the machine to be recognized as a UEFI machine by this version of WDS, it needs to be sending a value of 7 . The machine is most likely sending a value 0 currently, which is causing this issue. 

    Thursday, August 11, 2011 10:20 PM
  • Okay i've setup my 2008 r2 server with domain, dns, dhcp and the new WDS. I've got my machine booting with my old boot.wim file i was using for my vista imaging. Now we have 3TB drives running win7 64bit. Like everyone else i can only get DVD and USB drive to work I have sandybridge motherboard. HOW DO WE GET PXE UEFI!!!! someone. Anyone!!???!?!?!?

    I really dont like using DVD's or USB keys in a production invironment. DVD's get scratched. USB keys somehow disapear, or break. I need centralized server image deployment.


     Type   Architecture Name
                ----   -----------------
                  0    Intel x86PC
                  1    NEC/PC98
                  2    EFI Itanium
                  3    DEC Alpha
                  4    Arc x86
                  5    Intel Lean Client
                  6    EFI IA32
                  7    EFI BC
                  8    EFI Xscale
                  9    EFI x86-64

    Is 7 the correct response? or do we want 9 "EFI x86-64" and what is EFI BC? i googled it with nothing usefull returned.

    @Stephan, you say not all your machines are 64bit. Mine are. so what could i do to force UEFI all the time?

    - What, I need a signature?
    Wednesday, August 24, 2011 8:22 PM
  • Hi,

    I have the same problem.

    I can't boot PXE in UEFI mode.


    If I go to the BIOS of the Lenovo X220 and set the Boot Option the "UEFI only" the boot device manager only shows my SSD. The LAN card dissapears. That is another indicator that the NIC doesn't start in EFI mode.

    Maybe it is defined in the Intel Boot Agent which mode shall be used.

    Monday, August 29, 2011 8:41 PM
  • I don't know if that means anything, but I have an ASUS P8Z68-V PRO, with and onboard intel 82579 lan controller. I found the related intel data sheet, here:

    If you look at page 126, in Table 22 are described the Integrated Boot Agent Capabilities. Bit 3 describes the EFI EBC Capability, and by default it's set to 0. Since I can't boot via PXE using an EFI image, when I found this data sheet I simply gave up, supposing ASUS didn't add this functionality to the IBA. I'm not going to dump my lan controller flash, I think it may be possible, maybe I found the right intel tool, and check if this bit is set to 0. But it may also be worth a try...®+Desktop+Adapters&ProductProduct=Intel®+Gigabit+CT+Desktop+Adaptereng


    Tuesday, August 30, 2011 5:19 PM
  • @ruler88, Thanks for that information.

    After looking into the Lan drivers for my motherboard i found an efi.html file describing how to flash the Intel Option ROM to include efi. This is the same tool mmtomelleri is describing.

    However, in the efi.html file for my Intel NIC stated that LOM does not support this bootutil. see below.

    Installing the UEFI Network Driver Option ROM from the UEFI Shell

    The BootUtil command line utility can install the UEFI network driver on an Intel network adapter's option ROM. The UEFI network driver will load automatically during system UEFI boot When installed into the option ROM. Run BootUtil with the following command line options to install the UEFI network driver on all supported Intel network adapters:

    FS0:\>bootutil -up -all

    BootUtil can only be used to program add-in Intel PCI, PCI-X, and PCI-E network adapters. LOM (LAN On Motherboard) network connections cannot be programmed with the UEFI network driver option ROM.

    So does this mean i cant get UEFI to work? ARGGHGHRHGRGHRGHRH!

    - What, I need a signature?
    Tuesday, August 30, 2011 6:19 PM
  • Yes it seems, that the UEFI LAn Rom is coded into the UEFI Bios which is provided by the mainboard / Laptop manufacturer.
    Tuesday, August 30, 2011 6:36 PM
  • Well thank god im in contact with the motherboard manufacturer. Hopefully i can get a new BIOS that pushes out PXE UEFI support. This has been driving me MAD...

    I should hear back this week from them. If updating the Option ROM makes this work i will report back. cross your fingers :)

    - This is where you are supossed to put something witty. "something witty"
    Tuesday, August 30, 2011 8:42 PM
  • You can use a regular Intel NIC and flash it with an uEFI rom, however when I tried this I still had the same results. And for some reason the uEFI rom was marked as an development build which presented some red flashing warnings stating just that message.

    The only method that I'm aware of to flash the onboard intel nic rom, is by using Intel's flash image tool, which allows you to build your own mainboard rom update. However this program is licensed software for only the large OEM's and ISV's . I never understood how to use it since there's too many options with too little documentation.


    Kind regards,

    Stephan Schwarz.

    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCC.
    • Proposed as answer by Joe Raby Thursday, September 08, 2011 9:08 PM
    Tuesday, August 30, 2011 8:58 PM
  • If you're using WDS, have you considered using a Discover CD/DVD and booting into UEFI mode from that? 

    Most motherboards so far don't offer PXE boot ROM for UEFI.  This is just an unfortunate truth about the (lack of) maturity of UEFI.


    Creating a Discover image and burning it to DVD with the EFI bootloader files would definitely work in your scenario.  If you don't have an optical drive, you could always try writing it out to a USB thumbdrive, but again, some UEFI implementations don't support USB boot devices.

    The process goes like this:

    a)  Make sure you have a boot image in WDS

    b)  Create a Discover image.  This is an image that works for non-PXE clients.  Network connections are established after WinPE boots off the disc.

    c)  Make sure you have Windows AIK or OPK installed.  Copy the PE support files to a temp folder using the copype.cmd command.

    d)  Insert the Discover .WIM image to the proper folder and rename to boot.wim.

    e)  Use OSCDIMG to create a bootable ISO from all of that, and burn to disc.


    You can find the info on creating a Discover image here:

    NOTE:  You need to rename the image to boot.wim when you copy it into the CD's Sources folder   ....the doc doesn't say that for some reason.


    This is help on how to create an ISO that will boot in UEFI mode.  Substitute the OSCDIMG command for the steps in the previous article.  Change the folder paths as necessary:

    NOTE:  In Step 3, there should be a space between "amd64" and "winpe_x64".  Another typo!

    ALSO NOTE:  Make sure you wait until you have the VGA-style text that says "Press any key to boot from CD".  If the text looks like DOS (80-column format), that's BIOS Mode.


    Thursday, September 08, 2011 9:35 PM
  • So i've got nothing back from the motherboard supplier.

    As to the last reply from joe. I have two types of PC's. One has a DVD drive and the other one doesn't. DVD wont work for both. So as of now i have 32 USB Keys formated and setup to boot UEFI mode. Using the same DVD steps to create a dvd, then copy the finished image to a fat32 formatted usb key.

    On top of that my wim file is greater then 4GB so we had to split the file into two pieces to fit on the fat32 drive. I guess we could have created two partitions one fat32 and the other ntfs but i think the split works fine and makes it easier to build the usb key.

    I'm still pushing through with UEFI PXE with the manufacturer, Last BIOS killed PXE boot completly. today i recieved new one that puts it back. Still no UEFI PXE. If it turns out that new firmware makes UEFI possible i will reply back to this thread. If i get it to work at all i will reply.

    I'm still open for sugestions on things to try :)

    - This is where you are supossed to put something witty. "something witty"
    Tuesday, September 27, 2011 12:12 AM
  • Are there any solutions to this yet?

    Tuesday, March 06, 2012 3:28 PM
  • I gave up on PXE UEFI for now. Ended up building a 16 bay rack with 16 USB keys so i could image a bunch of PC's. Turns out i can image a windows box in under 12 minutes that way. Took 20-25 minutes with PXE imaging over a network. Only advantage of PXE would have been a centralized image location, making updates easier.

    Like someone else mentioned. You could build a bootable winpe usb key that boots UEFI and then pulls the image from a network location. Then you could use a 1GB memory stick to boot from. Keep the usb key price down that way.

    I do have another product that will need windows imageing sometime next year. Maybe i will look into it again at that point. Our Motherboard manufacturer never got back to us on PXE UEFI. Thats something i can bring back up with them when that project starts.

    Sorry, probably not what you wanted to here. Not what i was expecting when i first started into this either. Good luck JohnWayne77

    - This is where you are supossed to put something witty. "something witty"

    Tuesday, March 06, 2012 7:20 PM
  • Hi,

    I never managed to get it to work, since I used a custom bootprogram which nullified the uefi boot passthrough support in the first place. I then stumbled upon a different bootprogram I wanted to try but never had time to implement and test it's functionality.

    However, the new Windows Server 8 OS, has better WDS support for uEFI clients. So does MDT 2012 (not a nessecity). If you have the time and hardware resources to test it (I no longer do since I don't work at the same company as I did before) you might have better luck. The configuration panel of WDS in Server 8 has specific settings for x86 and x64 uefi capable machines (I was not aware there were "x86-only" systems with uEFI support).

    Kind regards,

    Stephan Schwarz.

    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCC.
    How to configure Windows RE/OEM Recovery Partition with MDT

    Wednesday, March 07, 2012 12:04 PM
  • The problem here is, we can not boot via PXE in UEFI mode because UEFI support is not coded into the mainboard bios. I think a dedicated network card with uefi support would work. In my case, it is not a WDS fail... The only solution I'm able to imagine is modifying the bios to include uefi support for LOM (see some posts before... profit wrote it).
    Wednesday, March 07, 2012 5:31 PM
  • For those of you that are able to work directly with the manufacturer, the best advice I have is to keep asking firmware updates that are based on the latest UEFI 2.3.1 reference implementation. Most vendors pick up the reference implementation from, and there have been many PXE related fixes included there.
    Friday, March 09, 2012 6:59 PM
  • So, I have WDS running and I have some hardware that seems to support UEFI PXE boot. I am able to successfully load up bootmgfw.efi, which loads the BCD files. From there I can choose any of my boot images configured in WDS. I select one that is configured for UEFI, then it loads up the sdi file and downloads the .wim file. As soon as the .wim file finishes downloading, I get a blank screen and the system hangs. I never get WinPE to load.

    I've tried this with Win7 boot images and Win8 boot images, all the same.

    Any chance someone here knows what I can look at?

    Monday, April 09, 2012 10:43 PM
  • You've come further than I have, so can't really help there.

    However maybe the WDS logs will show anything of interest.

    Is it a 2008r2 server or Win8 that's running wds btw?

    Kind regards,

    Stephan Schwarz.

    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCC.
    How to configure Windows RE/OEM Recovery Partition with MDT

    Monday, April 09, 2012 11:48 PM
  • I can see in the WDS event log that the machine completed the TFTP download of my WinPE wim file. I'm not sure the WDS logs could tell me anything else, as it is the client that seems bent on not booting WinPE, and my eventual destruction.

    WDS is running on 2008 R2. However, I have added a Windows 7 x64 EFI boot image and a Windows 8 x64 boot image, and I get the same results from both. However, those images on a CD boot the machine just fine.

    Wednesday, April 11, 2012 11:27 PM
  • Let's pretend we have a system with the proper uEFI support. What .efi file from WinPE or WDS should be specified as the default boot program? Is anyone 100% sure that bootmgfw.efi is the right one? Or does someone know for sure which one it should be?
    Monday, April 23, 2012 6:20 PM
  • The boot sequence for EFI machines is the following:

    1. DHCPv4 handshake from client -> server
    2. Client downloads wdsmgfw.efi.
    3. (user hits second F12 prompt, depending on prompt policy)
    4. wdsmgfw.efi downloads and executes bootmgfw.efi

    There's an additional complication here if you've added Win8 boot images to your server: you'll be using the Win8 boot programs as WDS automatically updates these when you import a boot image. Win8 does things a little differently then Win7, and it's not guaranteed that this will work right now, but is intended to work when Win8 ships.

    There's one known issue with using Win8 boot programs on a Win7 server that you can resolve by updating the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WDSServer\Providers\WDSTFTP\ReadFilter to include both \efi\* and efi\*. You'll need to restart the WDS service for this change to take effect.

    You should be able to revert back to the Win7 boot files by running wdsutil /update-serverfiles.

    Tuesday, April 24, 2012 7:48 PM
  • Not sure if this issue is still being monitored, but I thought I'd put my two cents in....

    Not many systems support UEFI Option ROM's for PXE boot.  Just because the system says it supports UEFI booting, at this point in time, you should just EXPECT that it won't support PXE boot in UEFI mode to avoid disappointment.  This will likely change with the advent of Windows Server 8 though, since all certified OEM Windows 8 clients are to have native UEFI support, and WDS will dictate that clients support PXE on UEFI.

    Just out of curiosity, have you tried to use a WDS Discover disk with UEFI CD/USB booting?  I haven't, so I don't know if this would work, but it seems to be the most logical option.

    Don't forget that for USB booting for UEFI requires that you do the following 10 (almost kinda sorta) easy steps:

    1)  First off, DON'T use the Windows 7 USB DVD Download Tool.  It doesn't do a proper job for UEFI on USB, so just forget about that idea altogether.  Forgotten it now?  Good.  Let's move on.

    2)  Mount your ISO image with a Virtual CD program (I recommend Virtual CloneDrive from SlySoft), or else extract it, or pop in the original DVD of the OS you want to copy.  This could be a Windows Setup disc, WinPE, or WDS Discover disc.  Whatever.  It just needs to have a way to launch Windows Setup (the installer that launches in WinPE).

    3)  Grab a 4-8GB USB stick and pop it in.  Format it FAT32, NOT NTFS like the Windows 7 DVD Tool would do it.  Your UEFI firmware won't support NTFS because it's not a freely-licensed filesystem like FAT32 and firmware makers aren't paying the licensing for NTFS.  You don't have to do anything special with the formatting otherwise - just use Right-Click | Format on the drive and choose FAT32 as the filesystem and proceed.  You can choose Quick Format to speed up the process.

    4)  Copy the contents of the image to the drive, whether it be from a folder or a DVD/CD.  Don't be dumb and just copy the ISO image file to the USB drive.  If you're trying to do this and don't know that by now, go back to school N00B!

    5)  Explore the USB stick.  You should see a bunch of folders on it.  One is called EFI.  Go into it.  Inside it you should see a Microsoft folder, and inside that, a BOOT folder.  The BOOT folder shouldn't reside inside the Microsoft folder for USB use.  It needs to just be a subfolder of EFI.  i.e. it should look like X:\EFI\BOOT, not X:\EFI\Microsoft\BOOT.  Copy and paste it one step out.

    6)  This part can be a bit tricky if you don't have the proper tools.  You'll either need a copy of IMAGEX or DISM and a copy of the BOOT or INSTALL.WIM easily accessible, or an installed version of 64-bit Windows Vista SP1, Server 2008, 2008R2 or Win7:

    6a)  DISM command:  dism /mount-wim /wimfile:(path to wim) /index:(index number of image in WIM) /mountdir:(empty folder on your hard drive for mount point) /readonly


    6b)  IMAGEX command:  imagex /mount (path to wim) (index number of image in WIM) (empty folder on your hard drive for mount point)


    6c)  Boot up your installed x64 version of Windows if you haven't already.

    7)  In either your mounted image or on your hard drive, navigate to the Windows folder, then BOOT, then EFI.  Inside you'll find a file called BOOTMGFW.EFI.  You need to copy this to your USB thumbdrive into the EFI\BOOT folder.  Then you have to rename the file as BOOTX64.EFI - on your new USB thumbdrive, NOT the source image!

    8)  If necessary, unmount your source image with DISM or IMAGEX because you won't need them anymore.

    9)  Go into your computers boot override screen using the requisite key during POST (you may have to go into the BIOS on some UEFI-equipped PC's) and choose the USB stick, making note if there is a separate BIOS or UEFI label for the USB stick - BE SMART and choose the UEFI option.  It should boot successfully and default to GPT drive partitioning when you follow the steps to start Windows Setup.

    10)  To confirm UEFI mode was launched properly:  Once Windows Setup starts to copy files, hit Shift-F10.  A Command-Prompt window appears.  Type the following:



    Check the list of drives and see if there is an asterisk under the GPT column for your hard drive (it's likely going to be Disk 0).  If so, everything is working according to plan.  Type EXIT and hit enter.  Then do it again to close the CMD window.  Enjoy!

    Thursday, May 17, 2012 3:42 PM
  • I'm still following it, even if it is useless in my case.

    I'm not sure if really Windows 8 clients will have UEFI PXE boot support for LOM, maybe they will continue to have native UEFI support for other boot devices, even if I do not know anything about what Microsofts requires in their certification for Windows 8 clients.

    Intel provides a tool that you can use to flash their add-in networking cards, this way you can add UEFI PXE to the IBA. Unfortunately, it doesn't work with LOM controllers, and probably even if it worked it would have not been enough. If you look at my first post, I tried and successfully booted a WDS recovery disk via USB in UEFI mode.

    Thursday, May 17, 2012 5:09 PM
  • I got a new Dell XPS 8500 with I7 Gen 3 chipset.  It came with windows 8, which means it had to come with UEFI and Secure Boot enabled.  I was intially unable to apply my house windows 7 pro image via my Windows Deployment Server (Win2k8 R2).  However, once I updated the boot image with the 8500 NIC, Video, and SATA drivers AND disabled Secure Boot mode in the BIOS (but left UEFI Mode enabled), everything came up fine.

    Until I disabled the secure boot mode, the system would hang while trying to load the initial boot image.

    Tuesday, November 13, 2012 9:54 PM
  • Hi! I had the same problem but i solved it.

    Take the Boot.wim from original DVD from 8 Pro and add it to WDS. Then convert HD in GPT and make partitions, install, etc.

    I Allways use Winpe from ADK but in Uefi pxe clients doesnt work.

    Kind Regards!

    Thursday, January 17, 2013 3:42 PM
  • I am able to use the Windows 8 boot.wim from the OEM Installation Media on my WDS Server to deploy an image (to a Dell E6530 w/ UEFI/GPT partitions), but then the Install Image Win 7 x64, never boots.  Hangs at a black screen.  Very frustrating.

    When I try to boot using a W7 (WinPE 3.1) boot.wim from a similar Dell Installation Media on my WDS Server, the Boot Wim never loads, hangs at black screen.... odd.  I assume it's driver related, but I've downloaded the A11 WinPE driver package from and applied it to my Boot Image, and still the same.

    Friday, September 13, 2013 3:11 PM
  • Only WDS in Server 2012 and upcoming Server 2012 R2 can accept a UEFI PXE boot request. The EFI functionality in Server 2008 R2 is for Itanium systems and will not work with UEFI 2.3.1 motherboards. You can confirm this yourself on 2008 if you use WDSUTIL to force clients to boot to the EFI profile, the client will lock up because it isn't for that hardware.

    As far as WinPE goes, you need WinPE 4 x64 from Windows 8. UEFI spec requires OS must support GOP and previous versions of WinPE do not support that. You will notice that in UEFI mode, WinPE 4 will show the BIOS splash image instead of the Windows image on boot and upon loading, will use the native resolution of your display.

    I have previously successfully been able to deploy Windows 7 x64 to UEFI via UEFI PXE boot by capturing the OS and the EFI partition. This is not a good option because that locks the image to a specific disk size. I am working on deploying Win7 without having the disk size restriction but so far have not had much progress.

    Friday, September 13, 2013 3:35 PM
  • We did already migrate WDS to a 2012 Server to get UEFI support.  The issue was using WinPE 3.1 (ie Win 7 flavor) to deploy {legacy} Windows 7 images previously captured from MBR disks (did I just call Win 7 legacy!?).

    Historically the boot.wim off the Dell Installation media has been the best boot.wim for us; since they slipstream their drivers already into that.

    What we now know is that the WinPE 3.1 boot.wim with Dell A11 driver pack does work in our WDS UEFI boot scenario; however, it takes a long time to load.  Once it does; we can deploy the images to these machines.

    For some reason if we use the WinPE 4.0 (Win 8 Flavor) boot.wim to deploy these Win 7 images; the disk is partitioned in a manner that does not work.

    In the end, we failed one of our goals, which was to retain the Dell Diagnostic partition on the disk.  Success was only after we deleted all partitions from the disk, and let Win PE 3.1 format the disk as it needed to; obviously in GPT format not MBR format.

    To me this is all very odd; but I think we were very close to the right ingredients.  I'm still looking for a way to 'archive' the entire disk to an image file; so the HDD can be recovered to factory when we're done using them. We have Ghost on our WDS server for this; but it does not support GPT. Any other ideas?

    Wednesday, October 09, 2013 1:43 PM
  • Hello

    To grab entire disk to a file to be able to restore it 1:1 after you'll finish your testing with uefi and all you can use what I've been using for a few years now.

    1. Download and boot any linux live. Via usb, pxe, cd/dvd.
    2. When booted, mount your smb share in some directory. This will be the directory where your entire disk image will be saved
    3. now start command prompt/terminal (in this live linux system) and execute this:
      dd if=/dev/sd? of=/mount/point/of/your/smb/share/file_name_of_your_disk_image &

      ? - put there a letter which define your entire drive
      if - input file
      of - output file
      remember to add '&' character at the end. This way you'll get PID of dd process.
    4. Start another terminal and execute this:
      kill -USR1 pid_number_youve_received_starting_previous_command

      This will show you the progress of entire operation.
      Remember: Your disk will be copied 1:1 bit by bit, byte by byte so no compression is involved there and you'll have your entire disk in one single gigantic file. Even empty space will be copied. All will be saved including partitions (GPT/MBR/anything).

      It is possible to pipeline it and compress the data on the run but for that you'll have to search on how to do this since I don't remember on how this can be done right now.

    So that's for cloning entire disk.

    And please don't lynch me for saying linux but it really is the only way of cloning entire disk.

    Wednesday, February 12, 2014 12:47 AM
  • Dear All

    Actually, after nights of investigation I came across the solution:

    It works as soon as Netbios over TCP/IP is switched off on the NIC(s) (WINS tab, IPv4 properties) on the WDS server!

    This causes the NbtNS (Netbios name search) broadcasts on port 137 to cease and the TFTP on port 4011 to reply promptly.

    This makes UEFI PXE booting work for empty Hyper-V Generation 2 VMs as well as for physical clients.

    Sadly nobody out there could really help me, I hope my solution saves valuable time of others experiencing this problem.


    Wednesday, February 25, 2015 5:49 PM
  • Hi Dominique. It worked for me. Many thanks for this.

    Regards, Nóri

    • Edited by Arnór Monday, March 23, 2015 2:44 PM
    Monday, March 23, 2015 2:44 PM