How to disable TCP Offload options


  • Because of network performence problems I have to disable "TCP Large Send Offload" and "TCP Checksum Offload" at the NIC of the Hyper-V manager (not at the physical NIC). I tested this at a full installation and it seems to help. But I plan to use the Core installation.

    How to disable the TCP Offload [...] there without the device manager (which is not available at the core installation (a grate function, really...))?

    Thursday, May 1, 2008 12:01 PM


All replies

  • Hi,


    For the NIC, you'll need to modify the registry. There is an earlier thread on changing the binding order, which has the information to get you to the right place.


    There are some settings for TCP/IP, go to "netsh interface tcp" and then run "set global" and you'll see all the options for some of the advanced TCP/IP configuration. One of those may help.




    • Proposed as answer by th3hate Monday, June 27, 2011 7:39 AM
    Thursday, May 1, 2008 10:53 PM
  • These settings are not at this place. They are saved at "HKLM\System\CurrentControlSet\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\00<Index>

    - Ip4IpChecksum

    - Ip4TcpChecksum

    - Ip4TcpLsoV1




    Changing these values showed the expected effects.

    Friday, May 2, 2008 12:26 AM
  • Made all of the difference in the world! Thank you!
    Monday, July 6, 2009 5:20 PM
  • I believe I have the same performance problem (bursting) then unbelievably poor performance and more bursting.  So I'm trying to disable IPv4 TCP Checksum offload and TCP Large Send Offload.  However, the registry path mentioned here is not valid:



    There is no Class key under CurrentControlSet

    and when I go to the HKLM\System\CurrentControlSet\TCPIP\Parameters key I don't see a subkey for Class or a Subkey for [4D36E972-E325....

    And the parameters I do see don't include the options I'm trying to configure.  So instead I went into the physical nic properties for Hyper-V host which is being used as the virtual switch.  I configured the options there.  I'll monitor for a while to see if there is any change but it certainly feels like I'm poking around in the dark.


    Friday, May 28, 2010 2:39 PM
  • The quoted registry path is incorrect - it should read


    • Proposed as answer by Brian Walsh Thursday, September 27, 2012 8:55 AM
    Thursday, June 10, 2010 10:28 AM
  • Do i need to do this modification in the Hyper-V server or in the Guests OS?
    • Proposed as answer by PhilG7 Thursday, April 18, 2013 11:05 PM
    • Unproposed as answer by PhilG7 Thursday, April 18, 2013 11:05 PM
    Monday, October 10, 2011 5:31 AM