none
PDC not listening on NTP

    Question

  • Hi,

    The network is a Windows 2008 R2 domain with two Windows 2008 domain controllers.

    Nearly every server on the network has discarded the PDC as the time source and has no time source now.

    On any machine, server or workstation, when I run a command NET TIME /SET /YES, we get:

            Current time at \\OPSDC01 is 9/3/2010 12:13 PM

             The command completed successfully.

     

    If I run w32tm /MONITOR command, we get this:

    OPSDC01.ops.local *** PDC *** [10.3.100.20]:

        ICMP: 0ms delay.

        NTP: error WSAECONNRESET - no server listening on NTP port

    OPSDC02.ops.local [10.3.100.21]:                       

        ICMP: 0ms delay.

        NTP: -15.1504700s offset from OPSDC01.ops.local

            RefID: unspecified / unsynchronized [0.0.0.0]

     

    I ran a netstat command on OPSDC01, and sure enough, it is not listening on any UPD ports

    Any ideas what is going on?  The PDC is OPSDC01 and it has the time fine.  There is a GPS clock on the network that is serving time as well.  This is where I pointed the PDC to get it's time.  We need the network to have the same time as all the other equipment and linux machines on the network.

    Thanks,

    Sandi

    Friday, September 03, 2010 3:15 PM

Answers

  • If all machines are in the same domain, I'd suggest you set the time configuration on clients with Group Policy back to what the standard is:
    You can also configure a NTP server and configure client computer to be NTP clients.

    This is how to configure NTP servers and NTP clients (Can be applied on Microsoft Windows computers)

    • To configure a NTP server, you can do it by proceeding to modify these register entries:

    SYSTEM\CurrentControlSet\services\W32time\Config\AnnounceFlags= 1

    SYSTEM\CurrentControlSet\services\W32time\Parameters\NtpServer = time.windows.com (This will allow the NTP Server to synchronize with time.windows.com, if you don't need that you can let it empty)

    SYSTEM\CurrentControlSet\services\W32time\Parameters\Type = NTP (This is optional and should be enabled if you want your NTP server synchronize with another NTP server)

    • To configure a NTP client, you can do it by proceeding to modify these register entries:

    SYSTEM\CurrentControlSet\services\W32time\Config\AnnounceFlags= 0

    SYSTEM\CurrentControlSet\services\W32time\Parameters\NtpServer = the IP address or the DNS name of the NTP server

    SYSTEM\CurrentControlSet\services\W32time\Parameters\Type = NTP

     

    You can use a GPO to modify the registry entries and have a NTP server and NTP clients. You should see how to configure linux computers to be NTP clients for your NTP server.

    With the proposed NTP configuration, your problem should be solved.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights
    Friday, September 03, 2010 3:28 PM

All replies

  • If all machines are in the same domain, I'd suggest you set the time configuration on clients with Group Policy back to what the standard is:
    You can also configure a NTP server and configure client computer to be NTP clients.

    This is how to configure NTP servers and NTP clients (Can be applied on Microsoft Windows computers)

    • To configure a NTP server, you can do it by proceeding to modify these register entries:

    SYSTEM\CurrentControlSet\services\W32time\Config\AnnounceFlags= 1

    SYSTEM\CurrentControlSet\services\W32time\Parameters\NtpServer = time.windows.com (This will allow the NTP Server to synchronize with time.windows.com, if you don't need that you can let it empty)

    SYSTEM\CurrentControlSet\services\W32time\Parameters\Type = NTP (This is optional and should be enabled if you want your NTP server synchronize with another NTP server)

    • To configure a NTP client, you can do it by proceeding to modify these register entries:

    SYSTEM\CurrentControlSet\services\W32time\Config\AnnounceFlags= 0

    SYSTEM\CurrentControlSet\services\W32time\Parameters\NtpServer = the IP address or the DNS name of the NTP server

    SYSTEM\CurrentControlSet\services\W32time\Parameters\Type = NTP

     

    You can use a GPO to modify the registry entries and have a NTP server and NTP clients. You should see how to configure linux computers to be NTP clients for your NTP server.

    With the proposed NTP configuration, your problem should be solved.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights
    Friday, September 03, 2010 3:28 PM
  • Hi,

    The network is a Windows 2008 R2 domain with two Windows 2008 domain controllers.

     

    Nearly every server on the network has discarded the PDC as the time source and has no time source now.

    On any machine, server or workstation, when I run a command NET TIME /SET /YES, we get:

            Current time at \\OPSDC01 is 9/3/2010 12:13 PM

             The command completed successfully.

     

     

    If I run w32tm /MONITOR command, we get this:

    OPSDC01.ops.local *** PDC *** [10.3.100.20]:

        ICMP: 0ms delay.

        NTP: error WSAECONNRESET - no server listening on NTP port

    OPSDC02.ops.local [10.3.100.21]:                       

        ICMP: 0ms delay.

        NTP: -15.1504700s offset from OPSDC01.ops.local

            RefID: unspecified / unsynchronized [0.0.0.0]

     

    I ran a netstat command on OPSDC01, and sure enough, it is not listening on any UPD ports

    Any ideas what is going on?  The PDC is OPSDC01 and it has the time fine.  There is a GPS clock on the network that is serving time as well.  This is where I pointed the PDC to get it's time.  We need the network to have the same time as all the other equipment and linux machines on the network.

     

    Thanks,

    Sandi


    Sandi,

    Since this is R2, *curious,* what is the Network Location it configured itself to? Are all instances of the firewall enabled? If you disable all instances, and make sure File Sharing is enabled for the Location it believes it's part of, does it work?

    Reason I ask, is this is not the first time I've heard of errors relating to R2 connectivity, and sometimes it comes down to the firewall instance for the location, and File Sharing not being enabled, causing the problem.


    Ace Fekay, MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA 2003/2000, MCSA Messaging 2003, Microsoft Certified Trainer, Microsoft MVP - Directory Services. This posting is provided AS-IS with no warranties or guarantees and confers no rights.
    Friday, September 03, 2010 11:31 PM
  • Hi,

    If there is any update on this issue, please feel free to let us know.

    We are looking forward to your reply.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, September 07, 2010 9:19 AM
    Moderator