none
Event 5014 DFSR Error:1726

    Question

  • I'm running DFS on about 45 branch office 2008 servers to replicate data back to our Corp offices. I keep seeing the error listed below and then a second later I get another event saying that the service successfully established a inbound connection. Data seems to be replicating fine. Why is this error showing up so much in the logs? Should I worry about it?

    The DFS Replication service successfully established an inbound connection with partner BC-SERVER1 for replication group srg-llc.com\lvc\bc.

     

    Additional Information:

    Connection Address Used: BC-SERVER1.ABC.com

    Connection ID: DEC9AA40-C300-4E7E-996A-9EB6B8690064

    Replication Group ID: 0E7C2F66-2A38-4CD8-A77C-1A1BA157B971


    Jason
    Tuesday, June 9, 2009 11:09 PM

Answers

  • Hello Jason,

     

    Based on the research, TCP off loading on the network level may cause these several Event ID 5014 and the error 1726 in the Event logs.

     

    Please add these following registry values on the problematic Windows Server 2008 box to see it can be helpful.

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

     

     

    Value =DisableTaskOffload

    Type = DWORD

    Data = 1

     

     

    Value =EnableTCPChimney

    Type = DWORD

    Data = 0

     

     

    Value =EnableTCPA

    Type = DWORD

    Data = 0

     

     

    Value =EnableRSS

    Type = DWORD

    Data = 0


    Please note: We may need to reboot the server to make these settings take into effect.
     

    Hope it helps.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by David Shen Wednesday, June 10, 2009 11:06 AM
    • Marked as answer by David Shen Thursday, June 11, 2009 10:22 AM
    Wednesday, June 10, 2009 10:59 AM

All replies

  • Hello Jason,

     

    Based on the research, TCP off loading on the network level may cause these several Event ID 5014 and the error 1726 in the Event logs.

     

    Please add these following registry values on the problematic Windows Server 2008 box to see it can be helpful.

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

     

     

    Value =DisableTaskOffload

    Type = DWORD

    Data = 1

     

     

    Value =EnableTCPChimney

    Type = DWORD

    Data = 0

     

     

    Value =EnableTCPA

    Type = DWORD

    Data = 0

     

     

    Value =EnableRSS

    Type = DWORD

    Data = 0


    Please note: We may need to reboot the server to make these settings take into effect.
     

    Hope it helps.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by David Shen Wednesday, June 10, 2009 11:06 AM
    • Marked as answer by David Shen Thursday, June 11, 2009 10:22 AM
    Wednesday, June 10, 2009 10:59 AM
  • Hi,

    I have exactly the same problem, but in Windows Server 2003, is that workaround compatible too?

     

    Regards,

    Raúl.

    Wednesday, June 29, 2011 7:36 AM
  • compatible: yes, but it probably won't solve your problem!

    Im having the same issue between two WAN linked 2003 servers. Neither offloading, NIC drivers or MTU were the problem. Currently MSFT is trying to find the issue - I have to test hotfix by hotfix but currently no solution is in sight.

     

    update:

    I just had some time and spent some googeling. I found out, that a quite large number of the guys reporting that problem only had it via a WAN link, other DFS replications were fine, and so it is in my situation. And of those guys, several were using a SONICWALL firewall, and so do I.

    I finally found a blog, where the admin found out thatthe problem was caused by a default timeout value, configured in the filter rules of the sonicwall  firewall.

    http://faultbucket.ca/2011/02/dfsr-event-5014-the-remote-procedure-call-failed/

    Increasing that value to 1440 (24h) in the incoming and outgoing filter rule for that connection solved the problem immediately.


    • Edited by L_Herzog Sunday, July 3, 2011 1:07 PM solution found
    • Proposed as answer by L_Herzog Sunday, July 3, 2011 1:10 PM
    Sunday, July 3, 2011 10:39 AM
  • David,

    I'm having the same issue with the 5014 warning, but my replication stops from the branch office DFS server. (yet the hub can still send files to the branch).

    This 5014 is logged at 3am (on the branch dfs server) when our central hub dfs server kicks off a backup.

    Our other branch office servers do not have this issue.

    7 seconds after the 5014, we get a 5004 that the inbound connection is resumed, but replication is not happening.

    It wont until I manually restart the DFS replication service.

    We do not have an issue with our firewalls/vpns, etc. as the other poster.

    Right now I'm just restarting the service a couple hours after the 3am warning via script, but want to fix this permanently.

    Would these regedit changes be pertinent?

    Branch office server is 2008 R2 standard.

    Thanks,


    Josh

    Friday, February 17, 2012 4:19 PM
  • I have the exact same issue as you josh, seems as though the Regedit is a temporary fix.  Have we gotten an answer of fixing this besides the regedit?
    Tuesday, June 12, 2012 2:41 PM
  • tks, you help me too!

    Abraços, Marcelo Washington do Nascimento

    Tuesday, February 7, 2017 6:50 PM