none
all shortcuts on desktop and program list have changed to .lnk file and opens in notepad

    Question

  • Hello,

    I am using windows server 2008 R2. I was trying to open a file with notepad, and overlook the checkbox (User same option for opening all the files of this type). Now all the shortcuts on desktop  and program list have changed to .lnk file and opens in notepad. How to fix this issue?
    Tuesday, December 21, 2010 3:15 PM

Answers

  • Tuesday, December 21, 2010 3:51 PM
  • The issue occurs because the file association gets messed up. You need to reset or restore the file association to the default settings. To do this, please take the following steps:

     

    1)      Click Start Menu, and then type regedit in the Start Search and press ENTER.

    2)      Navigate to the following registry branch:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\[ext]

     

    3)      Replace the [exe] with the actual file extension that you want to restore its file type association to revert back to original Windows Vista default. If you unsure, simply browse through all the sub-key under FileExts.

    4)      Delete the sub-key named UserChoice.

    5)      Exit from Registry Editor.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, December 22, 2010 2:48 AM
    Moderator

All replies

  • Tuesday, December 21, 2010 3:51 PM
  • The issue occurs because the file association gets messed up. You need to reset or restore the file association to the default settings. To do this, please take the following steps:

     

    1)      Click Start Menu, and then type regedit in the Start Search and press ENTER.

    2)      Navigate to the following registry branch:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\[ext]

     

    3)      Replace the [exe] with the actual file extension that you want to restore its file type association to revert back to original Windows Vista default. If you unsure, simply browse through all the sub-key under FileExts.

    4)      Delete the sub-key named UserChoice.

    5)      Exit from Registry Editor.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, December 22, 2010 2:48 AM
    Moderator