none
Wrong time on virtual machine RRS feed

  • Question

  •  

    Hello,

     

    I'm running Windows 2003 Standard virtual machines under a Windows 2008 Datacenter Hyper-V Server.  The system time of all of my virtual machines is 3 hours later than the time of my physical host.

     

     

    When I try to change the time on my VMs, it resets itself back to the wrong time after a few seconds, and I get this message in the System log:

     

    Event Type: Information

    Event Source: W32Time

    Event Category: None

    Event ID: 35

    Description:

    The time service is now synchronizing the system time with the time source VM IC Time Synchronization Provider.

     


    Any ideas on what might be causing this?

     

    Thanks,

    Stephen

    Friday, May 23, 2008 8:13 PM

Answers

  • Hello,

     

    Would you please also try the following method and see how it goes?

     

    Disable the Windows Time service from the Services control panel in the guest machine. If you have any other clock synchronization tools in the guest machine, disable them. After that, select the "Time Synchronization" of the Integration Services and reboot the guest machine.

     

    Best regards,

    Chang Yin
    Tuesday, May 27, 2008 10:59 AM
  •  StephenZF wrote:

    What strikes me as peculiar in this case is that I have two separate Hyper-V hosts, and the guests on both of them are being affected, all of them +3.

     

    So if my host OS is at 16:45:59, then my guests will all be at 19:45:59.

    When you originally setup both these servers did you have to install as "EN-US' to get around the installing 'Hyper-V' bug and localization issues and are working now in a different 'locale' and the default 'locale' is still 'EN-US' from when you installed, thus the common +3 Hours. (It may also be a Router/Gateway on the network aquiring the time and passing it over the network or the network is pointing to it for time updates).

    Tuesday, May 27, 2008 11:14 AM

All replies

  • Time synchronization isn't perfect in Hyper-V, but three hours is a much larger time difference than can be explained by that. This sounds like your time zones don't match.

     

    Friday, May 23, 2008 8:30 PM
    Moderator
  •  

    is there any setting in Hyper-V so that the child Vms syncronize time with the Host Server?

     

    that is whenever they are started, they take the time from the Host machine.

    Friday, May 23, 2008 10:16 PM
  • I believe that by default any guest OS for which there are integration components will pick up its system time from the Hyper-V host.  If for some reason you didn't want this behaviour I think you would go to VM Settings->Integration Services and uncheck "Time Synchronization".  Not sure what will happen on a guest that doesn't have Integration Components.

    thanks

    Martin
    Saturday, May 24, 2008 1:39 AM
  •  

    In fact, guests with no Integration OSes are fine since they sync straight to the internet.  Only those with IC have a problem, since they sync with the host.

     

    I double-checked, the hosts and guests are in the same time zones, and still they are all 3hrs later.

     

    As a temporary measure, I unchecked Time Synchronization for the guest OS as you said - thanks for that.

     

    On the long run, though, would anyone have an idea with the Integration Components is synching +3?


    Thanks

    Monday, May 26, 2008 10:38 PM
  • From the early betas right up to the current RC1 of Hyper-V I have never had an issue with VM's and Time Sync with the parent partition when 'Guests' have the 'Integration Components' installed.

     

    The parent partition has at times been slow and failed some WIN32Time updates though this has never been more than ~10 minutes off correct time so to speak, never as far as 3 hours. Either way if my 'parpent partition' time is 16:45:59 then all my 'child partitions' with 'integration components' installed are also 16:45:59.

     

    Tuesday, May 27, 2008 7:25 AM
  • What strikes me as peculiar in this case is that I have two separate Hyper-V hosts, and the guests on both of them are being affected, all of them +3.

     

    So if my host OS is at 16:45:59, then my guests will all be at 19:45:59.

    Tuesday, May 27, 2008 10:34 AM
  • Hello,

     

    Would you please also try the following method and see how it goes?

     

    Disable the Windows Time service from the Services control panel in the guest machine. If you have any other clock synchronization tools in the guest machine, disable them. After that, select the "Time Synchronization" of the Integration Services and reboot the guest machine.

     

    Best regards,

    Chang Yin
    Tuesday, May 27, 2008 10:59 AM
  •  StephenZF wrote:

    What strikes me as peculiar in this case is that I have two separate Hyper-V hosts, and the guests on both of them are being affected, all of them +3.

     

    So if my host OS is at 16:45:59, then my guests will all be at 19:45:59.

    When you originally setup both these servers did you have to install as "EN-US' to get around the installing 'Hyper-V' bug and localization issues and are working now in a different 'locale' and the default 'locale' is still 'EN-US' from when you installed, thus the common +3 Hours. (It may also be a Router/Gateway on the network aquiring the time and passing it over the network or the network is pointing to it for time updates).

    Tuesday, May 27, 2008 11:14 AM
  • Hi Chang,

     

    your idea worked, until I rebooted the guest.  Even if the time service is not running, it stills resets itself back to +3.

     

    And no, I did not have to change the locale to work around the Hyper-V "bug"... in my case, I should be at -5, by the way.

    Tuesday, May 27, 2008 2:45 PM
  • Since I installed WS08 Hyper-V RTM en-us, the host itself has been drifting in time up to 10 minutes difference (slow). This happens regardless of which Internet time reference used and with or without any guest OS running.

    Also, the host and all guest OS are configued to be in the same time zone (GMT+2). Until the next auto synchronization period (clik on date/time then Internet Time tab), which is not adjustable in the GUI to a date/time of your choice (design limitation?), the time will continue to be slower and slower until it becomes unusable.

    A bug?


    TechNet Forum Moderator - http://www.leedesmond.com/weblog/
    Sunday, July 13, 2008 2:16 PM
    Moderator
  • Not a bug.

    If W32Time is disabled as a service and also Hyper-V's own Time Sync from integration services is put to sleep, the only time way for that VM to get it's time is to rely on internal clock (a virtual one, which is not perfect).

    The ideea is to disable Time Sync from Hyper-V integration services, restart the Host + guest and redirect W32time to get the correct time from an external source.

    Read more here:

    http://www.aperture.ro/index.php/2009/01/windows-time-sync-hyper-v-enabled-domain-controller-dilemma/

    Cheers,
    Z
    Monday, May 11, 2009 6:47 AM
  • I Have a similar problem , but cannot turn off the inergrated services time synch on the VM

    I have recently vitualised a DC on 2 node Server core cluster using hyper v.

    It appears I have the loop problem where the host is getting time from the Virtual DC and the Virtual DC is getting time from the host .

    In SCVMM I try to turn off Time Sync in inetrgrated services for the VM it refreshes and then turns back on. Is this because of the cluster ? my plan was to have the DC operate as it allways did and get the time from the next PDC emulator.

    Is my only option to have the cluster nodes sync directly form the net ?

    Friday, May 22, 2009 2:42 PM
  • Gazman19,

    Try turning off Time Sync from the actual hyper-V server rather than through VMM. We couldn't get it to turn off through the VMM either.

    Wednesday, October 27, 2010 9:46 PM
  •  

    Hello,

    I'm running Windows 2003 Standard virtual machines under a Windows 2008 Datacenter Hyper-V Server.  The system time of all of my virtual machines is 3 hours later than the time of my physical host.

    When I try to change the time on my VMs, it resets itself back to the wrong time after a few seconds, and I get this message in the System log:

    Event Type: Information

    Event Source: W32Time

    Event Category: None

    Event ID: 35

    Description:

    The time service is now synchronizing the system time with the time source VM IC Time Synchronization Provider.

    Any ideas on what might be causing this?

    Thanks,

    Stephen

    Are any of your DCs on physical boxes? If they are then set them up to pull time from pool.ntp.org. Then set up your hosts and guests to pull from that DC. Allow firewall exceptions for NTP inbound on that DC.

    If all DCs are VMs then set up one of the physical hosts to poll pool.ntp.org for time and then set the VMs to poll the host. Again set the firewall accordingly.

    http://blog.mpecsinc.ca/2011/01/hyper-v-preparing-high-load-vm-for-time.html

    We have had a lot of pain over the time skew situation for VMs.

    The above methods work for us. In some cases we drop in an HP MicroServer with Win2K8 R2 running as a DC and set it up to poll pool.ntp.org and then have all VMs poll it for time.

    The problem has to do with the polling frequency needed as indicated in the blog post. Do that to ntp.org's servers and they will pass along the Kiss-Of-Death packets basically killing the ability to poll their servers for time.

     


    Philip Elder SBS MVP Blog: http://blog.mpecsinc.ca
    Thursday, May 19, 2011 2:36 PM
  • Probably I found a solution. look....

    I Have 2 domain controller (PDC master PHYSICAL machine and a second VIRTUAL domain controller).

    PDC physical is syncronized with internet time service time.windows.com and also the virtual.

    But Virtual machine has not the same time because the setting of integration service on Hyper-V about this virtual machine was setted for TIME SYNCRONIZATION.

    Disabling the TIME SYNC setting on integration services of the virtual machine AND configuring the virtual machine for sync time (on regedit) with time.windows.com.....running "w32tm /resync'....and here we go !!!....the time is syncronized ad the physical domain controller.

    I hope this could be a solution for you.

    Thanks.

    Luca


    Luca Targa Vecomp Software
    Thursday, June 23, 2011 7:59 AM
  • Probably I found a solution. look....

    I Have 2 domain controller (PDC master PHYSICAL machine and a second VIRTUAL domain controller).

    PDC physical is syncronized with internet time service time.windows.com and also the virtual.

    But Virtual machine has not the same time because the setting of integration service on Hyper-V about this virtual machine was setted for TIME SYNCRONIZATION.

    Disabling the TIME SYNC setting on integration services of the virtual machine AND configuring the virtual machine for sync time (on regedit) with time.windows.com.....running "w32tm /resync'....and here we go !!!....the time is syncronized ad the physical domain controller.

    I hope this could be a solution for you.

    Thanks.


    Luca Targa Vecomp Software
    Thursday, June 23, 2011 7:59 AM
  • This happens to me yesterday after I move the virtual machines to another host computer. All my virtual machines are now 13 hours (yes, 13 hours) ahead of current time. Although I can disable the integrated time synchronization to solve the problem, Microsoft should fix this bug.

     

    Thanks,

    Simon

    Monday, August 1, 2011 3:10 AM
  • I found turning off the time sync in integration services from in VMM doesn't stick (goes back to checked when I revisit the setting).  But changing in hyper-v manager does work.

    Hope that helps.  I had a DC in a VM and it was off by 109s. It was maddening to try everything until I figured this one!

    Thursday, October 13, 2011 9:47 PM
  • THANK YOU THANK YOU THANK YOU!!!
    Friday, December 5, 2014 9:32 PM