Error message when attempting to print: Active Directory Domain Service is Currently Unavailable


  • My PC (windows 7) has stopped communicating with my Canon MX870 printer. I received error message: "Active directory domain service is currenlty unavailable." Printed fine this morning and for past two years but not now. Didn't make any changes today, just won't print. When I run troubleshooting test receive message that says "A print job in the print cue is preventing other jobs from printing" but I have deleted all jobs. Turned computer and printer off, etc. but no luck. Any suggestions?

    Thursday, December 01, 2011 3:40 AM


All replies

  • Hi,


    Please first try the following troubleshooter. If you receive the message "A print job in the print cue is preventing other jobs from printing", please run services.msc and restart the Print Spooler service.



    If the problem continues, please let us know the following information:


    1.    Is this computer in an Active Directory domain? Is there a printer server?

    2.    How does this Windows 7 computer connect to the Canon MX870 printer? Installed locally or shared on network?




    • Proposed as answer by Martin G. Evans Monday, December 05, 2011 3:09 AM
    • Marked as answer by Bruce-Liu Monday, December 05, 2011 4:26 AM
    Friday, December 02, 2011 5:55 AM
  • I had the same problem in the last two days. The printers (Canon PIXMA iMP4000 and Brother HL-5250DN) worked fine for years until recently. I plugged them into the computer directly and re-installed the drivers multiple times.

    I also run the Windows troubleshooter and FixIt tool. Both did not report problems.

    I tried various applications, Office 2007, Adobe Acrobat. Notepad. None can print.

    The printers show up on the Control Panel -- Devices and Pritners. I can see them on the print dialog box, just cannot "connect" to it from the Applications.

    Word gave the specific message (The Active Directory Domain Service is currently unavailable.) when clicking the Find Printers. Adobe just stopped working and quite when I tried to print.

    Really weird. Where do I turn on the Active Directory Domain Service? What is it anyway?



    Monday, December 05, 2011 6:33 AM
  •   I'm having the same problem with my computer not communicating with my canon printer.  All of a sudden (about 2 weeks ago), it just quite working.  Nothing had been changed.  I tried the above two options (troubleshooter and a fix program) which stated that no errors were detected, but still the problem exists.  Can you please help me!


    Monday, December 26, 2011 8:17 PM
  • Were you able to figure out the problem?  I'm having the same issue and can't seem to find help.



    Wednesday, December 28, 2011 7:04 PM