none
Remote Desktop Licensing Protocol error

    Question

  • I have spent the last 4 hours looking for solution online including Microsoft sites. So unless you have an EXACT match of solution to problem DO NOT tell me to TRY this or that in any article as I have probably already read it or tried it. 

    OK onto the issue.

    Brand new 2008 R2 SP1 standard Dell server. All updates applied. Joined as a stand alone server to domain. Remote desktop role installed. License server role installed. License server activated. 10 Per User RD (open License) Cals installed. Remote Desk Host Diagnostics gives clean bill of health. No other roles etc. installed. This is strictly a TS server.

    Workstations are Wyse thin clients running Windows 7 Embedded. They can see all allowed resources on domain. they can get to the internet as well. network connectivity and navigation confirmed.

    So.... When I start up RDP client on said terminals I get error of: The remote computer disconnected the session becase of an error in the licensing protocol.

    Remeber this is a Windows 7 embedded. hacks to registry or file copy from other OSes do not apply.

    And yes I checked with Wyse support.

    other Misc data:

     No firewall activated on server

    using the administrator account to attempt logon as it is already included in group. (Should not matter as it is a LICENSING  PROTOCOL error anyway)

    It is part of a 2003 domain.

    No I have not edited GP on 2003 system.

    Yes the event log has been reviewed. I see NO entries for this issue.

     

    IDEAS?????

     

     

    Thursday, May 19, 2011 6:39 PM

Answers

  • Issue Resolved.

    With Windows 7 the security settings for a regular user are severe. What would have worked for Vista and previous will not work with Windows 7. To get this to work you must log in as the administrator on Wyse terminal. (hold down shift key when selecting logoff.) choose Administrator on logon screen. Password (default) Wyse#123 (case sensitive). Disable write protect. (There is a shortcut for it on the desktop.) System will restart automatically. Logon to Wyse terminal  administrator again. Setup your RDP session for your terminal server. You should now be able to connect to your 2008 per user licensed terminal server. Log out of administrator on Wyse terminal. Log into Wyse terminal as a regular user. Repeat the process of RDP setup. Verify connection. Log off and go back into Administrator on wyse terminal. Re-enable write protect. Log off Wyse Terminal administrator and log back into it as the user. Verify that RDP session to your Terminal server still works. 

     

    What happens is that the registry entries are  write protected in windows 7 embedded, even in administrator mode. You must use the Wyse supplied utility to enable and disable this.

     

    2008 Terminal server licensed as per user on a MS 2003 domain. (not SBS)

    Wyse C90LE7 embedded windows 7

     

     

    • Marked as answer by VMX Tech Tuesday, June 07, 2011 2:45 PM
    Tuesday, June 07, 2011 2:41 PM
  • Hi,

    Are your comments regarding reviewing the original post directed at me?

    On your thin clients, do you not have the ability to run the Remote Desktop Client as an Administrator?  I have not used Windows 7 embedded at all let alone the specific build you are using so I do not know.

    What I am trying to do is rule out a permission problem with your thin clients.  When connecting to a Per User RDSH server a user should not need to modify the local registry, however, in a small number of cases I have seen where it needs read/write access to the MSLicensing key.  If it did not have enough permissions to the key it would fail with the error you are receiving.  Based on everything that you are seeing this (unique issue) would be the likely culprit.

    Have you updated the Wyse image to the latest version available on one thin client as a test?

    For reference, is the Wyse image based on Windows 7 RTM or Windows 7 SP1?

    Have you connected to the registry on one of the thin clients and checked permissions on the MSLicensing key?

    Have you opened a case with Wyse regarding this issue?  If they try and pretend like it is a normal RDS licensing problem please explain to them that you are using Per User licensing and your full XP and Windows 7 machines work fine.  The error in licensing protocol is almost exclusively seen in Per Device environments.  In a Per User environment you will see it if the server was unable to contact the licensing server, but that is not what is happening in your case.

    Thanks.

    -TP

    Tuesday, May 24, 2011 4:32 PM
    Moderator

All replies

  • Hi,

    In RD Session Host Configuration (tsconfig.msc) have you set the License mode to Per User, and specified your RD License server (set it to itself)?

    -TP

    Thursday, May 19, 2011 6:44 PM
    Moderator
  • Yes. I have followed MS documents acquired from Technet. I have used the diagnostic utility built into the RD session host MMC. I get no errors. All green check marks.
    Thursday, May 19, 2011 7:50 PM
  • Hi,

    Are you able to connect to your Server 2008 R2 SP1 from a windows XP workstation, or one of your 2003 servers?

    On the machines that are seeing the error, have you tried right-clicking on the Remote Desktop Connection Client and choosing Run as Administrator?

    Thanks.

    -TP

    Thursday, May 19, 2011 9:28 PM
    Moderator

  • You say there's no Firewall service on the server, is there a firewall between your clients and the server?  A protocol error would typically indicate either a problem with the physical connection, a problem with Firewall rules restricting some or part of the connectivity, or the software listening for the incoming connection is misconfigured or not running at all.  What network infrastructure resides between Clients and the server?

    Given your decription, you're probably tried to telnet to all the required ports listening on the server? 

    To learn anything of value from this, perform the test from the physical network connection that your thin client is using.

    if you can Telnet successfully, then you will probably find an issue at the server itself.

     

    Friday, May 20, 2011 3:12 AM
  • Again, Please review original post. It has all the relevant info.

    Answers too above posts:   

    Firewall: The Firewall on the server has already been deactivated for troubleshooting purposes.

    Network: Both are on internal network with no Firewall between the two. Infact they are in the same room on the same switch.  Both have network connectivity and can browse internal and external objects.

    Telnet to ports from thin client successful.

    Created a test user account just for RDP troubleshooting.

    RDP from Full OS XP clients and windows 7 do not have issues.

    These are Thin clients (Wyse C90LE7) with Windows 7 embedded. Steps suggested to take for workstation WILL NOT work with Windows 7 embedded. ONLY for full windows 7 client. 

     

     

    Tuesday, May 24, 2011 3:37 PM
  • Hi,

    Are your comments regarding reviewing the original post directed at me?

    On your thin clients, do you not have the ability to run the Remote Desktop Client as an Administrator?  I have not used Windows 7 embedded at all let alone the specific build you are using so I do not know.

    What I am trying to do is rule out a permission problem with your thin clients.  When connecting to a Per User RDSH server a user should not need to modify the local registry, however, in a small number of cases I have seen where it needs read/write access to the MSLicensing key.  If it did not have enough permissions to the key it would fail with the error you are receiving.  Based on everything that you are seeing this (unique issue) would be the likely culprit.

    Have you updated the Wyse image to the latest version available on one thin client as a test?

    For reference, is the Wyse image based on Windows 7 RTM or Windows 7 SP1?

    Have you connected to the registry on one of the thin clients and checked permissions on the MSLicensing key?

    Have you opened a case with Wyse regarding this issue?  If they try and pretend like it is a normal RDS licensing problem please explain to them that you are using Per User licensing and your full XP and Windows 7 machines work fine.  The error in licensing protocol is almost exclusively seen in Per Device environments.  In a Per User environment you will see it if the server was unable to contact the licensing server, but that is not what is happening in your case.

    Thanks.

    -TP

    Tuesday, May 24, 2011 4:32 PM
    Moderator
  • Issue Resolved.

    With Windows 7 the security settings for a regular user are severe. What would have worked for Vista and previous will not work with Windows 7. To get this to work you must log in as the administrator on Wyse terminal. (hold down shift key when selecting logoff.) choose Administrator on logon screen. Password (default) Wyse#123 (case sensitive). Disable write protect. (There is a shortcut for it on the desktop.) System will restart automatically. Logon to Wyse terminal  administrator again. Setup your RDP session for your terminal server. You should now be able to connect to your 2008 per user licensed terminal server. Log out of administrator on Wyse terminal. Log into Wyse terminal as a regular user. Repeat the process of RDP setup. Verify connection. Log off and go back into Administrator on wyse terminal. Re-enable write protect. Log off Wyse Terminal administrator and log back into it as the user. Verify that RDP session to your Terminal server still works. 

     

    What happens is that the registry entries are  write protected in windows 7 embedded, even in administrator mode. You must use the Wyse supplied utility to enable and disable this.

     

    2008 Terminal server licensed as per user on a MS 2003 domain. (not SBS)

    Wyse C90LE7 embedded windows 7

     

     

    • Marked as answer by VMX Tech Tuesday, June 07, 2011 2:45 PM
    Tuesday, June 07, 2011 2:41 PM
  • Disable UAC on the CLient Machine.

    or Delete the MSLisencing "HKLM\Software\microsoft\Mslicensing" key from the workstation and reboot it.

    next time when you logon Pullup the RDC with Elevated Rights --> RDc --Right click---Run as Admin.

    it will generate anew MsLisencing key inside Registry "HKLM\Software\microsoft\Mslicensing" it would work for next 90 days until you would pull up the RDP for the next time.

    If an unlicensed client connects to a Terminal Server for the first time, the Terminal Server issues the client a temporary Terminal Server Client Access License (CAL) token. After the user has logged into the session, the Terminal Server instructs the License Server to mark the issued temporary Terminal Server CAL token as being validated. The next time the client connects, an attempt is made to upgrade the validated temporary Terminal Server CAL token to a full Terminal Server CAL token. If no license tokens are available, the temporary Terminal Server CAL token will continue to function for 90 days. The license is stored in the client's registry. 

     

    Thursday, August 11, 2011 8:16 PM
  • this worked for me, as I am the admin. i needed to rdp from a thin client, read the other articles and found you cannot edit microsoft licenses from the registry. this is a good workaround for an admin, not so much a user.

    thanks! 

     
    Saturday, January 25, 2014 8:26 PM