none
Storage Migration Service RRS feed

  • Question

  • Hello everyone.

    I'm testing the new roles Storage Migration Service with a source server win2008 R2 to a dest server 2019. My orchestrator is also a WS2019.

    I got "Passed" in all checks/validations. When I click to start the transfer it keeps "running" and end up with an error Couldn't transfer storage on any of the endpoints.

    I've already tried to fully disable Win Firewall but with no luck. 

    At the eventlog there's I got these events ( 3503, 3509 and 3515) with the same message

    Couldn't transfer storage.
    
    Job: aaaa
    ID: cafba47b-9b20-4f11-abd9-634d6dd6b3ab
    State: Failed
    Error: 36931
    Error Message: 
    
    Guidance: Check the detailed error and make sure the transfer requirements are met. The transfer job couldn't transfer any source and destination computers. This could be because the orchestrator computer couldn't reach any source or destination computers, possibly due to a firewall rule, or missing permissions.

    Any advice?

    Regards


    Nathan Pinotti MCTS Infra | CCNA | CAPM | ITILv3

    Tuesday, November 6, 2018 2:03 AM

All replies

  • Hi Nathan


    Ever found a solution to it?
    Because I'm seeing the same in some cases.


    Best regards, Daniel...

    Tuesday, February 5, 2019 7:43 AM
  • Hi, I am sorry you were unable to transfer your endpoints properly.  You say you disabled all firewalls, did you do that on all machines necessary (you should only need to disable specific firewall rules depending on which computer).  The necessary firewalls to disable for each computer are defined here: https://docs.microsoft.com/en-us/windows-server/storage/storage-migration-service/overview under Security Requirements.

    Additionally there are certain endpoints that we do not transfer, such as Windows, Program Files, Program Files (x86), Program Data, Users (a full list can be found here: https://docs.microsoft.com/en-us/windows-server/storage/storage-migration-service/faq) Please make sure that those are not the end points you are trying to transfer.

    Finally if you are still unable to complete your Transfer please contact Microsoft Support and open a ticket.  They will be better able to help you directly as well as handle any logs you wish to provide them in the appropriate manner so that your issue can be resolved.  https://support.microsoft.com/en-us/gp/contactus81?forceorigin=esmc&audience=commercial

    Tuesday, February 26, 2019 6:51 PM
  • Nathan, did You resolve this problem ? I have same error when I try to migrate shares from 2003 r2 to 2019. I got "Passed" every tests too and at final step I got "Couldn't transfer storage on any of the endpoints." error.
    Thursday, March 28, 2019 8:04 PM
  • Hello,

    There was a bug that under certain conditions prevented all endpoints from being transferred despite passing validation.  More information about that bug can be found https://docs.microsoft.com/en-us/windows-server/storage/storage-migration-service/known-issues#certain-files-do-not-inventory-or-transfer-error-5-access-is-denied.  That has been fixed as of the 2019.03 D update.  Please make sure your Orchestrator and Proxy machines are up to date with the latest version of Windows Server 2019 and try again.  Hopefully that resolves your issue of being unable to transfer your endpoints.

    Eric

    Wednesday, May 8, 2019 6:36 PM
  • Hi Eric,

    What do you mean by "fixed as of the 2019.03 D update"? What is that? I am having issues with the transfers. I posted a new question in this forum but would like to get this answer from you, thanks!

    Friday, June 28, 2019 3:27 PM
  • Hi bvi1998,

    3D refers to the OS update.  Typically MS puts out updates twice a month with the number referring to the month (so the March D package).  The B packages contain security updates and the D packages contain feature updates, however each package contains all cumulative updates i.e. going from 4B to 6D would give you everything new in the 4D, 5B, 5D and 6B packages without having to install each separately.

    That said there are two issues I think being discussed in this thread.  If you are experiencing an error that says there was a failure to transfer all endpoints and the server in question is 2008R2 then that likely means there is a problem with your 2008R2 server and the suggested fix is to make sure your 2008R2 is up to date with all critical and important updates.

    If the issue is on other versions of Windows Server sources there was an issue with the Storage Migration service which is what I was discussing earlier being fixed as of the Windows Server 2019 March D update.  In either case we recommend keeping all servers up to date with updates but if you experience issues with a 2008R2 source it is likely the source that needs to have updates installed, if your issue is on other source versions then more likely you need to update your Orchestrator OS.

    Here is a list of all known issues with Storage Migration service as well as potential work arounds. https://docs.microsoft.com/en-us/windows-server/storage/storage-migration-service/known-issues

    Please let me know if that fixes your issues.

    Eric


    Wednesday, July 3, 2019 10:03 PM
  • Boa noite! 

    Segue o link do artigo não qualificado de funcionamento do Serviço de Migração de Armazenamento.

    http://cooperati.com.br/2018/10/15/storage-migration-service/


    Att. Gabriel Luiz

    Thursday, July 4, 2019 3:06 AM
  • You also have to have access to the shares. That is possibly the issue you’re having....
    Thursday, July 4, 2019 5:07 AM
  • Thanks Eric. Turns out that I needed to have read access to the shares. I was told that that information will get put into the documentation. I was also told that on the roadmap the products will not require this in the future. Thx
    Thursday, July 4, 2019 5:09 AM
  • Hi,

    Have the error, with WS2019, OS Build 17763.557.

    Source server WS2016, destination WS2019.

    Any idea?

    Thanks.

    Florent

    Thursday, July 4, 2019 6:28 AM