none
Can't flush DNS cache in Windows Server 2012 R2 RRS feed

  • Question

  • Hello all.

    We have a WSFC cluster for MS SQL AlwaysOn. There are three servers in the cluster, each server has two ethernet adapters: first one "public" for application usage and second one "private" for cluster only usage. All nics has correct static ip addresses: 192.168.104.0/24 for public and 192.168.79.0/24 for private.

    Servers may register their names in DNS only for their public ip addresses and may not register for private (Disabled option "Register this connection's addresses in DNS").
    That private adapter has only "TCP/IPv4" and "Microsoft Failover Cluster Virtual Adapter Performance Filter" enabled and should not participate in applications traffic.

    However from time to time one of the servers shows some unusual behaviour: if you ping its name locally you have got answer from private ip address. I.e. "nslookup servername3" returns 192.168.104.23, and "ping servername3" returns 192.168.79.23.
    Making static record in the windows hosts file "192.168.104.23 servername1" doesn't help. Ipconfig /flushdns doesn't help either.
    The name "servername3" resolves correctly "192.168.104.23" from all other hosts, this behaviour happens only locally.

    What should we do to make sure server resolves its name correctly, i.e. 192.168.104.23 only?
    Tuesday, July 9, 2019 10:28 AM

Answers

  • Hello,

    Thank you for posting in this forum.

    Go to NIC properties of 192.168.104.23->TCP/IPv4->Proterties->Advanced, then uncheck Automatic metric and modify Interface metric to 10.

    Do the same on NIC of 192.168.79.23 and modify Interface metric to 20.

    Best Regards,

    Leon


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, July 10, 2019 5:45 AM