none
Windows Server 2008 R2 Stuck in update loop can't get new updates error code 8000FFFF

    Question

  • I have a 2008 R2 Standard server (on VMware) that is stuck without being able to update.

    Behavior:

    Windows update fails on check for new updates error code 8000FFFF.

    When rebooting, server attempts to configure updates. Reboots to login screen, then shuts down and reboots a second time. At that point it attempts to configure updates (stops at 35%) and then displays the error "Error installing updates. Reverting changes." then we get to the login screen. Every restart or shut down exhibits this behavior.

    I cannot run "sfc /scannow" i get the error:

    There is a system repair pending which requires reboot to complete.  Restart Windows and run sfc again

    I have run the System Update Readiness Tool from this webpage: https://support.microsoft.com/en-us/help/947821/fix-windows-update-errors-by-using-the-dism-or-system-update-readiness

    CheckSUR.log:


    =================================

    Checking System Update Readiness.

    Binary Version 6.1.7601.22471

    Package Version 26.0

    2019-05-14 15:49


    Checking Windows Servicing Packages


    Checking Package Manifests and Catalogs


    Checking Package Watchlist


    Checking Component Watchlist


    Checking Packages


    Checking Component Store


    Summary:

    Seconds executed: 4557

     No errors detected

    (w) Unable to get system disk properties    0x0000045D  IOCTL_STORAGE_QUERY_PROPERTY    Disk Cache  

    I have tried deleting files from the %windir/SoftwareDistribution/Download & DataStore.

    I have tried stopping & starting (confirmed automatic delayed start) BITS, Windows Installer & Windows Update service.

    I tried removing registry keys: HKLM/Software/Microsoft/Windows/CurrentVersion/WindowsUpdate HKCU/Software/Microsoft/Windows/CurrentVersion/WindowsUpdate

    Nothing appears to work. I still get the 8000FFFF error and the constant attempt to install some phantom update that doesn't exist and reboots twice then reverts.

    Any help would be greatly appreciated! Thanks in advance.
    Wednesday, May 22, 2019 2:48 PM

All replies