locked
Keyboard layout wrong on logon screen, but fine on desktop...??

    Question

  • Took  me ages to troubleshoot this problem, which I found when I tried to logon via rdp to server with administrator account.... It kept saying wrong username or password...

    After much trial and error, it would appear that on the logon screen my keyboard layout differs from when I am in the desktop.. All setting are set to UK layout, but I think on the logon screen the keyboard is set to US....  Ive figured this due to some of the characters being on the wrong keys!!!

    How can I change this...??  Is this a bug???
    DrSoton
    Wednesday, November 11, 2009 3:54 PM

Answers

  • Found the answer, eventually!!

    http://windowsitpro.com/article/articleid/14867/how-do-i-configure-the-default-keyboard-layout-during-login.html

    A. You can change the keyboard layout using the keyboard control panel applet (start - settings - control panel - keyboard - Input Locales) however this does not affect the layout used during logon (which is by default English (United States)). To change this perform the following:

    1. Start the registry editor  (regedit.exe)
    2. Move to HKEY_USERS\.DEFAULT\Keyboard Layout\Preload
    3. Double click on 1 and change the number to your local layout (you could get this by looking at HKEY_CURRENT_USER\Keyboard Layout\Preload1). Click OK

    DrSoton
    • Marked as answer by DrSoton Wednesday, November 11, 2009 8:02 PM
    Wednesday, November 11, 2009 8:00 PM

All replies

  • Hi,

    Check what layout you have on the client PC, I assume it is US.

    сила в справедливости
    Wednesday, November 11, 2009 4:04 PM
  • Fine on client pc...

    I found the problem by typing my password in the username box on the server (so I could see it).. and then again on the desktop.. and they are different..  The charactors in quesiton are on different keys on the UK and US keyboards...


    DrSoton

    Just trid typing them again to confirm, and it is correct....

    The password I type in the username box is different from when I type it on the deslktop, and these are a few of the known differences between us and uk keyboard layouts...
    Wednesday, November 11, 2009 4:22 PM
  • Found the answer, eventually!!

    http://windowsitpro.com/article/articleid/14867/how-do-i-configure-the-default-keyboard-layout-during-login.html

    A. You can change the keyboard layout using the keyboard control panel applet (start - settings - control panel - keyboard - Input Locales) however this does not affect the layout used during logon (which is by default English (United States)). To change this perform the following:

    1. Start the registry editor  (regedit.exe)
    2. Move to HKEY_USERS\.DEFAULT\Keyboard Layout\Preload
    3. Double click on 1 and change the number to your local layout (you could get this by looking at HKEY_CURRENT_USER\Keyboard Layout\Preload1). Click OK

    DrSoton
    • Marked as answer by DrSoton Wednesday, November 11, 2009 8:02 PM
    Wednesday, November 11, 2009 8:00 PM