none
Using a Intel NUC I7 can't seem to get the NIC (Ethernet Adapter) to show on native VHD boot using the generated image RRS feed

  • Question

  • I tried building the Nano image using the Drivers extra folder, but still no Ethernet adapter found in the nano console.

    System HW:

    http://www.intel.com/content/www/us/en/nuc/nuc-kit-nuc5i7ryh.html

    Command Line used to build the native boot Nano image:

    New-NanoServerImage -MediaPath D:\   -BasePath .\Base -TargetPath c:\VHDs\Nano\NanoServer-custom.vhd -ComputerName Nano-srvr1 -Compute -Storage -Cluster -OEMDrivers -DriversPath c:\NanoServer-new\Drivers\extras

    C:\NanoServer-new>dir Drivers\extras
     Volume in drive C has no label.
     Volume Serial Number is FC98-6CD4

     Directory of C:\NanoServer-new\Drivers\extras

    12/09/2015  10:08 PM    <DIR>          .
    12/09/2015  10:08 PM    <DIR>          ..
    09/10/2015  12:34 AM            14,033 e1c64x64.cat
    08/18/2015  11:46 AM             3,114 e1c64x64.din
    08/18/2015  11:46 AM            92,363 e1c64x64.inf
    08/12/2015  03:26 PM           472,048 e1c64x64.sys
    09/10/2015  12:34 AM            14,025 e1c65x64.cat
    08/18/2015  11:47 AM             3,113 e1c65x64.din
    08/18/2015  11:47 AM            91,661 e1c65x64.inf
    08/12/2015  03:27 PM           472,048 e1c65x64.sys
    04/02/2015  04:46 AM            76,048 e1cmsg.dll
    09/01/2015  12:45 PM            16,558 e1d64x64.cat
    08/13/2015  02:14 AM             3,130 e1d64x64.din
    08/13/2015  02:14 AM           128,291 e1d64x64.inf
    08/13/2015  02:12 AM           529,904 e1d64x64.sys
    09/01/2015  12:45 PM            15,032 e1d65x64.cat
    08/13/2015  02:13 AM             3,130 e1d65x64.din
    08/13/2015  02:13 AM           128,374 e1d65x64.inf
    08/13/2015  02:14 AM           531,424 e1d65x64.sys
    04/02/2015  04:46 AM            75,288 e1dmsg.dll
    07/04/2015  09:43 AM            17,742 e1r64x64.cat
    06/18/2015  02:11 AM             3,097 e1r64x64.din
    06/18/2015  02:11 AM           176,198 e1r64x64.inf
    06/18/2015  12:42 AM           523,248 e1r64x64.sys
    07/04/2015  09:43 AM            16,920 e1r65x64.cat
    05/04/2015  05:23 PM             3,096 e1r65x64.din
    05/04/2015  05:23 PM           139,821 e1r65x64.inf
    04/21/2015  01:02 AM           486,344 e1r65x64.sys
    04/02/2015  04:46 AM            75,288 e1rmsg.dll
    07/06/2015  10:23 AM            11,729 e1s64x64.cat
    06/05/2015  02:07 AM             3,097 e1s64x64.din
    06/05/2015  02:07 AM            44,389 e1s64x64.inf
    06/05/2015  01:08 AM           522,736 e1s64x64.sys
    06/05/2015  01:37 AM            76,784 e1smsg.dll
    05/26/2009  10:05 AM            36,472 NicCo36.dll
    04/18/2014  01:17 PM           125,728 nicco4.dll
    02/25/2015  04:23 AM            89,872 NicInE1R.dll
    12/06/2013  06:09 AM            91,936 NicInE1S.dll
    02/25/2015  04:23 AM            89,144 NicInstC.dll
    06/17/2015  01:28 AM            90,608 NicInstD.dll
    05/08/2013  03:51 AM            80,672 NicInVQ.dll
    09/23/2015  02:19 PM           405,472 PROUnstl.exe
    12/09/2015  10:08 PM            28,994 ql2300.cat
    12/09/2015  10:08 PM         1,633,072 ql2300.sys
    12/09/2015  10:08 PM            22,076 ql2x00.inf
    12/09/2015  10:08 PM             9,216 qlco.dll
    12/09/2015  10:08 PM            11,264 qlcox64.dll
    12/09/2015  10:08 PM           163,328 qlfcx64.exe
    12/09/2015  10:08 PM                24 QLOGIC
    12/09/2015  10:08 PM           237,056 Qlpropx64.dll
    12/09/2015  10:08 PM           233,472 QLSDM.DLL
    12/09/2015  10:08 PM           290,816 QLSDMx64.DLL
    07/18/2015  01:39 AM             1,028 readme.txt
    12/09/2015  10:08 PM             6,501 txtsetup.oem
    07/22/2013  11:06 AM            11,897 v1q64x64.cat
    03/26/2013  08:21 AM             2,743 v1q64x64.din
    07/17/2013  04:34 PM            22,579 v1q64x64.inf
    07/17/2013  04:34 PM           131,344 v1q64x64.sys
    06/20/2013  04:09 AM            73,480 v1qmsg.dll
                  57 File(s)      8,658,867 bytes
                   2 Dir(s)  106,862,862,336 bytes free

    What drivers should be used form Intel:  Windows 8.1/Windows 10.  I already understand that x64 signed is required.

    The adapter in the NUC is a Intel Pro 1000 that works fine under Windows 8.1/10.0.

    From Windows 8.1:

    PS C:\Windows\system32> Get-NetAdapter -Physical

    Name                      InterfaceDescription                    ifIndex Status       MacAddress             LinkSpeed
    ----                      --------------------                    ------- ------       ----------             ---------
    Ethernet                  Intel(R) Ethernet Connection (3) I218-V       5 Up           B8-AE-ED-75-E3-3A         1 Gbps

    Note 1:  Also when there are no adapters detected when you select Networks from the Nano console there seems to be a crash when you hit enter where it asks you to select an adapter.

    Note 2:  Why is the Intel Pro 1000 not included in the OEM drivers?  Seems like a standard system NIC.

    Note 3:  I am using the recent Technical Preview 4 off the MSDN.

    Thanks,

    Rick

    Thursday, December 10, 2015 5:30 AM

Answers

  • The above link works if you can sign your own cat files.

    Thanks,

    Rick


    Rick Hicksted

    • Marked as answer by rhicksted Wednesday, December 16, 2015 5:50 AM
    Wednesday, December 16, 2015 5:50 AM

All replies

  • Here is the bcdedit -v output:

    Windows Boot Loader
    -------------------
    identifier              {d67b82f4-19c6-11e5-92d6-dc4d6b05f8f9}
    device                  vhd=[C:]\VHDs\Nano\NanoServer-custom.vhd,locate=custom:1
    2000002
    path                    \Windows\system32\boot\winload.efi
    description             Nano Server Technical 4
    locale                  en-us
    inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
    isolatedcontext         Yes
    allowedinmemorysettings 0x15000075
    osdevice                vhd=[C:]\VHDs\Nano\NanoServer-custom.vhd,locate=custom:2
    2000002
    systemroot              \Windows
    resumeobject            {6185cf42-9ef9-11e5-a7d0-806e6f6e6963}
    nx                      OptIn
    bootmenupolicy          Standard
    hypervisorlaunchtype    Auto
    ems                     No


    Rick Hicksted

    Thursday, December 10, 2015 5:33 AM
  • Hi Rick,

    Is the system booting but you have no networking? if not, can you please share the error you are getting? Do you have video attached and does the Recovery Console show any networking?

    You should be using the Win10 or a WS16 version of the driver.

    Thanks,

    Andrew

    Friday, December 11, 2015 7:58 PM
  • It is booting fine, but no network card seen.  I even trued a USB ethernet card.

    I did put the W10 driver in the drivers extra folder when building the image.

    Thanks for any pointers,


    Rick


    Rick Hicksted

    Here are some pics:

    Console after loggin in.

    No adapters found.

    Using the arrow key I see a crash

    • Edited by rhicksted Monday, December 14, 2015 4:48 AM
    Sunday, December 13, 2015 10:36 PM
  • Hi Rick,

    From the directory listing above, it looks like you have a mix of the Win8.1/WS12R2 drivers and the Win10 drivers. Can you try with just the Win10 drivers? It looks like the set under Pro1000\Winx64\NDIS64 are the ones you want.

    Thanks,

    Andrew

    Monday, December 14, 2015 4:21 PM
  • Still does not work with just the WIN10 NIC drivers.

    I am going to try this one:

    http://deploymentresearch.com/Research/Post/517/Deploying-Windows-Server-2016-to-Intel-NUC-devices

    Thanks,


    Rick


    Rick Hicksted

    • Marked as answer by rhicksted Wednesday, December 16, 2015 5:44 AM
    • Unmarked as answer by rhicksted Wednesday, December 16, 2015 5:50 AM
    Wednesday, December 16, 2015 3:32 AM
  • The above link works if you can sign your own cat files.

    Thanks,

    Rick


    Rick Hicksted

    • Marked as answer by rhicksted Wednesday, December 16, 2015 5:50 AM
    Wednesday, December 16, 2015 5:50 AM
  • Hi Rick,

    Glad to hear you got it working. Thanks for sharing the link, I wasn't aware of that.

    Thanks,

    Andrew

    Wednesday, December 16, 2015 5:33 PM
  • Hi ,

    what cards can be user and are in the list ?

    I already tested on four different machines all with intel cards

    Thanks,

    Monday, December 28, 2015 1:59 PM