none
Configure Wallpaper Using Default HKCU Hive & Group Policy RRS feed

  • Question

  • Good day,

    I'm attempting to use the new features of Group Policy Preferences to configure settings on a desktop via the registry.  Here is what I am attempting to accomplish:

    Configure the Default Desktop Background via Group Policy for each user
    Allow the user to change the background if they desire
    Do not re-apply the configured background if we update other settings in the GPO

    I found that you should be able to accomplish this by enabling "Apply Once and do not reapply" for the particular registry setting.  The problem that I am having is that if I use the HKCU hive, the setting will apply for the first user that logs into the system and every other user will receive the default Windows 7 background.

    I'm wondering if it is possible to configure the HKEY_Users default hive once, and then every user that logs in will receive the background?

    Any help is greatly appreciated.


    Greg Frair
    Thursday, January 6, 2011 8:29 PM

Answers

  • Just so everyone is aware, I ended up setting the wallpaper in the default profile using the registry.  Just in case anyone else encountered the same frustration as myself, I was trying to use the following command:

    REG LOAD "HKU\DefUser" "C:\Users\Default Users\ntuser.dat"
    REG ADD "HKU\DefUser\Control Panel\Desktop" /v "Wallpaper" /d "C:\wallpaper.jpg"
    REG UNLOAD "HKU\DefUser"

    This would not work and was driving me insane, because I could change other registry settings using the same command.  I discovered that it was the theme that was overwriting my registry settings.   First I had to save a custom theme somewhere and then change my command to the following:

    REG LOAD "HKU\DefUser" "C:\Users\Default Users\ntuser.dat"
    REG ADD "HKU\DefUser\Control Panel\Desktop" /v "Wallpaper" /d "C:\wallpaper.jpg"
    REG ADD "HKU\DefUser\Software\Microsoft\Windows\CurrentVersion\Themes" /v "CurrentTheme" /d "C:\ThemeName.theme"
    REG UNLOAD "HKU\DefUser"

    Hope this helps other out.

    Thanks,


    Greg Frair
    • Marked as answer by gfrair Friday, January 7, 2011 10:33 PM
    Friday, January 7, 2011 10:33 PM

All replies

  • Hi,

    Do you know the "Desktop Wallpaper" Group Policy in the administrative template settings? You can set this setting to control the desktop wallpaper in the domain.

    User Configuration--->Policies--->Administrative Template--->Desktop--->Desktop--->Desktop wallpaper

    Friday, January 7, 2011 6:23 AM
    Moderator
  • Hi Miles,

    Yes I am aware of this setting.  The issue with this particular setting is that you cannot configure it to "Apply Once".  Therefore, if the users change their background to a custom background, and then we make a change to the GPO, all user's will revert back the original background.

    Doesn't sound like a big deal, but will result in a lot of calls to our support center.

    Any other suggestions?


    Greg Frair
    Friday, January 7, 2011 7:01 PM
  • Just so everyone is aware, I ended up setting the wallpaper in the default profile using the registry.  Just in case anyone else encountered the same frustration as myself, I was trying to use the following command:

    REG LOAD "HKU\DefUser" "C:\Users\Default Users\ntuser.dat"
    REG ADD "HKU\DefUser\Control Panel\Desktop" /v "Wallpaper" /d "C:\wallpaper.jpg"
    REG UNLOAD "HKU\DefUser"

    This would not work and was driving me insane, because I could change other registry settings using the same command.  I discovered that it was the theme that was overwriting my registry settings.   First I had to save a custom theme somewhere and then change my command to the following:

    REG LOAD "HKU\DefUser" "C:\Users\Default Users\ntuser.dat"
    REG ADD "HKU\DefUser\Control Panel\Desktop" /v "Wallpaper" /d "C:\wallpaper.jpg"
    REG ADD "HKU\DefUser\Software\Microsoft\Windows\CurrentVersion\Themes" /v "CurrentTheme" /d "C:\ThemeName.theme"
    REG UNLOAD "HKU\DefUser"

    Hope this helps other out.

    Thanks,


    Greg Frair
    • Marked as answer by gfrair Friday, January 7, 2011 10:33 PM
    Friday, January 7, 2011 10:33 PM