none
FQDN on logon screen, why? RRS feed

  • Question

  • Dear all,

    I've recently set up 2 windows servers, running server 2008 R2. At the login screen after your press CTRL ALT DEL it used to give the format:

    **OurDomainName\Administrator
    e.g. mydomain\Administrator

    However now it's for some reason giving the format:

    **OurFullyQualifiedDomainName\Administrator
    e.g. mydomain.internal\Administrator

    Being relatively new to windows server 2008, any help or advice would be greatly appreciated as to why this has suddenly changed.

    Many Thanks.
    Saturday, September 4, 2010 6:30 PM

Answers

  • Hi dcjg70,

     

    Thanks for post here.

     

    So have you got any issue when logon system by using just “administrator” ?

    By default system will record the last logon user name, so I suspect that this is because someone who last time locally or remotely logon this system was inputted this format username.

    You may like to check the audit log to verify.

     

    If you want to prevent this , modify the security setting could be done.

     

    Interactive logon: Do not display last user name

    http://technet.microsoft.com/en-us/library/cc785301(WS.10).aspx

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, September 7, 2010 4:01 AM

All replies

  • Please try to add a DNS suffix for your domain (Do it on the computer on which you have this problem):

    http://technet.microsoft.com/en-us/library/cc786695(WS.10).aspx

    Once added, check that NetBIOS over TCP/IP is enabled:

    http://ecross.mvps.org/howto/netbt.htm

    After that, try to open a session using mydomain\username

     

    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights

     

     

    Saturday, September 4, 2010 6:34 PM
  • This problem is on the Domain controller itself not a client, however from what you've put could it be that this is due to me enabling reverse lookups within DNS?

    Many Thanks for your reply.

    Saturday, September 4, 2010 7:50 PM
  • This problem is on the Domain controller itself not a client, however from what you've put could it be that this is due to me enabling reverse lookups within DNS?


    There is no reason so that enabling reverse lookups within DNS will cause a such issue.

    This is a problem due to NetBIOS resolution.

    Please perform what I mentioned in the previous reply on the domain controller.

     

    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights

    Saturday, September 4, 2010 7:55 PM
  • Hi Dcjg70,

    One of the reason for this is raise in the functional level of Windows Server 2008 domain/forest.  You probably need to ensure that the functional level you are running currently capable to resolve Netbios names.

    I am sure that it looks for FQDN only because Netbios resolution or support disable due to some reason.

    Please let us know in case we help you more in this.

    Regards,

    Tilak


    IT Consultant
    Sunday, September 5, 2010 6:10 AM
  • The servers are brand new, and are running Windows Server 2008 R2 both with a Forrest Functional level of Server 2008 R2

    I've checked the Netbios for the adpaters and they both say that Netbios is on default.

     

    This issue is strange, as all was well and this is a clean install of Windows server 2008 R2.

     

    On the logon screen I just don't understand why it used to say:

    Domainname\Administrator

    and now its adding .internal to the end so it looks like this Domainname.internal\Administrator

     

    Any help would be greatly appreciated.

    Sunday, September 5, 2010 1:10 PM
  • The servers are brand new, and are running Windows Server 2008 R2 both with a Forrest Functional level of Server 2008 R2

    Based on that article, I don't think it is a problem with your Functional level:

    http://technet.microsoft.com/en-us/library/cc771132%28WS.10%29.aspx

    Have you tried what I told you?

    You still not told me the result.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Sunday, September 5, 2010 1:17 PM
  • Hi dcjg70,

     

    Thanks for post here.

     

    So have you got any issue when logon system by using just “administrator” ?

    By default system will record the last logon user name, so I suspect that this is because someone who last time locally or remotely logon this system was inputted this format username.

    You may like to check the audit log to verify.

     

    If you want to prevent this , modify the security setting could be done.

     

    Interactive logon: Do not display last user name

    http://technet.microsoft.com/en-us/library/cc785301(WS.10).aspx

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, September 7, 2010 4:01 AM