none
Error message on RD Web Access for Server 2012

    Question

  • I had been testing a RD Web Access site for the past few months without any problems. Then on Monday 8/19/2013 we went live with the site and got the following error message:

    Error: Unable to display RD Web Access

    An unexpected error has occurred that is preventing this page from being displayed correctly.

    Viewing this page in Internet Explorer with the Enhanced Security Configuration enabled can cause such an error.

    Please try loading this page without the Enhanced Security Configuration enabled. If this error continues to be displayed, please contact your administrator.

    bFormAuthenticationMode = false; iSessionTimeout = parseInt("0"); RemoteApp and Desktops Connect to a remote PC  redirectclipboard%3Ai%3A1%0D%0Aredirectprinters%3Ai%3A1%0D%0Aredirectcomports%3Ai%3A1%0D%0Aredirectsmartcards%3Ai%3A1%0D%0Adevicestoredirect%3As%3A*%0D%0Adrivestoredirect%3As%3A*%0D%0Aredirectdrives%3Ai%3A1%0D%0Asession%20bpp%3Ai%3A32%0D%0Aprompt%20for%20credentials%20on%20client%3Ai%3A1%0D%0Aspan%20monitors%3Ai%3A1%0D%0Ause%20multimon%3Ai%3A1%0D%0Aremoteapplicationmode%3Ai%3A1%0D%0Aserver%20port%3Ai%3A3389%0D%0Aallow%20font%20smoothing%3Ai%3A1%0D%0Apromptcredentialonce%3Ai%3A1%0D%0Aauthentication%20level%3Ai%3A2%0D%0Agatewayusagemethod%3Ai%3A1%0D%0Agatewayprofileusagemethod%3Ai%3A1%0D%0Agatewaycredentialssource%3Ai%3A0%0D%0Afull%20address%3As%3ASERVER.DOMAIN.LOCAL%0D%0Aalternate%20shell%3As%3A%7C%7CAppLauncher%0D%0Aremoteapplicationprogram%3As%3A%7C%7CAppLauncher%0D%0Agatewayhostname%3As%3ASERVER.DOMAIN.LOCAL%0D%0Aremoteapplicationname%3As%3ARemoteApplication%0D%0Aremoteapplicationcmdline%3As%3A%0D%0Aworkspace%20id%3As%3ASERVER.DOMAIN.local%0D%0Ause%20redirection%20server%20name%3Ai%3A1%0D%0Aloadbalanceinfo%3As%3Atsv%3A//MS%20Terminal%20Services%20Plugin.1.RemoteApps%0D%0Aalternate%20full%20address%3As%3ASERVER.DOMAIN.LOCAL%0D%0Asignscope%3As%3AFull%20Address%2CAlternate%20Full%20Address%2CUse%20Redirection%20Server%20Name%2CServer%20Port%2CGatewayHostname%2CGatewayUsageMethod%2CGatewayProfileUsageMethod%2CGatewayCredentialsSource%2CPromptCredentialOnce%2CAlternate%20Shell%2CRemoteApplicationProgram%2CRemoteApplicationMode%2CRemoteApplicationName%2CRemoteApplicationCmdLine%2CAuthentication%20Level%2CRedirectDrives%2CRedirectPrinters%2CRedirectCOMPorts%2CRedirectSmartCards%2CRedirectClipboard%2CDevicesToRedirect%2CDrivesToRedirect%2CLoadBalanceInfo%0D%0Asignature%3As%3AAQABAAEAAADLBAAAMIIExwYJKoZIhvcNAQcCoIIEuDCCBLQCAQExCzAJBgUrDgMC%20%20GgUAMAsGCSqGSIb3DQEHAaCCAzcwggMzMIICG6ADAgECAhAZuGCjm7z1i0q93/UJ%20%2038iEMA0GCSqGSIb3DQEBCwUAMB0xGzAZBgNVBAMMEkFSVEVNSVMuSU5IUC5MT0NB%20%20TDAeFw0xMzAzMTkxNjU1MDNaFw0xNDAzMTkxNzE1MDNaMB0xGzAZBgNVBAMMEkFS%20%20VEVNSVMuSU5IUC5MT0NBTDCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEB%20%20ALYupsSytMTjfTB0uOb9UpCJE0oeHKEpfSAVCFZm/GUvlJCZeid2zBrzWnlLQ82t%20%20Hx/pvNNN6hTXzCd98cnAuz5zh2e5WGrE7k6nVDT87LuEapJE45UQ8QP5ZIRbup6B%20%20mVdxGmAHAoKfIozeFXSh8IzhhUlKCZRbjM33d6t/4wFl3ka9/zIDzNUWeU/BbuIU%20%20BlNYCCYfGwwQIcCXt1uvHkWv8RHIPCVKip7U7xoWVo9O/cnmDZKJaahLf/c/i4Sj%20%20pXkmitzwoiGf8Y/UeNxqAAHHncGpY7GIPkUu8JIlS0DPe11y+VaLimGLKEHN4Dvp%20%20MUk16rumsqGm0NtMfGIR6dMCAwEAAaNvMG0wDgYDVR0PAQH/BAQDAgWgMB0GA1Ud%20%20JQQWMBQGCCsGAQUFBwMCBggrBgEFBQcDATAdBgNVHREEFjAUghJBUlRFTUlTLklO%20%20SFAuTE9DQUwwHQYDVR0OBBYEFFlCRWgRnztrhSivTm/EyZSmwLQMMA0GCSqGSIb3%20%20DQEBCwUAA4IBAQBZ8I/Mb0+RlOzi/diSFWcRG9wC7xIWKdNKxP5ZgobDgwvNXGk+%20%20sectw7IQLKe34rxUKlGpys3eVWwKjQKV1jg6X4UxFzfFxnJ8M2A9wBpwG7kEYTsg%20%20vT6b8PSC2klGNg3E7isUQqownXJDpTeIx8JC2fjWRUIcbVWkJb6JKBz05NLIM8Oe%20%20//pQWhMY4pwttWoChJBhc9zaP5lRqFiNZXoGyLoiMdf9bwtxj1+IJeGTgTozGcuc%20%208W8npi5zQ6HbJE1LdpDHXV/EjoAzOoqm1b4xUj2cBVXjj/NbQgI4Cha94WTGgsBj%20%20aimnvJk49lWykmWUEi2jRhaxzQw8uutDQX4QMYIBWDCCAVQCAQEwMTAdMRswGQYD%20%20VQQDDBJBUlRFTUlTLklOSFAuTE9DQUwCEBm4YKObvPWLSr3f9QnfyIQwCQYFKw4D%20%20AhoFADANBgkqhkiG9w0BAQEFAASCAQBV4M9b+dvJxbHgsZnYvfr7W70eoKw+OuIj%20%20vqh8agPpAyyzKDzUHF5bgcEqKSMPjccTBXKVZQRPmnJyPS9qC6t3ZFtTYaZfTjNb%20%20PTsT4E3Qgkc3PutIf+0Pvj3I1XGHl1SXtfznGX1tHT+PSJ1Y1Olnd/1NxEsoMYT7%20%204cgcNsTkRGX5po36Os+TOVIL69s1qhaTDNx7fNfeoyJch3lW5goxON90MH4fp5Gc%20%20Nmy2b6SHzs/GTQpvEyqBQ+aLK6QK0Zq26xrv6vw72uNNuBg6VUzjFDnZx6xDnyP+%20%20Tdf+N65SzTd4FhMPgN/6XEROV5Kw0DzIp4xIrVoMhR18F57Np1xR%20%20%0D%0A redirectclipboard%3Ai%3A1%0D%0Aredirectposdevices%3Ai%3A0%0D%0Aredirectprinters%3Ai%3A1%0D%0Aredirectcomports%3Ai%3A1%0D%0Aredirectsmartcards%3Ai%3A0%0D%0Adevicestoredirect%3As%3A%0D%0Adrivestoredirect%3As%3A*%0D%0Aredirectdrives%3Ai%3A1%0D%0Asession%20bpp%3Ai%3A32%0D%0Aprompt%20for%20credentials%20on%20client%3Ai%3A1%0D%0Aspan%20monitors%3Ai%3A1%0D%0Ause%20multimon%3Ai%3A1%0D%0Aremoteapplicationmode%3Ai%3A1%0D%0Aserver%20port%3Ai%3A3389%0D%0Aallow%20font%20smoothing%3Ai%3A1%0D%0Apromptcredentialonce%3Ai%3A1%0D%0Aauthentication%20level%3Ai%3A2%0D%0Agatewayusagemethod%3Ai%3A2%0D%0Agatewayprofileusagemethod%3Ai%3A1%0D%0Agatewaycredentialssource%3Ai%3A0%0D%0Afull%20address%3As%3ASERVER.DOMAIN.local%0D%0Aalternate%20shell%3As%3A%7C%7CFE7Shell%0D%0Aremoteapplicationprogram%3As%3A%7C%7CFE7Shell%0D%0Agatewayhostname%3As%3ASERVER.DOMAIN.LOCAL%0D%0Aremoteapplicationname%3As%3AThe%20Remote%20Application%0D%0Aremoteapplicationcmdline%3As%3A%0D%0AWorkspace%20Id%3As%3ASERVER.DOMAIN.local%0D%0A

    If anyone could give me suggestions on how to fix this issue that would be great.



    • Edited by rbaerINHP Tuesday, August 20, 2013 1:59 PM
    Tuesday, August 20, 2013 1:50 PM

Answers

  • After speaking with Microsoft it was determined that we needed to use HTTPS and add an internal CA to not have any issues with our RDWeb page.
    • Marked as answer by rbaerINHP Tuesday, September 3, 2013 2:36 AM
    Tuesday, September 3, 2013 2:36 AM

All replies

  • This error means that your browser was unable to apply the XSLT stylesheet that transforms RDWeb's underlying XML into HTML. Typically this happens when your browser is unable to download the stylesheet. A typical problem that blocks downloading the stylesheet is when your local machine is a Server SKU with IE Enhanced Security Configuration enabled (hence the error message).

    If the solution is not something obvious (e.g. turning off IE Enhanced Security Configuration as the error message suggests), your best bet is to turn on IE's F12 developer mode to see if you can figure out why the stylesheet is not being downloaded or applied.

    Hope that helps,


    Travis Howe | RDS Blog: http://blogs.msdn.com/rds/default.aspx

    Tuesday, August 20, 2013 10:42 PM
    Moderator
  • I already had IE Enhance Security Configuration disabled for both the Admin and User. I am also running Windows Server 2012 if that makes a difference. Is there anything specific we should be looking for in the F12 Developer Mode? We are currently running IE 9 in our environment. I can upload the HTML code to this post.

    Thank you for your help!

    Wednesday, August 21, 2013 4:42 PM
  • One thing I wasn't clear about: you need to disable IE Enhanced Security Configuration on the client machines. It has no impact on the RDWeb server itself (unless you are navigating to the website from localhost, in which case it is also a client machine). You may have already done this (or it may not apply if your end-users are using Client SKU client machines), but I thought I'd double-check.

    For the F12 developer mode, a good first step is to look for errors in the console that pop-up when you are trying to load the page. If it is failing to download, you will be able to see that by capturing network traffic in the Network tab. You can then dig-in for more info, like the HTTP status code returned by the server.

    Hope that helps,


    Travis Howe | RDS Blog: http://blogs.msdn.com/rds/default.aspx

    Wednesday, August 21, 2013 6:14 PM
    Moderator
  • After running Fiddler and Wireshark we did noticed a 401 unauthorized: access is denied due to invalid credentials. Also that is is trying to use multiple Authentication Methods. If you stay on the error page and refresh a few times it will eventually show the site and the applications available. 
    Wednesday, August 21, 2013 7:48 PM
  • Hrm. Assuming you have left your RDWeb configurations at the default, it should just be using forms-based authentication to load the webpage, including the XSLT stylesheet. Is RDWeb behind some kind of proxy that might be requiring additional methods of authentication?

    Travis Howe | RDS Blog: http://blogs.msdn.com/rds/default.aspx

    • Marked as answer by Jeremy_WuModerator Tuesday, September 3, 2013 2:32 AM
    • Unmarked as answer by rbaerINHP Tuesday, September 3, 2013 2:34 AM
    Thursday, August 22, 2013 6:02 PM
    Moderator
  • Hi rbaerINHP,

    I would like to check if there is any update.

    Thanks.


    Best Regards
    Jeremy Wu

    Saturday, August 24, 2013 10:30 AM
    Moderator
  • Not yet. We submitted a support ticket so hopefully they can get us the answer.
    • Marked as answer by rbaerINHP Tuesday, September 3, 2013 2:35 AM
    • Unmarked as answer by rbaerINHP Tuesday, September 3, 2013 2:35 AM
    Sunday, August 25, 2013 12:53 AM
  • After speaking with Microsoft it was determined that we needed to use HTTPS and add an internal CA to not have any issues with our RDWeb page.
    • Marked as answer by rbaerINHP Tuesday, September 3, 2013 2:36 AM
    Tuesday, September 3, 2013 2:36 AM