none
Hyper-V 2012 R2 new VM with ISO in DVD boot failed - default SCSI not IDE RRS feed

  • Question

  • Hi, have created some VMs fine on 2008R2 and 2012 Hyper-V but now onto 2012 R2, am using the Gen 2 VM and hitting install error when booting them from the 2012R2 RTM .ISO (downloaded straight from Technet) loaded into virtual DVD:


    I see from http://social.technet.microsoft.com/Forums/windowsserver/en-US/53f901e4-5bd0-4e13-80a2-bca2f57b15e9/hyperv-unable-to-boot-from-cd-or-iso-in-vm-machine?forum=winserverhyperv that Hyper-V seems unable to boot from a synthetic SCSI until guest OS actually installed - so Catch-22! But I can't add an IDE Controller because it's not on the list:

    I tried the Integration Services and it seems fine on the Settings (including ticking the only one unticked - Guest Services) although if you need to run them from the DVD, it has the same problem - you can see them loaded (or the Win2012R2 ISO) in the DVD Media but you can't make them run through booting on SCSI!

    The physical drives are SATA not SCSI but presumably no matter as Hyper-V runs SCSI virtually, but why does Hyper-V default to SCSI and how do I get the DVD to run off an IDE instead if that is the way to install a base OS from .ISO? Or is there an easier way than all this?

    TIA, Phil.

    Friday, October 11, 2013 5:58 PM

Answers

  • Ok cheers for conf but as we see from original screenshot, there are no IDE channels on all these VMs and that seemed to be the problem... however it is a red herring... I switched to installing from local file .iso rather than through DVD and that was fine, so went back to another VM using the DVD - and realised I had been dumb and not paid attention enough!

    Basically, the IDE error is irrelevant - it just stops the DVD .iso loading by default if you leave it. Presumably if the IDE channels were created as they should be, it would have been fine. The thing is, you can do what the (virtual) boot message says and hit any button quickly before it gets to the IDE loading - that way it does indeed boot from the DVD, phew! I def did this originally, but like safe mode F8-ing, timing is often awkward. That's what you get for doing this in the background and getting mislead by missing IDEs and errors - hope this helps somebody else in such a D'oh! moment...!

    • Marked as answer by TickboxPhil Saturday, October 12, 2013 10:48 AM
    Saturday, October 12, 2013 10:48 AM

All replies

  • As mentioned, its a virtual DVD through Hyper-V (there is no physical DVD on the rackmount DL120), so can't be anything physically dying.

    Mount wise, I tried extracting the ISO (which extracted fine, so there's nothing wrong with the .ISO) and pointing to the top folder but Hyper-V new VM only seems to recognise .ISO so can't seem to do an "in-place" virtual mounting, unless you know how to?

    As there seems nothing wrong with the ISO, but something awkward with the way Hyper-V defaults to SCSI instead of IDE, which then stops the access as per the article linked, can anybody advise on that?

    Cheers, Phil.

    • Proposed as answer by Ryan Boud Sunday, September 28, 2014 8:22 PM
    • Unproposed as answer by Ryan Boud Sunday, September 28, 2014 8:22 PM
    Friday, October 11, 2013 6:25 PM
  • Thanks for conf, but even creating a VHDX without OS still sets it up with a SCSI Controller, not IDE for some reason (like my screenshot, but not like that in the linked technet screenshot). Can't find any way to do otherwise (nothing in the Sybex Hyper-V 2012 book either), hmmpph.

    How to set up an VM with IDE controller instead of SCSI?

    Friday, October 11, 2013 7:45 PM
  • Like I said, I created a straight VHDX (without OS, ie to install later) but it still creates it with the SCSI Controller! Can't see where to set it to not use any controller (although that's not surprising, as a Virtual Disk will need some kind of controller to be created with in the first place, wether it has an OS or not.

    Friday, October 11, 2013 8:06 PM
  • Ok cheers for conf but as we see from original screenshot, there are no IDE channels on all these VMs and that seemed to be the problem... however it is a red herring... I switched to installing from local file .iso rather than through DVD and that was fine, so went back to another VM using the DVD - and realised I had been dumb and not paid attention enough!

    Basically, the IDE error is irrelevant - it just stops the DVD .iso loading by default if you leave it. Presumably if the IDE channels were created as they should be, it would have been fine. The thing is, you can do what the (virtual) boot message says and hit any button quickly before it gets to the IDE loading - that way it does indeed boot from the DVD, phew! I def did this originally, but like safe mode F8-ing, timing is often awkward. That's what you get for doing this in the background and getting mislead by missing IDEs and errors - hope this helps somebody else in such a D'oh! moment...!

    • Marked as answer by TickboxPhil Saturday, October 12, 2013 10:48 AM
    Saturday, October 12, 2013 10:48 AM
  • The virtual machine you created is a generation 2 VM, there are no IDE controllers available in generation 2 VMs, they can use all features including OS-BOOT with SCSI-Disks.

    You can still use generation 1 VMs for older operating systems. generation 1 VMs provide legacy drivers like IDE.

    Regards,

    Benedict

    Saturday, October 12, 2013 6:01 PM
  • Interesting.  Looks like this means that Gen 2 VMS can't access local hardware IDE DVD drives either.

    That's an issue for me right now because I'm having a problem getting a virgin Gen2 VM to mount a new Server 2012 R2 ISO file on two brand new Hyper-V hosts I just built from a burned DVD copy (using Windows 7) of the exact same file, which worked flawlessly.  They both keep saying the ISO is corrupted -- that same ISO I used to burn the DVD I installed them from.  And I tried another download use the alternative download method (not the download manager), get the exact same error.  No sign of it being sparse, or a wrong extension, or download-protected.  Tried re-lettering the D: drive on the host, that didn't help either.

    I'll try a Gen1 VM...

    -- Ken


    /kenw K&M Systems Integration Ltd. 403-274-7848


    Sunday, December 22, 2013 3:52 PM
  • Actually, for 2012 R2 Hyper-V, it seems to depend on whether you are working with a generation 1 or generation 2 VM.  

    When I created a gen 2 VM, it got an error related to having a corrupt ISO file every time the VM tried to boot from the ISO for initial installation.

    So I created a gen 1 VM, pointed it at the same ISO, et voila, boot and install/run, no errors.  And the gen 1 VM can access the IDE DVD drive too, not that it matters now.

    Interestingly, the Server 2012 R2 host servers still get errors trying to mount the ISO, even though they have no problem reading the DVD I burned from it.


    /kenw K&M Systems Integration Ltd. 403-274-7848


    Monday, December 23, 2013 4:29 AM
  • Still Having issues???

    I reproduced your errors (all of them)...and eventually found the resolution

    I created a Gen2 VM, with a VHDX Hard Drive, then Booted to an SCSI DVD Drive with a WS2012R2.iso

    After you create the VM and Hard Drive, do the following:

    1. Copy the W2012R2.iso to a Folder (on the Host)

    2. Go to the VM Config Properties

    3. Create an SCSI DVD Drive & point it to the local WS2012R2.iso

    4. Set the boot order to that DVD Drive

    5. Under Installation Services, enable all (Guest Services was unchecked) Not Sure if this was necessary

    6. **The Key** Change your Default Memory (Startup 512mb) to "Startup = 2048mb"  [This did it for me]  Then after it's up and running, change your memory to how you want it.

    7. Save all Settings, then Start that VM



    Monday, February 10, 2014 4:47 AM
  • I found this article:

    http://blogs.technet.com/b/jhoward/archive/2013/11/11/hyper-v-generation-2-virtual-machines-part-9.aspx

    I hope this help.

    "...yes, we’re acutely aware that the generation 2 EFI boot loader messages persist on the screen and it can be a little confusing. Essentially what the generation 2 virtual machine did was:

    • Attempt to boot from the CD SCSI device containing the Windows 8 ISO. This is where the ‘Press any key…’ message came from. As no key was pressed, we went to the next boot entry. (And this is where we didn’t clear the message from the EFI CD boot loader)
    • I didn’t press F12 (in fact, this VM wasn’t connected to a network), so network boot failed
    • The SCSI VHDX is raw with no partitioning or file system, so this too failed

    So why did the generation 1 virtual machine start setup from the Windows media? The answer is simply that it’s the way Windows media is built, and it’s inconsistent between the PCAT and EFI loaders.

    However, it’s relatively simple to solve if you want to avoid the press any key message. In fact, we almost have all the pieces from previous parts. In particular, part 4 where we injected keyboard drivers into the Windows 8 media.

    If you loopback mount Windows 8 or 8.1 RTM media, and navigate to the \efi\microsoft\boot directory, you will see there are two versions of cdboot.efi

    clip_image006

    The default version, cdboot.efi prompts for a keypress. The unused version, cdboot_noprompt.efi doesn’t prompt.

    So it’s fairly simple to create modified media which uses the noprompt version. First, copy the contents of the ISO to a working directory, rename cdboot.efi to cdboot_prompt.efi, and rename cdboot_noprompt.efi to cdboot.efi.

    clip_image008

    Do the same with efisys.bin and efisys_prompt.bin

    clip_image010

    Then re-use our oscdimg command (in an elevated deployment and imaging tools environment) from part 4 to recreate the media.

    clip_image011

    "

    Best Regards:

    Tamás


    • Edited by jaki.tamas Sunday, June 29, 2014 5:33 PM
    Sunday, June 29, 2014 5:31 PM
  • I am constantly building new machines, and I use AMD. I have not seen issues with Hyper-V using SATA hard disks which host the VHDX files. I use another rig as a file server and all virtual machines can see the shares fine.

    Gen 1 like the older SKUs use VHD or VHDX and they have IDE and SCSI

    Gen 2 have SCSI only, and these can attack storage the same as Gen 1 albeit with a different controller.

    I use a storage box (NAS) and that is what I am using for general storage

    I am using AMD 990FX based system boards which all support UEFI and PCI Express

    SCSI CDROM works on my rigs fine. I use it to install a new server VM.


    Corsair Carbide 300R with window
    Corsair TX850V2 70A@12V
    Asus M5A99FX PRO R2.0 CFX/SLI
    AMD Phenom II 965 C3 Black Edition @ 4.0 GHz
    G.SKILL RipjawsX DDR3-2133 8 GB
    EVGA GTX 6600 Ti FTW Signature 2(Gk104 Kepler)
    Asus PA238QR IPS LED HDMI DP 1080p
    ST2000DM001 & Windows 8.1 Enterprise x64
    Microsoft Wireless Desktop 2000
    Wacom Bamboo CHT470M
    Place your rig specifics into your signature like I have, makes it 100x easier to understand!

    Hardcore Games Legendary is the Only Way to Play!

    Monday, June 30, 2014 1:19 PM
  • OK Microsoft,

    Here's my rant on Gen2 Hyper-V VM's.

    Why in the universe would I want to have a VM that can only read ISO's and not any physical media?  Do you have any idea how many business line of apps that come on physical media ONLY?  It would appear that Microsoft, thinks I have nothing better to do that to have yet another step to perform just to get one thing done.  Looks like I have to create an ISO just to be able to install anything on my VM's if all I have is physical media. . . Seriously?!?!?!

    It's bad enough that every new operating system I have to locate every usable tool that MS moves to other locations for no apparent reason, except to say it's new and improved.  The only advantage that I can see is wear out my mouse with more and more clicks.  I just love clicking 9+ times to perform every simple task.  But now just to install a business line application, I get the added step of creating an ISO.

    Thanks.  At least I get to bill for the added time required.


    Sunday, September 28, 2014 8:04 PM
  • I should mention that when I was setting up some new virtual machines in the shop recently, I was having no problems with SCSI mounted VHD, VHDX or optical disk images.

    if you have a physical optical disk, there are many tools that can make an image of that in ISO format

    even the OEM version of Nero can do that easily

    given the average blade box has no physical optical drive, I found it expedient to use a different machine with a bunch of ISO images for various versions of Windows I use for QA assurance purposes

    How looking at the image in the original post, I see that Hyper-V does not like the machine its running on.


    MSFT Signature

    Place your rig specifics into your signature like I have, makes it 100x easier!

    Hardcore Games Legendary is the Only Way to Play!

    Sunday, September 28, 2014 8:42 PM
  • I have been working on this issue for days now trying to install XP Pro VM on a Windows 8.1 host using Hyper V Generation 2. The XP Pro is in .iso format of course. I tried every suggested solution and they all failed. Needless to say that it installed without problem on Generation 1. In my research, I read that Generation 2 works only on Windows 8 VM and above and doesn't work on Windows 7 or XP. So I tried creating a Win 8 VM with Gen 2, it installed without any problem. Hope this helps others and save them from wasting their time like I did.

    Moral of the story and after wastin days on this issue, I discovered that Microsoft screwed up AGAIN!!!!

    Mike

     
    Tuesday, November 18, 2014 6:07 PM
  • XP is not supported as a Generation 2 VM.

    1) I don't recall XP supporting UEFI boot.

    2) XP does not have the Integration Components built into the kernel.

    This article: http://technet.microsoft.com/en-us/library/dn282285.aspx published in June 2013 outlines the supported OSes in the VM.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Tuesday, November 18, 2014 9:40 PM
    Moderator
  • XP is not supported as a Generation 2 VM.

    1) I don't recall XP supporting UEFI boot.

    2) XP does not have the Integration Components built into the kernel.

    This article: http://technet.microsoft.com/en-us/library/dn282285.aspx published in June 2013 outlines the supported OSes in the VM.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    I have fiddled around and I could not get XP up even cloning to a gen 2, par for the course 

    i use a hyper-v manager to manage everything, this way I can use the connect feature to see what is up, that tool can do screen shots so its handy that way



    MSFT Signature

    Place your rig specifics into your signature like I have, makes it 100x easier!

    Hardcore Games Legendary is the Only Way to Play!
    Vegan Advocate How can you be an environmentalist and still eat meat?

    Wednesday, November 19, 2014 2:22 PM
  • Do not enable Secure Boot in Setting --> Firmware --> Secure Boot
    Wednesday, May 20, 2015 3:29 AM
  • I ran into something similar where it was giving me an error "the unsigned image's hash is not allowed" when trying to use Windows 7 Enterprise version of ISO from MSDN download. I turned out that when creating a new VM, you want to select Generation 1 and not Generation 2 as error was confusing and not relate to unsigned image's hash or anything so hope this helps someone else.
    Monday, August 3, 2015 8:47 PM
  • @Tapori in your case you must have had Secure Boot enabled.  Which would explain the hash error.

    Either way, Generation 2 is UEFI, so the OS must support UEFI boot to use it.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Monday, August 3, 2015 8:58 PM
    Moderator
  • Do not enable Secure Boot in Setting --> Firmware --> Secure Boot
    Worked Great. Thanks!
    Monday, October 5, 2015 1:01 PM
  • Thanks mate!

    It helped

    Wednesday, January 20, 2016 3:47 PM
  • that's it!
    Sunday, July 10, 2016 5:54 PM
  • Hi Phil,

    I know this is a very old thread but the solution is to disable the Secure Boot.

    Turn off the vm and under Secure Boot uncheck this option and try again.

    Thanks a lot,

    Thiago


    Thiago Di Giorgio Senior

    IT Infrastructure Analyst

    thiago.gio@hotmail.com |Skype: thiago.giorgio | LinkedIn: linkedin.com/in/tgiorgio

    Thursday, August 4, 2016 12:04 PM
  • This is the correct way to do! Thank you BrianEh!!!
    Friday, August 5, 2016 6:18 PM
  • Worked! ;) Thanks.

    Relax: It's all just fun and games! ;)

    Wednesday, August 10, 2016 1:12 AM
  • YAY! This was the issue for me!

    THANK YOU!

    Thursday, December 1, 2016 6:24 PM
  • Hi the solution to your problem is to go under VM > Settings > Security and turn off secureboot. After you turn that off you can boot the iso. Sorry that this answer comes so late but hopefully someone else will find it helpfull.
    Sunday, December 3, 2017 7:35 AM