locked
Device Manager - All devices not installed ! ! RRS feed

  • General discussion

  • In Device Manager I have a category 'Other devices' with two Unknown device under it.

    I have a ASUS A8N32-SLI Deluxe Socket 939 Mother Board. (in case anyone has the same and thinks they can help) This is my second install of win 7. The first install I had troubles with win 7 and my realtek sound card; as well as these two unknown devices. I was able to fix the realtek problem on the first install, but not the unknown devices.

    On this install win 7 had no problems with the MB's built in Realtek sound chip. Nice to know Microsoft is busy working on these things. :-) <~ brown nosing. Last install after solving so many little problems on my own I decided to tackle these Unknown devices. Up to that point all I'd done is right click on them and tell win 7 to update the drivers.

    First I downloaded any new drivers and software from Asus for vista and this mother board. Then right clicked on them and chose update driver and pointed to each (unzipped) download in succession. Then I did the same using the CD that came with my MB. Then I just started running the programs in the hopes that one of them would do it.

    Afterwards I still had the two Yellow ! unknown Devices and what seemed to me a very sluggish computer. So I've done a fresh install and now am looking to find out what these items are and get the drivers installed in a less hap hazard way.

    Too that end I booted up a fresh install of XP on the same comp to compare the two device managers. The two compare until the heading Network adapters. In XP’s device manager under

    Network adapters, I have two items.

    1394 Net Adapter &

    Nvidia nForce Networking Controller

    In Win 7 under Network adapters I have only

    Nvidia nForce Networking Controller.

    In XP the next item on the tree is

    NVIDIA Network Bus Enumerator with - you guessed it

    Nvidia Network Bus Enumerator under it.

    Followed by Ports (Com & LPT)

    On Win 7 under Network adapters the next item on the tree is the ‘Other devices’ with the two unknowns under it, Followed by Ports (COM & LPT) meaning win 7 is missing the Nvidia Network Bus Enumerator.

    The only other difference between the two Device Managers is under the Heading System Devices. This category is so dissimilar has to not really allow direct comparison. At least not by me.

    Going to do a search to see if I can find new drivers for 1394 Net Adapter and for Nvidia Network Bus Enumerator but looking for some input before I start willy nillie trying to install things again.


    Computer User
    Tuesday, January 27, 2009 5:47 PM

All replies

  • try installing the vista drivers for those devices in Vista Compatibility mode.

    Right click on the driver installer file, select Properties, Compatibility Tab, then select Vista, at the  bottom put a tick in run as Administrator Apply/OK

    then try running the installer file.
    Tuesday, January 27, 2009 6:16 PM
  • Also, try getting the drivers linked on this thread... they worked for me.  I also did the "run in Vista compatibility mode" for the setup.

     http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/cf818538-ac9b-4b8e-a471-3b5268b6b8c6

    Wednesday, January 28, 2009 7:15 AM
  •   Just an update.  I tried the links in the thread you posted Alderson21.  No go. 

     

    I also tried googling Drivers for the two mentioned items. Found lots of links that sounded promissing but never succeeding in addressing my issue.  Even went to Nvidia's sight and stumpled around always seemed to end up in the same place so downloaded and installed a 53 mb file and installed that. Made some changes in Device Manager. Pretty much just renaming things but still stuck with the two Unknown Devices.

     

    Anyone have any fresh ideas?


    Computer User
    Thursday, January 29, 2009 4:12 PM
  • amdaway used to take these "away" in vista.  I have one too that wont dissappear.  Its likely the quiet and cool mobo feature on my asus M2R32-MVP motherboard that i havent installed a driver for yet.
    Thursday, January 29, 2009 6:08 PM
  •  amdaway ???
    Computer User
    Thursday, January 29, 2009 8:30 PM
  • What is the hardware ID for the two unknown devices?  Go into device manager, right click on the unknown devices, select properties, then click on the details tab. You will see a heading of "Property" which has a drop down below it.  Select "Hardware ID" and that will give you the hardware ID. 

    If one of your unknown devices has a hardware ID of ACPI\AWY00001 then this driver will fix that.

    AMDAway is part of AMD Live, which I still have not figured out.  Anyway I installed Windows 7 on a machine with a AMD Athlon 64x2 and had an unknown device in device manager that was the AMDAway. Didn't seem to hurt the system.  I did find the driver file here  http://global.msi.com.tw/index.php?func=driverfile&dno=2458&i=0. I know it is from MSI but I have read that the driver is generic.  After you unzip the file, you will see a setup.exe but it will not work in Windows 7, you have to use the update driver button in device manager and browse for the AMDAway.inf file that is in one of the folders of the zip file from MSI. 

    Friday, January 30, 2009 6:41 AM
  • Very interesting.  Since they were unknown it never crossed my mind to ask DM to display their properties.

     

    Think somehow I just figured it was 'unknown'.

     

    One of them is ACPl\PNPB006 next line *PNPB006

    The other is ACPl\PNPB02F next line *PNPB92F

     

    I'll have to google that and see if it come up with anything.

     


    Computer User
    Friday, January 30, 2009 2:31 PM
  •  Well. Searching by these hardware ID #'s had success of sorts. Didn't find any working drivers but while reading posts on the second item I did come across a post stating that going into the BIOS and disabling the game port get rid of the 'unknown'. 

    Since I don't use the game port I went in and did just that, and at the same time dissabled my midi port. This got rid of my two 'Unknowns'.

    Not how I would like too. I'd like to know if I wanted to hook up my joystick I could find a driver for the game port. I did see these two items where (and still are) problems in Vista as well. So maybe MS is working on it.


    Computer User
    Friday, January 30, 2009 3:11 PM
  • G'day Tharkum,

    I have the same motherboard, you need to turn of the midi port and the game port in the bios. Turning these of should not cause any problems unles you use those ports. Hope this is of some help.


    eclecticb
    Monday, February 2, 2009 2:03 AM
  • I have the same problem with Windows 8.1 but the link have postet doesn't work. Have you the possibility to send me a workin link for the drive for (MSI) apc\awy0001\2&daba3ff&2. Many thanks
    Wednesday, January 22, 2020 8:25 AM