Group Policy and Default Printer Setting. Printer Not showing up on client.


  • Hi,

    I have server 2008 with vista clients,all on latest updates.

    I have the correct GP extensions installed on clients.
    I'm using the policy option for user control panel settings to set a shared printer as the default printer targeted to a specific OU.
    When I run the simulation the printer is correctly mapped.
    I have loopback enabled.

    but the printer will not appear. Printer connections are good and printer can be reached and test page printed from both server and client.

    Am I missing a setting to have the printer appear on the client machine as default after gpupdate /Force?

    my settings are identical to the settings in this article

    Thanks in advance,

    Wednesday, February 10, 2010 6:55 PM


  • Hi Greg,

    You may install the updates (KB943729 and KB915865). In addition,you should edit GPP polices.
    Computer Configuration>Policies>Administrative Templates>System>Group Policy and enable this settings: Drive Maps Policy Processing, Printer Policy Processing, User Group Policy loopback processing mode.

    Here is a great online article about deploy printers through Windows 2008 GPP.

    In addition, please also apply the following GPP hotfix on the problematic clients.

    Best Regards,
    Wilson Jia

    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Wilson Jia Friday, February 12, 2010 7:55 AM
    Thursday, February 11, 2010 9:12 AM