none
Cannot uninstall Powershell V1 From Server 2003 R2 Standard x86 RRS feed

  • Question

  • I am posting this question in this forum at the recommendation of a moderator who feels this is a Powershell forum inquiry. Any help would be appreciated!

    I have been reading through many articles without any success in finding the answer.

    I have to upgrade a Server 2003 Standard 32 Bit server to 2008 Standard (Non R2) to preserve 32 bit functionality of some vendor applications that are currently running on the server.

    I found a round-about way of removing powershell (Delete the registry entry and move the V1.0 folder out of the powershell directory in the Windows folder) and Windows Server 2008 will upgrade that way (I'm doing testing in a virtual environment) but after I perform the upgrade to 2008 I have random errors about powershell 1.0 registration on some of the applications. I also fear that additional changes to the server such as installing applications might cause problems. This is definitely not an orthadox solution.

    Here is the deal (And yes I have read the KB articles I have been able to locate) the installation folders for powershell were removed whenever this Server 2003 R2 Standard server had the latest service packs removed in previous years. When attempting an upgrade (I don't have a choice) it tells me Powershell must be uninstalled.

    Powershell cannot be uninstalled from the server in add / remove programs (With the show updates checkbox selected). It does not exist. There are no un-installer packages in the c:\windows directory.

    I tried this stuff:

    http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/8ff0cd96-f86d-416b-8fdb-095f3fca2766/

    WindowsServer2003-KB926139-v2-x86-ENU.exe >>> This will not install because it says the previous version of powershell must be removed (There is no uninstaller / and there is no "V1" version ofWindowsServer2003-KB926139-v2-x86-ENU.exe anywhere that I can locate online..... I think I need this version to possibly install / uninstall to recover the uninstall directories in the c:\windows directory.

    I tried this:

    http://support.microsoft.com/kb/926139

    These do not exist on the server to uninstall.....

    • Hotfix for Windows Server 2003 (KB926139)
    • Hotfix for Windows Server 2003 (KB926140)
    • Hotfix for Windows Server 2003 (KB926141)


    Eventually I just caved into trying this method:
    http://social.technet.microsoft.com/Forums/en-US/itprovistaapps/thread/262ab957-1b90-1486c-8a7d-c8f84fd6e732/

    Steps 1 wouldn't work (I couldn't find WindowsServer2003-KB926139-x86-ENU.exe)
    2. Manually remove the Installation folder(s) (I did that)
    %windir%\System32\WindowsPowerShell\V1.0

    3. Remove the registry key (I did this)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell

    I did not fully understand some of the other steps. All I know is after the upgrade to 2008 finished Server 2008 reported needing to run a repair on the .Net Framework. This took a while and after it completed I had to reboot.

    Is there a more orthadox way to do this? Why doesn't Microsoft keep an archive of sorts of installers that are critical to being able to successfully upgrade operating systems to 2008 / 2012 such as WindowsServer2003-KB926139-x86-ENU.exe ???

    If anyone has any input or has actually successfully cleanly installed this old version of powershell please let me know so that I can meet the clients requirements of maintaining the integrity of their applications.

    Thanks everyone!

    Tuesday, April 16, 2013 3:20 PM

All replies

  • so if you go control panel you dont see powershell v1 in there?

    • In Control Panel, open Add or Remove Programs.
    • Uninstall any instances of Windows PowerShell that appear in the installed programs list or the installed updates list. Windows PowerShell might be listed as a Windows update with the Knowledge Base article number KB926139.

    how about in server features under remove features?

    but if the reg hack worked you might have to leave it at that

    Tuesday, April 16, 2013 4:48 PM
  •  Correct.

    control panel > you dont see powershell v1 in there?

    It is unfortunately not in Control panel. And the uninstall folder is not in c:\windows\ because when SP2 was installed on Server 2003 it would have removed all of the uninstall folders in the Windows folder. So there is no easy way to manually uninstall the old version of powershell (Non v2 WindowsServer2003-KB926139-x86-ENU.exe > Not WindowsServer2003-KB926139-v2-x86-ENU.exe (The v2 executable is the only available on the Microsoft site). I need the V1 I think to install / uninstall prior the 2008 Enterprise x86 upgrade in order to safely remove powershell.

    Nor was it available under remove features. The registry hack won't cut it at this point because a bunch of legacy apps had registrations with powershell and when the registry key was deleted / program folder for powershell v1.0 was removed from the Windows directory it started causing "genericname.cpl cannot load because it is not registered etc in powershell) - Something along those lines

    • Edited by Azca Admin Tuesday, April 16, 2013 11:45 PM
    Tuesday, April 16, 2013 11:42 PM
  • Any ideas out there please?
    Wednesday, April 17, 2013 10:57 PM
  • Hi,

    How about running:

    "C:\WINDOWS\$968930Uinstall_KB968930$\spuninst\spuninst.exe"

    Another way we could try rename powershell, for more details, please go through the below thread:

    http://social.technet.microsoft.com/Forums/en-US/itprovistaapps/thread/5debb397-cedf-4822-bd7c-cc08f2d38ef8

    Hope this helps.

    Regards,

    Yan Li

    If you have any feedback on our support, please click here .


    Cataleya Li
    TechNet Community Support


    Thursday, April 18, 2013 6:33 AM
    Moderator
  • Hi,

    Just checking in to see if the suggestions were helpful. Please let us know if you would like further assistance.

     

    If you have any feedback on our support, please click here .


    Cataleya Li
    TechNet Community Support

    Monday, April 22, 2013 2:51 AM
    Moderator
  • Had the same problem on Srv 2003 x64 Enterprise today. PS1 was not listed in Software nor was a management framework, not even under updates.

    The Update 968930 was also not installed. I checked with good old Sysinternals regmon what the update installer was checking to determine if PS1 was installed.

    I found this: 12.88320065    update.exe:6172    OpenKey    HKLM\SOFTWARE\Microsoft\PowerShell\1    SUCCESS        

    I backed up this Key and deleted it. I also deleted the PS1 folders in filesystem.

    I was then finally able to install WindowsServer2003-KB968930-x64-DEU.exe.

    • Proposed as answer by L_Herzog Monday, April 22, 2013 12:15 PM
    Monday, April 22, 2013 12:15 PM
  • When I renamed the powershell folder / moved it out of the folder and backed up the registry key / deleted it I was getting Powershell registration errors in various areas of Server 2008 Enterprise x86. So L_Herzog do you have any errors anywhere after deleting the PS1 folder / the registry key like I am? Did you install something after deleting the key / removing the PS1 install folder?

    I have no solution yet for safely removing Powershell and yet being able to preserve the application integrity of the system after upgrading to 2008 x86 Enterprise from 2003 Standard R2.

    .Net did run some kind of repair right after the install and it took some time to complete after the PS1 folder / registry key were removed. But no idea what it repaired if opening various programs reports errors about PS1 registrations.

    Monday, April 22, 2013 9:33 PM
  • Hi,

    Have you go through the thread I post out, there are many suggestions that should  be helpful.

    Please try them.

    Regards,

    Yan Li

    If you have any feedback on our support, please click here .


    Cataleya Li
    TechNet Community Support

    Wednesday, April 24, 2013 5:32 AM
    Moderator
  • Rename the existing PowerShell folder located below. Was able to upgrade to Server 2008 after.

    Server 2003 32 bit: %windir%\System32\WindowsPowerShell

    Server 2003 64 bit: %windir%\Syswow64\WindowsPowerShell

    Monday, June 17, 2019 4:09 PM