Windows Server 2008 r2 Error setting IP address using NETSH command - syntax limitations in recovery mode? RRS feed

  • Question

  • This is driving me nuts. I've searched forums and looked at my syntax but I cannot see what is wrong.

    1. Booted using F8

    2. Selected the recovery options startup

    3. Open command window

    netsh int ipv4 set address name="Local Area Connection" static

    I get error "The interface is unknown." Yet I can display the interfaces and "Local Area Connection" is there! See screenshot of exact commands and error in reply below.

    Thursday, March 1, 2012 8:08 PM


All replies

  • Can't capture text to clipboard from recovery console. Here is a screenshot.

    Thursday, March 1, 2012 10:35 PM
  • P.S. This is Windows Server 2008 R2 Enterprise Edition, system recovery mode.
    Thursday, March 1, 2012 10:37 PM
  • PING. It has been 4 days and no reponse. Am I in the correct community forum?

    Let me rephrase the question: How do I establish a static IP address on the network adapter during recovery operations? I am attempting to test a bare metal restore of a backup created by Windows Server Backup to a network share.

    • Proposed as answer by Bandesz Thursday, April 11, 2013 10:48 AM
    Monday, March 5, 2012 3:57 PM
  • Look, the procedure I'm following is documented by Microsoft (here: http://blogs.technet.com/b/askcore/archive/2009/02/04/windows-server-backup-2008-restore-from-network-location.aspx) and everywhere I've looked for this the obvious missing step is assigning the IP address to the target machine. I'll try cross-posting in other forums to see if I can trigger an answer to this question. Please, someone?
    Wednesday, March 7, 2012 3:28 PM
  • I ran into the same problem. Here is what worked for me.

    Replace: netsh int ipv4 set address name="Local Area Connection" static

    With: netsh int ip set address name="Local Area Connection" static

    IT worked for me on a HP PRoLiant DL360 G7 with 4 NIC's and only one NIC physically connected.

    "Local Area Connection 2" in my case.


    Friday, March 9, 2012 4:07 AM
  • Greg, Tried your suggestion of using "IP" instead of "IPV4" in the NETSH command, but this gave me the same result.
    Monday, March 12, 2012 8:49 PM
  • Another clue, but I'm still stuck. The scenario is:

    1. Boot machine, press F8 to select the recovery startup type

    2. logon using local administrator account

    3. Select command prompt from system recovery options (see screen shot)

    4. In CMD window commands IPCONFIG /ALL or NETSH INTERFACE IPV4 SHOW ADDRESSES both indicate that only the "Loopback Pseudo-Interface 1" is present.

    5. Select System Image Recovery from the system recovery options menu, click on Advanced tab, request a recovery image from a network location

    6. Select command prompt from system recovery options, IPCONFIG and NETSH now show all network adapters but the physical adapters are all configured for DHCP and since there is no DHCP server on this subnet are defaulting to the 169.254.*.* random addresses. Can't change the addresses, NETSH is ineffectual in this case. WTF?  

    Monday, March 12, 2012 8:55 PM
  • Before you use netsh to configure your network type: wpeinit

    Found here:


    • Marked as answer by George Perkins Wednesday, March 21, 2012 8:07 PM
    Wednesday, March 21, 2012 6:58 PM
  • Thank you for pointing out I need to use the WPEINIT command!

    It would be nice if Microsoft would document this. The article on bare metal restore referenced at the top of this thread does not. Hopefully now at least it will show up in searches of community forums if someone else has this issue.

    Wednesday, March 21, 2012 8:11 PM
  • JBanks - I just wanted to say THANK YOU.   I have been searching for a way to do this for 2 days now.   Your instructions worked PERFECTLY!

    Side note: since my server had 6 active NICs, I had to set each of them to a valid IP address (because you never know which one is actually going to get used).

    Friday, May 10, 2013 7:17 AM
  • 3 years and same issue with server 2012!!!! Been working on this all day and will not connect with all stated tips. This sucks.


    Friday, February 26, 2016 9:57 PM