none
SysPrep Issues Win 2008 R2 RRS feed

  • Question

  • Getting Sysprep Fatal error on Windows 2008 r2 Choose OOBE , generalize , Shutdown Options

    It is an VMWare Viryual machine

    2012-02-02 07:29:14, Error [shsetup] CleanupAdministratorPassword: NetUserSetInfo(1003) failed (0x800708c5) [gle=0x000003e5]
    2012-02-02 07:30:39, Error [0x0f0082] SYSPRP LaunchDll:Failure occurred while executing 'C:\Windows\System32\slc.dll,SLReArmWindows', returned error code -1073425657
    2012-02-02 07:30:39, Error [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = -1073425657
    2012-02-02 07:30:39, Error [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0xc004d307
    2012-05-04 18:09:46, Error [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:09:46, Error [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f
    2012-05-04 18:11:17, Error [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:11:17, Error [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f
    2012-05-04 18:21:48, Error [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:21:48, Error [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f

    In our case i belive the Syerver Image Which is already been deployed by a Template (VMware) has already been Syspreped 3 times .

    As i checked the logs setupact.log I can see the Number of times the sysprep has ran.

    Maybe I try a brand new install.

    Or if in case i can get a working solution that will be great as well.

    Tuesday, May 8, 2012 4:07 AM

Answers

  • Hi

    invoke sysprep like this:
    -skiprearm.xml:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="generalize">
            <component name="Microsoft-Windows-Security-Licensing-SLC" processorArchitecture="AMD64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>1</SkipRearm>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:c:/Tims/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    -Save the script to c:\Windows

    -Invoke sysprep like:

    sysprep /generalize /oobe /shutdown /unattend:c:\Windows\skiprearm.xml

    .....

    If this doesn´t help you have to Setup a new "image" or the image from a previous time (before you have captured the Setup 3 times) with the skiprearm.xml.


    Kind regards,

    Tim
    MCITP, MCTS
    http://directoryadmin.blogspot.com

    This posting is provided 'AS IS' with no warranties or guarantees and confers no rights.



    • Edited by Tim Buntrock Tuesday, May 8, 2012 6:47 AM
    • Marked as answer by Kitaab Tuesday, May 15, 2012 6:37 PM
    Monday, May 7, 2012 8:15 AM

All replies

  • Getting Sysprep Fatal error on Windows 2008 r2 Choose OOBE , generalize , Shutdown Options

    It is an VMWare Viryual machine

    2012-02-02 07:29:14, Error                        [shsetup] CleanupAdministratorPassword: NetUserSetInfo(1003) failed (0x800708c5) [gle=0x000003e5]
    2012-02-02 07:30:39, Error      [0x0f0082] SYSPRP LaunchDll:Failure occurred while executing 'C:\Windows\System32\slc.dll,SLReArmWindows', returned error code -1073425657
    2012-02-02 07:30:39, Error      [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = -1073425657
    2012-02-02 07:30:39, Error      [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0xc004d307
    2012-05-04 18:09:46, Error      [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:09:46, Error      [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f
    2012-05-04 18:11:17, Error      [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:11:17, Error      [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f
    2012-05-04 18:21:48, Error      [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:21:48, Error      [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f

    Monday, May 7, 2012 7:44 AM
  • Hi

    invoke sysprep like this:
    -skiprearm.xml:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="generalize">
            <component name="Microsoft-Windows-Security-Licensing-SLC" processorArchitecture="AMD64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>1</SkipRearm>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:c:/Tims/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    -Save the script to c:\Windows

    -Invoke sysprep like:

    sysprep /generalize /oobe /shutdown /unattend:c:\Windows\skiprearm.xml

    .....

    If this doesn´t help you have to Setup a new "image" or the image from a previous time (before you have captured the Setup 3 times) with the skiprearm.xml.


    Kind regards,

    Tim
    MCITP, MCTS
    http://directoryadmin.blogspot.com

    This posting is provided 'AS IS' with no warranties or guarantees and confers no rights.



    • Edited by Tim Buntrock Tuesday, May 8, 2012 6:47 AM
    • Marked as answer by Kitaab Tuesday, May 15, 2012 6:37 PM
    Monday, May 7, 2012 8:15 AM
  • Hi,

    Getting Sysprep Fatal error on Windows 2008 r2 Choose OOBE , generalize , Shutdown Options

    It is an VMWare Viryual machine

    Please seek assisstance at: http://communities.vmware.com/community/vmtn/server/vsphere/esx


    Mohammed Imtiyaz Ali

    Monday, May 7, 2012 12:22 PM
  • @Tim

    I am not sure the xml file is an option to use as you are mentioning something like

    <cpi:offlineImage cpi:source="wim:c:/Tims/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

    It seems that it is for Windows 7
    Do we have to change something in the xml to make it work for the Windows Server 2008 R2.

    In our case i belive the Syerver Image Which is already been deployed by a Template (VMware) has already been Syspreped 3 times .

    As i checked the logs setupact.log I can see the Number of times the sysprep has ran.

    Maybe I try a brand new install.

    Or if in case i can get a working solution that will be great as well.

    • Edited by Kitaab Monday, May 7, 2012 2:34 PM
    Monday, May 7, 2012 2:15 PM
  • Getting Sysprep Fatal error on Windows 2008 r2 Choose OOBE , generalize , Shutdown Options

    It is an VMWare Viryual machine

    2012-02-02 07:29:14, Error                        [shsetup] CleanupAdministratorPassword: NetUserSetInfo(1003) failed (0x800708c5) [gle=0x000003e5]
    2012-02-02 07:30:39, Error      [0x0f0082] SYSPRP LaunchDll:Failure occurred while executing 'C:\Windows\System32\slc.dll,SLReArmWindows', returned error code -1073425657
    2012-02-02 07:30:39, Error      [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = -1073425657
    2012-02-02 07:30:39, Error      [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0xc004d307
    2012-05-04 18:09:46, Error      [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:09:46, Error      [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f
    2012-05-04 18:11:17, Error      [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:11:17, Error      [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f
    2012-05-04 18:21:48, Error      [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 31
    2012-05-04 18:21:48, Error      [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001f

    Hello,

    I would recommend asking them here: http://social.technet.microsoft.com/Forums/fr-FR/winserversetup/threads


    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Monday, May 7, 2012 2:38 PM
  • @Tim

    I am not sure the xml file is an option to use as you are mentioning something like

    <cpi:offlineImage cpi:source="wim:c:/Tims/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

    It seems that it is for Windows 7
    Do we have to change something in the xml to make it work for the Windows Server 2008 R2.

    In our case i belive the Syerver Image Which is already been deployed by a Template (VMware) has already been Syspreped 3 times .

    As i checked the logs setupact.log I can see the Number of times the sysprep has ran.

    Maybe I try a brand new install.

    Or if in case i can get a working solution that will be great as well.

    You can use this also for Windows Server 2008 R2.

    If you using the skiprearm.xml the computer will not be rearmed and you can sysprep unlimited times.


    Kind regards,

    Tim
    MCITP, MCTS
    http://directoryadmin.blogspot.com

    This posting is provided 'AS IS' with no warranties or guarantees and confers no rights.

    Tuesday, May 8, 2012 6:46 AM
  • Hi,

    You another post has been replied, please avoid posting a duplicate post. Thanks for your understanding.

    http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/152737a4-53a9-4c17-8cc9-4145645b35fd/#0e4bcce5-9da3-4b11-92a5-d013e74b2ff6

    Tuesday, May 8, 2012 6:52 AM
    Moderator
  • The Person in that forum advised to open a post in this forum , i dont like to Duplicate your work , but i thought i will get better help posting here so i did. I apologize for the Inconvenience.
    Wednesday, May 9, 2012 5:24 AM
  • Do we change something in this Line in the XML to mention Windows Server 2008 R2

    <cpi:offlineImage cpi:source="wim:c:/Tims/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    Thursday, May 10, 2012 4:05 AM
  • Its only the source I used but its also working for 2008 R2.

    Kind regards,

    Tim
    MCITP, MCTS
    http://directoryadmin.blogspot.com

    This posting is provided 'AS IS' with no warranties or guarantees and confers no rights.

    Thursday, May 10, 2012 6:04 AM
  • thanks for it, i created a brand new server no syspreps done.. so havent tested the method yet ..as soon as i test i will update it.. but i think your answer is relevant.
    Tuesday, May 15, 2012 6:38 PM