none
RemoteApp Very Slow to Use (Post Login) RRS feed

  • Question

  • Hey Everyone,

    I have got a bit of a strange issue I cannot quite get to the bottom of.

    We have got a 2008R2 RDS with RemoteApp configured (only just started using RemoteApp). Our first app we deployed using it is an app that runs from a network share (exe that passes through queries to a DB). We need it on RemoteApp because it uses an anonymous relay to send emails so we cannot allow all desktops to do this.

    Anyway... Other than the usual time to login, the app itself runs very slow. Clicks, keyboard strokes, refreshes are all very laggy. We are running on a gigabit LAN and the app is just deployed as an RDP file (no web access). The server is not under too much load and has been overspecced just in case.

    The app runs perfectly without RemoteApp. It also runs perfectly when you RDP into the RemoteApp server, and open the .exe from there.

    Would really appreciate any suggestions.

    Cheers

    Garry

    Thursday, December 19, 2013 11:10 PM

Answers

  • Hi Garry,

    Thanks very much for your update.

    Since the Wordpad RemoteApp can work properly, there is no problem with the RemoteApp Feature. And from your description, the app runs perfectly without RemoteApp. It also runs perfectly when you RDP into the RemoteApp server, and open the .exe from there. Then this issue appears to be an compatible issue between the RemoteApp Feature and the app called PayGlobal.

    Currently, you are going to upgrade some clients to RDP Version 7. If the issue persists after upgrading, it is recommended you involve PayGlobal vendor to help with this issue since we don't have source code of this APP and what we can about it is very limited.

    If there are any questions, please feel free to post them here.

    Regards,

    Sophia Sun


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by SOH_Garry Monday, January 13, 2014 5:26 AM
    Wednesday, January 8, 2014 12:43 AM

All replies

  • Hi,

    There might be some time delay for proper solution. Appreciate your patience.

    Thank you for your understanding and support!

    Thanks.
    Sunday, December 22, 2013 4:07 AM
    Moderator
  • Hello Garry,

    Thanks for choosing Microsoft.

    Would you please collect the following information to help narrow sown this issue?

    ====================================================== 

    Do all Remote Apps encounter this issue or only this one encounter this issue?

    Please publish a notepad.exe and test whether users encounter the same issue with it.

    Would you please let me know the name of this application and whether it is free to install? So that I can do a test on my local machine.

    Regards,

    Sophia



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Tuesday, December 24, 2013 9:02 AM
  • Hello Garry,

    Here are some articles related to this issue. Hope they are helpful.

    Remote Desktop Protocol Performance

    http://download.microsoft.com/download/4/d/9/4d9ae285-3431-4335-a86e-969e7a146d1b/RDP_Performance_WhitePaper.docx

    Announcing the Remote Desktop Protocol Performance Improvements in Windows Server 2008 R2 and Windows 7 white paper

    http://blogs.msdn.com/b/rds/archive/2010/02/05/announcing-the-remote-desktop-protocol-performance-improvements-in-windows-server-2008-r2-and-windows-7-white-paper.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, January 2, 2014 4:18 AM
  • Hi Sophia,

    Sorry for the late reply, I have been on leave.

    I published a Wordpad app and it seems to be fine. I can switch between tabs quickly, change fonts, and the screen refresh is as fast as I am typing (45 wpm).

    The app we are using is called PayGlobal. Unfortuantely, it is not free.

    Cheers

    Garry

    Sunday, January 5, 2014 10:41 PM
  • Hi Sophia,

    Thanks for the links above. I don't think latency or speed is an issue, as we are on a LAN and latency is very low when pinging the RemoteApp Server, and the Application Server.

    I am going to upgrade a few of the clients to RDP Version 7 anyway, and see if it makes a difference.

    Cheers

    Garry

    Sunday, January 5, 2014 11:01 PM
  • Hi Garry,

    Thanks very much for your update.

    Since the Wordpad RemoteApp can work properly, there is no problem with the RemoteApp Feature. And from your description, the app runs perfectly without RemoteApp. It also runs perfectly when you RDP into the RemoteApp server, and open the .exe from there. Then this issue appears to be an compatible issue between the RemoteApp Feature and the app called PayGlobal.

    Currently, you are going to upgrade some clients to RDP Version 7. If the issue persists after upgrading, it is recommended you involve PayGlobal vendor to help with this issue since we don't have source code of this APP and what we can about it is very limited.

    If there are any questions, please feel free to post them here.

    Regards,

    Sophia Sun


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by SOH_Garry Monday, January 13, 2014 5:26 AM
    Wednesday, January 8, 2014 12:43 AM