locked
Error enabling remoting in WinXp SP3 RRS feed

  • Question

  • In a Hyper-V 2008 R2 Server I enable remoting using Enable-PSRemoting, or winrm quickconfig and this work ok.
    Also work in Win7, and I have remoting from Win7 to my Hyper-V Server.

    I install PS V2 in a machine with WinXP SP3, and when I run winrm quickconfig (as admin) I receive

    WinRM is configured ....
    WSManFault
    Message = Access denied
    Error Number: -2147024891 0x80070005
    access denied

    Any help would be apreciated
    Tuesday, November 10, 2009 11:10 PM

Answers

  • Hi, now solved the problem.
    I receive this from Connect :

    This is by design. Please try the following and try again:
    Use Local Security Settings (Secpol.msc) to change the setting of the
    "Network Access: Sharing and security model for local accounts" policy
    in Security Settings\Local Policies\Security Options to "Classic".

    Then I try and is ok after changing security police to 'Classic'.
    I now making remoting to my HyperV server.

    PS: The link to Connect https://connect.microsoft.com/PowerShell/feedback/ViewFeedback.aspx?FeedbackID=510094
    • Marked as answer by jfcarpi Friday, November 13, 2009 8:18 AM
    Friday, November 13, 2009 8:18 AM

All replies

  • I'm assuming you've downloaded the latest PowerShell v2 for XP?  And that you're running this command as Administrator?
    Wednesday, November 11, 2009 1:08 AM
  • Hi,

    This problem may be caused by conflicts of software or corrupt files. Please disable any third party antivirus software and Firewall to test again.

    If the problem still occurs, let’s use Process Monitor to trace the process:

    Process Monitor
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx   

    Download and run it. Click File menu, check Capture Events, try to reproduce this error, when the error occurs, uncheck Capture Events again. Exported events to Logfile.PML and upload the file and then use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the file and then give us the download address.

    Please also help to collect MPS Report:

    1)    Download proper MPS Report tool from the website below.

    Microsoft Product Support Reports
    http://www.microsoft.com/downloads/details.aspx?FamilyID=CEBF3C7C-7CA5-408F-88B7-F9C79B7306C0&displaylang=en

    2)    Double-click to run it, if requirement is not met, please follow the wizard to download and install them. After that, click Next, when the "Select the diagnostics you want to run" page appears, select "General", "Server Components", click Next.

    3)    After collecting all log files, choose "Save the results", choose a folder to save <Computername>MPSReports.cab file. Please use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the file and then give us the download address.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, November 11, 2009 7:21 AM
  • Yes, I download from 'WindowsXP-KB968930-x86', and I run it as Administrator.

    I receive the same error in commands like 'winrm enumerate winrm/config/Listener' or 'winrm get winrm/config'.

    I go to test in other machine and to trace the process as Mervyn suggest.

    Then I post results.

    Wednesday, November 11, 2009 8:28 AM
  • I test that in two more machines (virtual).
    The last is a new Virtual Machine where I make a new install of WinXP SP3, then I install dotNet2.0 SP2 and PoserShell 2.0 Final ( KB).

    I open PS and the results are

    Windows PowerShell
    Copyright (C) 2009 Microsoft Corporation. Reservados todos los derechos.

    PS C:\Documents and Settings\jfcarpi> Enable-PSRemoting

    Configuración rápida de WinRM
    Se está ejecutando el comando "Set-WSManQuickConfig" para habilitar este equipo
     para administración remota mediante el servicio WinRM.
     Esto incluye:
        1. Iniciar o reiniciar (si ya está iniciado) el servicio WinRM
        2. Establecer el tipo del servicio WinRM en inicio automático
        3. Crear una escucha para aceptar solicitudes en cualquier dirección IP
        4. Habilitar una excepción de firewall para el tráfico WS-Management (sólo
    para http).

    ¿Desea continuar?
    [S] Sí  [O] Sí a todo  [N] No  [T] No a todo  [U] Suspender  [?] Ayuda
    (el valor predeterminado es "S"):S
    WinRM se ha actualizado para recibir solicitudes.
    Se cambió el tipo de servicio WinRM correctamente.
    Servicio WinRM iniciado.

    Set-WSManQuickConfig : <f:WSManFault xmlns:f="http://schemas.microsoft.com/wbem
    /wsman/1/wsmanfault" Code="5" Machine="xptest"><f:Message>Acceso denegado. </f:
    Message></f:WSManFault>
    En línea: 50 Carácter: 33
    +             Set-WSManQuickConfig <<<<  -force
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManQuickConfig], In
       validOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQu
       ickConfigCommand

    PS C:\Documents and Settings\jfcarpi> winrm quickconfig
    WinRM está configurado para recibir solicitudes en este equipo.
    WSManFault
        Message = Acceso denegado.

    Nº de error:  -2147024891 0x80070005
    Acceso denegado.
    PS C:\Documents and Settings\jfcarpi>


    The same happens in all machines.
    I run with procmon and log, and run FixIT. I put the files in:

    http://cid-7faae3540a4980de.skydrive.live.com/self.aspx/.Documents/

    The files of the virtual machine are 'XPTest_' and of the real machine are 'Atomic_'

    Wednesday, November 11, 2009 3:42 PM
  • I was looking at "help Set-WSManQuickConfig", and remembered something from before...  Do you have the Windows Firewall enabled on this machine?  In the past, I think if the Windows Firewall was disabled on a computer the remoting setup would cause an exception.
    • Edited by Marco Shaw Wednesday, November 11, 2009 5:44 PM typo
    Wednesday, November 11, 2009 5:44 PM
  • The firewall was disabled.

    Now I try enabling/disabling the firewall in Atomic machine (an Asus EeePC 901 from I am writing now, that only has WinXp + Office 2003 + some portable admin tools) and I receive the same error messages.

    I try tomorrow on XPTest virtual machine at work.

    Wednesday, November 11, 2009 7:44 PM
  • I took a peak at the Process Monitor log and nothing stood out for me.
    Wednesday, November 11, 2009 8:03 PM
  • Hi,

    Thank you for update. From the log file, we cannot find Access Denied error.

    Also, I noticed that you run "winrm quickconfig" from the Powershell Console. Please try to run the command directly from Command Prompt console:

    Net stop winrm
    net start winrm
    winrm quickconfig

    Is there any error?

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, November 12, 2009 7:09 AM
  • Hi,
    I go to my XPTest machine, enable firewall and try Enable-PSRemoting and receive the same error.
    I go to command prompt and the same happens

    Microsoft Windows XP [Versión 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\jfcarpi>net stop winrm
    El servicio de Windows Remote Management (WS-Management) está deteniéndose.
    El servicio de Windows Remote Management (WS-Management) fue detenido con éxito.

    C:\Documents and Settings\jfcarpi>net start winrm
    El servicio de Windows Remote Management (WS-Management) está iniciándose.
    El servicio de Windows Remote Management (WS-Management) se ha iniciado con éxito.

    C:\Documents and Settings\jfcarpi>winrm quickconfig
    WinRM está configurado para recibir solicitudes en este equipo.
    WSManFault
        Message = Acceso denegado.

    Nº de error:  -2147024891 0x80070005
    Acceso denegado.

    And now success, I explain.

    I make a new virtual machine, but for that I use 'Windows for Legacy PCs' in english (for now I use spanish version of products), I install SP3 for WinFLP, dotNet2.0SP1 and install PowerShell 2.0, the output is

    Windows PowerShell
    Copyright (C) 2009 Microsoft Corporation. All rights reserved.

    PS C:\Documents and Settings\Administrator> Enable-PSRemoting

    WinRM Quick Configuration
    Running command "Set-WSManQuickConfig" to enable this machine for remote
    management through WinRM service.
     This includes:
        1. Starting or restarting (if already started) the WinRM service
        2. Setting the WinRM service type to auto start
        3. Creating a listener to accept requests on any IP address
        4. Enabling firewall exception for WS-Management traffic (for http only).

    Do you want to continue?
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help
    (default is "Y"):Y
    WinRM has been updated to receive requests.
    WinRM service type changed successfully.
    WinRM service started.

    WinRM has been updated for remote management.
    Created a WinRM listener on HTTP://* to accept WS-Man requests to any IP on this machine.
    WinRM firewall exception enabled.

    PS C:\Documents and Settings\Administrator>

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Administrator>winrm quickconfig
    WinRM already is set up to receive requests on this machine.
    WinRM already is set up for remote management on this machine.

    C:\Documents and Settings\Administrator>

    Thus I think, there are some problems with spanish versions ??

    Can submit the problem to PowerShell Team ??

    Any new idea ??
    • Marked as answer by Marco Shaw Thursday, November 12, 2009 1:26 PM
    • Unmarked as answer by jfcarpi Thursday, November 12, 2009 2:25 PM
    Thursday, November 12, 2009 11:57 AM


  • Thus I think, there are some problems with spanish versions ??

    Can submit the problem to PowerShell Team ??

    Any new idea ??
    Yes, you can submit feedback/bugs here:
    https://connect.microsoft.com/powershell
    Thursday, November 12, 2009 1:28 PM
  • This is the answer to your problem, I'm not sure why you unmarked this as the answer.  You resolved the problem...
    Thursday, November 12, 2009 2:54 PM
  • Sorry but the problem is unresolved.

    PowerShell Remoting by now not function on spanish version of products, may be have a bug this versions, but this is not a solution.
    And if the problem is not resolved it must be remain unanswered.

    I now making more tests and post here the results.

    Thursday, November 12, 2009 3:41 PM
  • The last test.
    I make a new virtual machine with WinXP SP2 spanish, apply SP3 spanish.
    Then I install dotNet2SP1 and Powershell english version, I take the same results: don't work.

    Windows PowerShell
    Copyright (C) 2009 Microsoft Corporation. All rights reserved.

    PS C:\Documents and Settings\jfcarpi> Enable-PSRemoting

    WinRM Quick Configuration
    Running command "Set-WSManQuickConfig" to enable this machine for remote
    management through WinRM service.
     This includes:
        1. Starting or restarting (if already started) the WinRM service
        2. Setting the WinRM service type to auto start
        3. Creating a listener to accept requests on any IP address
        4. Enabling firewall exception for WS-Management traffic (for http only).

    Do you want to continue?
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help
    (default is "Y"):Y

    WinRM service type changed successfully.
    WinRM service started.

    Set-WSManQuickConfig : <f:WSManFault xmlns:f="http://schemas.microsoft.com/wbem
    /wsman/1/wsmanfault" Code="5" Machine="xptestsp2"><f:Message>Acceso denegado. <
    /f:Message></f:WSManFault>
    At line:50 char:33
    +             Set-WSManQuickConfig <<<<  -force
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManQuickConfig], In
       validOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQu
       ickConfigCommand

    PS C:\Documents and Settings\jfcarpi>

    Microsoft Windows XP [Versión 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\jfcarpi>winrm quickconfig
    WinRM already is set up to receive requests on this machine.
    WSManFault
        Message = Acceso denegado.

    Error number:  -2147024891 0x80070005
    Acceso denegado.

    C:\Documents and Settings\jfcarpi>

    I go to submit the bug trough Connect site.
    But sorry, I understand that this question must remain unanswered until a solution is received.
    I will keep you informed of the powershell team's answers.

    Thank's to all.
    Thursday, November 12, 2009 4:41 PM
  • No, you should use the MS Connect site to go forward with this issue.  You can post the connect URL/ID here for others to reference and/or search on.

    You should mark this as answered here, because you've the best answer this forum can provide.
    Thursday, November 12, 2009 5:36 PM
  • Hi, now solved the problem.
    I receive this from Connect :

    This is by design. Please try the following and try again:
    Use Local Security Settings (Secpol.msc) to change the setting of the
    "Network Access: Sharing and security model for local accounts" policy
    in Security Settings\Local Policies\Security Options to "Classic".

    Then I try and is ok after changing security police to 'Classic'.
    I now making remoting to my HyperV server.

    PS: The link to Connect https://connect.microsoft.com/PowerShell/feedback/ViewFeedback.aspx?FeedbackID=510094
    • Marked as answer by jfcarpi Friday, November 13, 2009 8:18 AM
    Friday, November 13, 2009 8:18 AM
  • Hi,

    Glad to hear the problem was resolved. If you have more questions in the future, you’re welcomed to this forum.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, November 16, 2009 8:47 AM
  • I had the same issue. Configured WinRM on Vista x64, worked like a charm. Then tried on a virtual Win7 installation (VMWare Virtual Player). I always got this error, always! Access denied. I changed pretty much every security setting through gpedit and secpol until I finally found the culprit:

    German:
    Sicherheitsoptionen: Lokale Richtlinien: Sicherheitsoptionen -> Konten: Lokale Kontenverwendung von leeren Kennwörtern auf Konsolenanmeldung beschränken

    I don't know the exact English terms, but it's something like

    Security Settings-> Local policies->Security options->Accounts:bla bla -> set to "Deactivate"

    Nobody on the entire internet mentions this! Microsoft doesn't mention this! When you got a problem with windows, you are always left alone, no support, no nothing. Took me 3 hours to solve the problem, thanx Microsoft... 
    Wednesday, January 20, 2010 5:15 AM
  • Babel fish translates:

    Konten: Lokale Kontenverwendung von leeren Kennwörtern auf Konsolenanmeldung beschränken

    as

    Accounts: Local account use of empty passwords to console registration limit

    which I guess is actually "Accounts: Limit local account user of blank passwords to console logon only"


    :J
    Thursday, April 15, 2010 10:23 AM