none
If the WSE Server is down ...

    Question

  • Hi - I've found out the hard way, that now that WSE is handling all the domain/dhcp stuff - (rather than my router), if the server is "down", my clients can't even get onto the internet

    Q: Is it possible to configure things (preferably at the ad/domain end), so that if the WSE server is offline, my client pcs can at least get on the internet ?


    Thursday, July 19, 2012 6:47 PM

Answers

  • Thanks - adding my router's ip address to the DHCP Server's Scope as a 2nd DNS has indeed fixed the problem 

    But in case I'm barking up the wrong tree, it would be nice to have a definitive statement as to whether DHCP should be on the Server or the Router

    Friday, July 20, 2012 2:38 PM

All replies

  • Hi - I've found out the hard way, that now that WSE is handling all the domain/dhcp stuff - (rather than my router), if the server is "down", my clients can't even get onto the internet

    Q: Is it possible to configure things (preferably at the ad/domain end), so that if the WSE server is offline, my client pcs can at least get on the internet ?



    If you're using DHCP on your clients, then you must have a DHCP server running somewhere in your LAN.  If your router supports it, you could try setting up your router as a DHCP server as well, but have it hand out different IPs within the same subnet as the server (i.e. WS12E can hand out 192.168.1.10-99 and your router can hand out 192.168.1.100-199).
    Thursday, July 19, 2012 7:45 PM
    Moderator
  • The server does not do DHCP unless you installed it on the server?  My clients surf just fine with the server off.

    Grey

    Thursday, July 19, 2012 9:39 PM
    Moderator
  • I think the issue is DNS. A connected client is configured to use the DNS server of WSE. And this failes unless a second DNS server is configured manually.

    LightsOut - Power Management for Windows Home and Small Business Server http://www.homeserversoftware.com

    Friday, July 20, 2012 5:53 AM
  • The server does not do DHCP unless you installed it on the server?  My clients surf just fine with the server off.

    Grey

    I must admit I did install DHCP manually on the server - because I read in the documentation titled "Before You Install Windows Server 2012 Essentials" which states:

    "Windows Server 2012 Essentials ensures that DHCP is not running on both the server and the router— when DHCP is enabled on the router, DHCP is not enabled on the server during installation. When you run the Connect to the Internet Wizard after the installation is finished, DHCP is disabled on the router, and it is enabled on the server."

    I took that last bit to mean that if DHCP was not enabled on the router, it should/would be installed on the server ? 


    Friday, July 20, 2012 7:27 AM
  • Well it is beta :)  DHCP may or may not be supported.

    I think Martin is right, the issue is DNS.  in a "normall" install, (DHCP not on the WSE box) there is a client piece install with the connector that looks for the server.  If it sees the server it uses the server for DNS.  If it does not see the server it sets DNS to be what it was before.  For example if you take a laptop off the lan, it would not work if it did not go back to "normal"

    If you have DHCP on the server, then normall is the server.  So I am thinking what you should do is go into the DHCP Scope on the server and add your router to the DNS settings.  So you will have 2 listed.  Server then router.  Server is down, iot will use the router


    Grey

    Friday, July 20, 2012 11:18 AM
    Moderator
  • Thanks - adding my router's ip address to the DHCP Server's Scope as a 2nd DNS has indeed fixed the problem 

    But in case I'm barking up the wrong tree, it would be nice to have a definitive statement as to whether DHCP should be on the Server or the Router

    Friday, July 20, 2012 2:38 PM
  • You will have to wait until RTM for a definitaive answer :)

    Grey

    Friday, July 20, 2012 2:41 PM
    Moderator
  • Anyone have a link to the RTM answer now?

    For now I've decided to simply add my router as secondary DNS and disable the "Windows Server LAN Configuration"


    mark


    • Edited by markeboyle Saturday, December 8, 2012 5:25 AM
    • Proposed as answer by tinkererguy Friday, May 24, 2013 2:23 AM
    • Unproposed as answer by tinkererguy Friday, May 24, 2013 2:23 AM
    Saturday, December 8, 2012 4:55 AM
  • One way around this documented step-by-step here:

    http://www.tinkertry.com/ws2012e-dns-fix/

    so your router's DHCP server will grant your clients their DNS configuration, instead of DNS hard-coded (by a service) to point to your (possibly remote) server.

    Friday, May 24, 2013 2:25 AM
  • With the new Windows Server 2012 R2 Essentials (preview release out Jun 24 2013), turns out the domain join skip feature works, but still, there's the same issue with the client's DNS config:
    http://www.tinkertry.com/windows-server-2012-r2-essentials-preview-the-essentials-experience



    • Edited by tinkererguy Wednesday, June 26, 2013 3:31 AM removed spaces
    Wednesday, June 26, 2013 3:30 AM
  • I have been having this same problem with Windows Server 2012 Essentials (not R2).  I found the Tinkertry articles from this Tech Republic article:

    http://www.techrepublic.com/forums/questions/why-does-our-preferred-dns-server-setting-keep-reverting/

    I went looking for the Windows Server LAN Configuration, but discovered it was not there.  I kept following the article along to the Tinkeytry article where he was talking about disabling the connector - etc.  Step 7 - to change the registry key from False to True caught my attention.

    http://www.tinkertry.com/how-to-make-windows-server-2012-r2-essentials-client-connector-install-behave-just-like-windows-home-server/

    7) Next, Run regedit.exe, then head to this key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Networking\ServerDiscovery
    then change “SkipAutoDNSServerDetection” from False to True.

    I changed the key for one of my users and had them shut down and cold boot.  I had them try the wireless, and it seemed to work.  I have two Server 2012 Essentials domains I manage, so I am going to try it with other users, and will report back.  My only concern is when they connect back to the domain it would revert for some silly reason.

    Thank You Paul Braren and Bill Gilliss.  

    Tuesday, December 2, 2014 2:39 AM
  • Just to chime in with my own two pence,

    I wrote about the Lan Configuration Service and why it does what it does here, http://titlerequired.com/2013/06/17/unravelling-the-mystery-of-client-dns-with-essentials-family-servers/

    I also put a script together to handle the UR3 changes to Essentials 2012.

    http://titlerequired.com/2014/02/14/essentials-2012-manage-dns-autodiscovery/


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+

    Friday, December 12, 2014 1:05 PM
    Moderator
  • Added a little addendum over here today, on a related thread (yeah, this DNS stuff is a VERY common issue for folks):

    https://social.technet.microsoft.com/Forums/en-US/winserveressentials/thread/603bf59c-4b1f-4fa1-817e-8d0a6bbf236f/#b3f82c6e-aebd-4b84-ae86-f721528ec250

    Friday, December 12, 2014 8:12 PM