none
Cutting Logon Delay from a minute to seconds... RRS feed

  • Question

  • So in GP, there is this

    Configure Logon Script Delay

    in this location

    computer policies/ Admin Templates /system/group policy

    Not configuring it delays it to 5 min...Putting it to 0 delays it to 5 minutes as well..

    1 minute is too long, I need it to go to seconds, but if I put in .50 or .20 it automatically goes

    to 5 or 2...  Can I get this to go to about 20 seconds?

    Thursday, November 15, 2018 10:38 PM

Answers

  • I have this fixed... Some actually changed the wallpaper setting in BGinfo. Still it would be nice to be able for other reasons to cut the time to 30 seconds or so...
    • Marked as answer by David-71 Friday, November 16, 2018 9:47 PM
    Friday, November 16, 2018 9:47 PM

All replies

  • Hello David.

    The values are unfortunately only in minutes, so 1 minute is the minimum delay you can set for this GPO.

    If you want the logon scripts to run at user logon without any delay, you should configure the setting to Disabled.

    If you enter the time in minutes as zero (0), the setting is also Disabled, and the Group Policy client runs the logon scripts at user logon without any delay.

    Since you already tried setting the minutes to zero (0) you could try configuring this GPO as Disabled to see if there's an improvement or not.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, November 16, 2018 12:46 AM
  • Hi, David
    Based on your description, I found this policy and carefully read the detailed description of this policy.
    We can see policy description as below:

    1. Enter “0” to disable Logon Script Delay. If you disable this policy setting, Group Policy will run scripts immediately after logon.

    2. If you enable this policy setting, Group Policy will wait for the specified amount of time before running logon scripts.
    3. By default, the Group Policy client waits five minutes before running logon scripts. This helps create a responsive desktop environment by preventing disk contention.
    If you do not configure this policy setting, Group Policy will wait five minutes before running logon scripts.

    In summary, this policy setting allows you to configure how long the Group Policy client waits after logon before running scripts. The delay time for this policy is in minutes, it is designed by Microsoft, we can not change it. We either disable this policy, Group Policy will run scripts immediately after logon
    And if we must use this policy, the shortest delay can be configured for 1 minute.

    Thank you for your understanding and supports.
    Best Regards,
    Daisy Zhou

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 16, 2018 3:14 AM
    Moderator
  • Hello, Leon and Daisy I know that disabling it sets it to 0 minutes. Here is my problem with that...

    In my logon bat, I have lines to run some regedits, and also to copy down some shortcuts to the desktops

    and then start two programs, one being our main app and the 2nd is bginfo... So, if I set it to zero, then everything else starts in that logon bat, but bginfo does not...I can't for the life of me figure out why. I copied the login bat directly to a user desktop and it starts just fine running it as the user.... so no problem there... IT is when I set it to 0 everything else works, the regedits, the shortcut copies and the launching of the main app all works.. Now, when I set it to 1 minute or 2 minutes, everything works...bginfo included, but that delay is horrible.   .... So, I thought, maybe bginfo is launching before the desktop is ready, (this is a citrix environment and we use folder redirection and profile server) so.... , I put it back to start right away, and then I put bginfo as the last item and the line above it, a sleep line and have tried 20 seconds, 30

    seconds, 40 seconds...etc, and it doesn't launch at all again.. So the best thing that I came up with was putting  the bginfo line in the start these programs at logon, in the group policy and that cuts the time down in half, but still not optimal...So I am really left perplexed with this... this used to work, just fine, but then it stopped, and I am not sure why... Also, I have tried the start bginfo line in the powershell section, and it is also delayed by a lot.... Any help is appreciated.

    Friday, November 16, 2018 4:38 AM
  • I have this fixed... Some actually changed the wallpaper setting in BGinfo. Still it would be nice to be able for other reasons to cut the time to 30 seconds or so...
    • Marked as answer by David-71 Friday, November 16, 2018 9:47 PM
    Friday, November 16, 2018 9:47 PM
  • Hi,
    Thank you for your update. I am so glad that our problem has been resolved.

    Have a nice day!

    Best Regards,
    Daisy Zhou

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 19, 2018 12:58 AM
    Moderator