Windows update broke Microsoft Visual Basic 6.0 Common Controls: mscomctl.ocx and comctl32.ocx


  • We've been using a plugin, written in VBA, in Word 2007 on Windows 7 happily for a couple of years now.

    This morning (2012-04-12) it stopped working.  After a lot of messing about, including uninstalling some Office 2010 components (I don't recall installing it - was it part of the update?), and some Visual Studio (Express) type tools, reinstalling Office (2007) entirely, I finally narrowed it down to the "Visual Basic 6.0 Common Controls" (in VBA -> Tools|References).

    I fixed it on my machine by reinstalling from

     but now a colleague has the same problem (in a different country, so I can't easily poke around his machine), and just reinstalling from that URL doesn't fix it.  He has worked around for the moment by restoring to the System Restore point created before the update.

    I'm hoping this is a bug, rather than a policy decision to no longer support those controls.


    Thursday, April 12, 2012 5:52 PM


All replies

  • IT would seem that the MSCOMCTL.OCX file was deregistered by one of the recent updates.

    Please try reregistering the two .OCX files:

    Go to - C:\windows\system32\    and run "regsvr32 mscomctl.ocx" (for 32 bit Win7)

    Go to - C:\windows\syswow64\   and run "regsvr32 mscomctl.ocx" (for 64 bit Win7)

    Do the same for comctl32.ocx where ever you find it.

    Hope this helps until Microsoft creates another fix to fix this bug.

    • Edited by AKENK Thursday, April 12, 2012 9:13 PM
    Thursday, April 12, 2012 9:11 PM
  • Hello,

    This forum is for general discuss of Windows Server questions.

    For this query, I’d suggest you post in both Microsoft Office forum and VB forum for the accurate explanation of this problem.

    Microsoft Office

    Office 2010 Application Compatibility

    Visual Basic


    Friday, April 13, 2012 3:21 AM
  • Where did you repost this question? I need to follow it as the same problem has occured on my system and I cannot update my system until it is fixed....
    Thursday, August 30, 2012 8:09 PM
  • Hi kellyjmartens and DAVEx7

    Our company has two windows 7 home premium computers on which reside our legacy development platforms for the two, respectively, VB6.0 Applications. When this April update came out it was automatically installed and both system automatically and systematically crashed with the new found inability to load the aforementioned Active X libraries.

    Our Clients needed fixes that we couldn't work on. Our development efforts ground to a screeching halt. Our support team had no 3d tier support because the programmers were helpless. This is in the name of an automatic update from Microsoft. I'm not so sure I can, in good faith, recommend un-monitored (automatic) updates from Microsoft any longer. This hurt us.

    To fix the problems from Microsoft, I had to regedit HKCR\TypLib right-click/Permissions... Add current User, Allow Full Control and Read.(special permissions too?) and apply to child keys and data as well.

    This immediately fixed the problem. It is not possible to do as AKENK has suggested (re register the deregistered active x controls) without permissions to write to the registry.

    I don't see how the above links, which don't solve the problem can possibly be marked as the "Answer" again, in good faith. Rather, they toe the Microsoft line. 

    So, kellyjmartens, to fix it, try the above as I'm sure the above links supplied didn't fix anything. It was, however, the "Answer". 

    Some tourists were flying in a helicopter in the great northwestern US heading from Boise to Seattle and enjoying the beautiful scenery when the pilot lost track of time and subsequently their position. Trying to read water tower marking was ineffective so coming up to a large building the passenger held up a sign "WHERE ARE WE?" it said. A person in the cafeteria scrambled to reply with their own sign, "YOU'RE IN A HELICOPTER" was the reply. Perplexed the passenger thought the misinformation strange but the pilot, confident as to their location, turned to a heading and proceeded directly to the Seattle destination. On arriving the passenger asked how he knew where they were from the cryptic sign he replied "The information they gave was absolutely accurate but totally useless so I knew we were at Microsoft."

    Thus it is with the information to which most links refer. The above "Answer" clearly within that category and the one I've just posted will solve your problem.

    --Wes Writes Code

    • Proposed as answer by kellyjmartens Thursday, September 15, 2016 3:02 PM
    Monday, March 25, 2013 8:20 PM