Windows Server 2012 ---- Server Manager Error ---- Online - Data retrieval failures occured


  • I have been working with DPM 2012, and have two DC's. while working with DPM one of the servers "Server manager" now gernerates this error when trying to view Role & Features.....can't view em.

    Screen Shot

    These are further details/ info  on the error.

    Error ITGDC1 : Configuration refresh failed with the following error: The metadata failed to be retrieved from the server, due to the following error: The WS-Management service cannot process the request. The class MSFT_ServerManagerTasks does not exist in the root/microsoft/windows/servermanager namespace.   2/22/2013 9:06:41 AM

    I have tried with no luck

    - DISM /Online /Cleanup-Image /RestoreHealth

    - Checked event logs



     Also tried this from other posts on MS Site

    - invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_servermanagertas
    ks -methodname GetServerInventory -arguments @{SMServerID='My Server Name'}

    which generates the error 

     "invoke-cimmether: invalid calss"

    - winrm quickconfig

    and other things I tried/ looked into at this point don't remember all of them.

    I seen that other people have experienced this issue but mostly with Win 2008 R2 and were told to run Microsoft's System Update Readiness Tool for Windows Server 2008 R2 x64......But since I am having the same problem on Win Serv 2012, this cannot be ran on the newer server version.

    Don't know what else to try....getting ready to do an in place upgrade....2012 to 2012....or do a fresh install ....

    This is a VM running on a Hyper-V / SCVVM 2012 box....

    Any help would be greatly appreciated......

    Thanks !!


    Friday, February 22, 2013 2:43 PM

All replies

  • Refer to the below KBs first. If it doesn’t help, I’d try in-place upgrade to repair install this VM

    "The WS-Management service cannot process the request" error message after the WinRM service restarts in Windows Server 2012 message in Windows Server 2008 R2 or in Windows 7 when you try to connect to a remote server: "Server Manager cannot connect to <server_name>"





    TechNet Subscriber Support

    If you are TechNet Subscriptionuser and have any feedback, please send your feedback here.

    Monday, February 25, 2013 2:55 AM
  • Hi,

    Thank you for the recommended actions to try.

    With regards to WinRM /qucikconfig, I had tried this before and it didn't resolve the issue.

    The install is a Full GIU Vm that was running before, but now it seems the Inventory database is not functioning properly. I am able to remotely connect, with Server manager from a Win 8 box, its just that the inventory data seem to be stuck/ corrupt.

    The other commands you have kindly provided a link to, would not be an option since the install is a GUI install, and not a Core install.

    At this point it seems that an inplace upgrade is the only option.

    Over all this is concerning and hope that this does not become a common issue with Win Server 2012.

    Best Regards



    Monday, February 25, 2013 12:24 PM
  • Friday, September 27, 2013 12:42 PM
  • It is loo late, maybe, but may be useful for one's, who will find this post like me.

    I broke down WMI repository and got the same error. More detailed, part of server management WMI repository was missing due to unsuccessful reconstruction:

    Get-CimClass -Namespace root\microsoft\windows\servermanager -Class MSFT_ServerManagerTasks
    Get-CimClass : Not found
    At line:1 char:1
    + Get-CimClass -Namespace root\microsoft\windows\servermanager -Class MSFT_ServerM ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (root\microsoft\...verManagerTasks:String) [Get-CimClass], CimException
        + FullyQualifiedErrorId : HRESULT 0x80041002,Microsoft.Management.Infrastructure.CimCmdlets.GetCimClassCommand

    I was able to fix it by running this script, based on

    Without the 32-bit part repair was not complete, errors appeared.

    sc config winmgmt start= disabled net stop winmgmt /y %systemdrive% cd %windir%\system32\wbem for /f %%s in ('dir /b *.dll') do regsvr32 /s %%s for /f %%s in ('dir /b *.exe') do regsvr32 /s %%s cd %windir%\sysWOW64\wbem for /f %%s in ('dir /b *.dll') do regsvr32 /s %%s for /f %%s in ('dir /b *.exe') do regsvr32 /s %%s

    cd %windir%\system32\wbem

    wmiprvse /regserver winmgmt /regserver sc config winmgmt start= auto net start winmgmt cd %windir%\system32\wbem for /f %%s in ('dir /s /b *.mof *.mfl') do mofcomp %%s cd %windir%\sysWOW64\wbem for /f %%s in ('dir /s /b *.mof *.mfl') do mofcomp %%s pause

    Please don't run it without thinking first, only like a last resort - because 3rd party WMI addons may stop working, so you will have to reinstall software in question, or even the OS itself.

    Из ослиного гнезда ... :)

    • Edited by bazanovv Thursday, October 10, 2013 11:19 AM
    • Proposed as answer by aalyam Sunday, May 29, 2016 7:50 AM
    Thursday, October 10, 2013 11:14 AM