MPS 2012 Stuck in Console Mode RRS feed

  • General discussion

  • I have been using MPS2011 for some time and have sometimes had the issue where it just logs into the SRCshell account spanned over all the monitors.  To fix this I used to go into the user settings and set it back to requiring Ctrl-Alt-Del at logon then switch it to normal mode in MPS manager.

    Unfortunately MPS2012 seems to be way more unreliable and this fix no longer works so every two weeks I seem to have to reinstall the piece of junk again.  I have looked through the event logs which reveal nothing about MPS and have tried the log collector which is really good at generating a whole stack of content but no good at pointing out what might be a problem.  Is there anyone at Microsoft that knows how this stuff works and could point me in the right direction as the next reinstall is back to 2011 and will signal my giving up on the platform.

    The machine in question has six locally connected monitors and works great for about two weeks before if drops out to WMSShell never to return to Normal mode.

    Tuesday, July 9, 2013 11:38 AM

All replies

  • Hello,

    I'm sorry to hear that you are having problems with WMP2012, I'm using it and so far no problems, have you tried to enter MultiPoint Manager then select "Switch to station mode".


    Jorge Montaño, Microsoft Partner, http://jorgemontano.wordpress.com/

    Friday, August 2, 2013 7:16 PM
  • I have the exact same problem. The support on this OS is awful. 
    Tuesday, May 20, 2014 3:17 PM
  • and have tried the switch to station mode.......!!!!!! :D
    Tuesday, May 20, 2014 3:24 PM
  •   If you could, please run regedit and navigate to \HKEY_USERS\. There should be a list of S-1 folders - please select the first one that has more than 4 numbers, i.e. S-1-5-21-XXXXXXXX-XXXXXXX. Then, navigate to \Software\Microsoft\Windows NT\CurrentVersion\Winlogon. The key for "Shell" should be set to C:\Program Files\Windows MultiPoint Server\WmsShell.exe.

    Can you confirm that this is what you are seeing in the registry when you are having this issue, or if it is something else?  

    Friday, May 23, 2014 12:35 AM
  • I am having the same problem as mentioned above.  This registry key simply does not exist on any of the 2012 MP Servers that I have.
    Monday, September 8, 2014 6:36 PM
  • FIXED!


    tutorial here on how to fix

    Thursday, July 2, 2015 12:22 PM
  • Hi, If you hit this in WMS 2012, you should be able to just delete the user "WmsShell" and then restart the system. The WMS repair service will detect the missing account and recreate it which will restore the missing shell registry entry.

    If you have any ideas about what's causing this to happen, though, we'd love to hear them! We've theorized that maybe something is damaging the profile and causing Windows to load the WmsShell user using a temporary profile (or to create a new one). The temporary profile would have just the standard shell (explorer.exe) configured which matches the observed behavior above.

    We've made some improvements to the repair service in the new MultiPoint Services role in Windows Server 2016 to detect and resolve this, and may be able to include it in a future update roll up for WMS 2012.


    Friday, July 10, 2015 12:37 AM
  • I solved the locking problem stuck in console mode.

    Install WMS2012, create a account Administrator, after this create other account Adminstrator (Admin).

    Creat a shortcut "wmsshell.exe", double click in and login with the second account Administrator (Admin).

    The Shell start in Station Mode.

    Wednesday, June 27, 2018 1:00 AM