none
W32Time event ID 24 and 29

    Question

  • I have one member server (VM) that is reporting Event ID 24 and 29 in relation to one of our DC (GC). Both the DC GC and DC FSMO are referred to as the name servers on this member server.

    So I checked the DC GC that it's reporting the error for and when I open a CMD prompt at type 'net time' it refers to our main DC (FSMO) and the command completed successfully.

    When I type the same command on the FSMO, it refers to an external time source

    When I type the command on the member server it also refers to the FSMO and command completed successfully

    All this looks ok to me so why is the member server reporting W32Time errors. I've read around on this issue and found no one answer, only do this and do that for many many different things (which I'm not prepared to do). I'd prefer a suitable suggestion

    Thursday, February 17, 2011 9:35 AM

Answers

  • If you are having time sync problems, try the following:

    From a command prompt on the member server
     "net time /setsntp: "                  (Note the blank space prior to the end ")
      The prior command line tells the member server to delete the current registry settings for the time service

    Follow this by: 
     w32tm /config /syncfromflags:domhier /update
      The prior command line should reset the domian time hierarchy

    Follow this by:
     net stop w32time && net start w32time
      This member should now be part of the time domain heirarchy

    --
    Paul Bergson
    MVP - Directory Services
    MCITP: Enterprise Administrator
    MCTS, MCT, MCSE, MCSA, Security+, BS CSci
    2008, Vista, 2003, 2000 (Early Achiever), NT4
    http://www.pbbergs.com    Twitter @pbbergs
    http://blogs.dirteam.com/blogs/paulbergson

    Please no e-mails, any questions should be posted in the NewsGroup. This
    posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, February 18, 2011 1:03 PM
    Moderator
  • I went with this in the end and it seems to have worked.

    • w32tm /config /manualpeerlist:NTP_server_IP_Address, 0x8 syncfromflags:MANUAL
    • net stop w32time
    • net start w32time
    • w32tm /resync

    Friday, February 18, 2011 3:25 PM

All replies

  • Hello,

    make sure the integration services or Vmware tools are disabled for time sync. Also for VMware if this si the case search there knowledge base about adding additional lines into the config file of the VM. Sometimes this is required even if time sync is disabled.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Thursday, February 17, 2011 10:37 AM
  • This is normal & seen because of time conflict between host on VM 7 DC time, take a look at below.

    http://support.microsoft.com/kb/976924

     

    Regards


    Awinish Vishwakarma| MYBlog

    Disclaimer : This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    Thursday, February 17, 2011 11:00 AM
    Moderator
  • Ok, couple of things to query,

    1. This is a member server not a DC

    2. It's not happening on other VM's

    3. This is 2003 VM server running on Virtual Server 2005

    Thursday, February 17, 2011 11:10 AM
  • Take a look at below troubleshooting.

    http://msmvps.com/blogs/markd/pages/15677.aspx

    http://www.mcbsys.com/techblog/2010/08/w32time-errors-in-a-hyper-v-virtual-environment/

    Is you windows 2003 is having latest SP & security patches installed, if not install & try.

     

    Regards


    Awinish Vishwakarma| MY Blog

    Disclaimer : This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    Thursday, February 17, 2011 12:46 PM
    Moderator
  • The first link relates to a DC, my problem is with a member server (as already mentioned)

    The second relates to Hyper-V, again this server is a VM on VS2003

    Friday, February 18, 2011 9:05 AM
  • If you are having time sync problems, try the following:

    From a command prompt on the member server
     "net time /setsntp: "                  (Note the blank space prior to the end ")
      The prior command line tells the member server to delete the current registry settings for the time service

    Follow this by: 
     w32tm /config /syncfromflags:domhier /update
      The prior command line should reset the domian time hierarchy

    Follow this by:
     net stop w32time && net start w32time
      This member should now be part of the time domain heirarchy

    --
    Paul Bergson
    MVP - Directory Services
    MCITP: Enterprise Administrator
    MCTS, MCT, MCSE, MCSA, Security+, BS CSci
    2008, Vista, 2003, 2000 (Early Achiever), NT4
    http://www.pbbergs.com    Twitter @pbbergs
    http://blogs.dirteam.com/blogs/paulbergson

    Please no e-mails, any questions should be posted in the NewsGroup. This
    posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, February 18, 2011 1:03 PM
    Moderator
  • I went with this in the end and it seems to have worked.

    • w32tm /config /manualpeerlist:NTP_server_IP_Address, 0x8 syncfromflags:MANUAL
    • net stop w32time
    • net start w32time
    • w32tm /resync

    Friday, February 18, 2011 3:25 PM