none
Event ID: 1054 - Windows cannot obtain the domain controller name.

    General discussion

  • Hello...I have read the past posts in regards to this specific issue, but the resolution didn't work. I have tried adding the Reghack and updated the NIC drivers. Our client OS is Windows XP. I am able to authenticate with the DC's, but when you look in the event logs the following is tagged:

    Windows cannot obtain the domain controller name for your computer network. (An unexpected network error occurred. ). Group Policy processing aborted.
    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    The time provider NtpClient was unable to find a domain controller to use as a time source. NtpClient will try again in 15 minutes.

     

    The funny thing is some of the GPO’s that I defined have been applied – just added some interactive messaging, and that worked?!? When I go to the ‘run’ command I can hit the domain controller and see the SYSVOL share.

     

    This is a brand new setup with two Windows 2003 SP domain controllers.

    ZT

    • Changed type Bruce-Liu Monday, November 9, 2009 2:49 AM
    Friday, October 30, 2009 4:54 PM

All replies

  • ZT, 
    A few general diagnostic questions:
    1. What service pack level are your systems (DCs and client)?
    2. Are there any other time related errors on the DCs or clients?
    3. What is the output of GPRESULT on the client?

    Finally, you mention that some policies are being applied. Are there GPOs that are not being applied? What types of settings do those contain?

    Guy
    Friday, October 30, 2009 5:01 PM
  • Guy,

    1. DC = Windows 2003 - Standard SP2    OS = Windows XP Pro SP2
    2. There are no time related errors on the DC - the DC's look good as there are no errors being logged on them. There are time related errors on the client though "The time provider NtpClient was unable to find a domain controller to use as a time source. NtpClient will try again in 15 minutes.".
    3. Here is what I received when I ran "gpresult":

    INFO: The user "DOMAIN\user account" does not have RSOP data

    ZT

    Friday, October 30, 2009 5:20 PM
  • I ran the following:

    DCDIAG - Passed
    NETDIAG - DNS failed, so more than likely this could be the overall cause of the issue.

    DNS test . . . . . . . . . . . . . : Failed

        [WARNING] The DNS entries for this DC are not registered correctly on DNS
    se
    rver '192.168.1.3'. Please wait for 30 minutes for DNS server replication.

        [FATAL] No DNS servers have the DNS records for this DC registered.

    ZT

    Friday, October 30, 2009 5:31 PM
  • ZT,
     That sounds right. DNS issues would cause both the group policy and time issues. I would verify the DNS addresses on each DC and make the service is running. 

    Also, check the _msdcs DNS zone for records related to each DC. If records are missing, you can restart the netlogon service on a DC to force it to register its records. Error logs on the DC (DNS, Directory Service, Application) should give you more information about anything that's going wrong.

    Guy
    Friday, October 30, 2009 6:12 PM
  • OK, I restarted both the 'netlogon' and 'dns' service then re-ran 'netdiag'. It passed. DNS figured itself out. I went to a client system and the time sync is now fixed - thank you!!

    Ran a 'gpupdate /force', but still receiving the GPO error.

    ZT
    Friday, October 30, 2009 7:19 PM
  • This is driving me crazy now. Everything from the domain controller point of view looks good. Everything passes when running DCDIAG & NETDIAG. I can login into multiply systems on the domain with domain accounts and the systems even register in AD. Just keep receiving this error when group policy is trying to be applied. I have removed the group policy's and re-created - same result. Everytime I run "gpresult" I receive the following:

    INFO: The user "DOMAIN\user account" does not have RSOP data

    ZT
    Sunday, November 1, 2009 11:29 PM
  • ZT,
     To confirm: you are getting no group policy processing on a client XP machine with the above error coming up when you run GPresult, correct?

    Sorry if this is duplicate information, but does this happen on only one machine or more? does it happen for any user on the impacted machine? are there any other errors related to GPOs or domain communication on the impacted machines? Can you check %windir%\debug\usermode\UserEnv.log and %windir%\security\logs\winlogon.log for relevant errors?

    Guy

    Monday, November 2, 2009 5:25 PM
  • I hope someone is reading this thread still since it is old.

    I have similar issue with our XP client computers.

    We have a single domain with a few domain controllers in different locations. I have tried all the suggestions found from Microsoft and other forums, none seem to help.

    When I changed the subnet of the location where the problem computers are in, to a different Active Directory site, it works ok.

    The site that doesn't work have two domain controllers. One is Windows 2003 SP2 and this is also the primary DNS server. The other domain controller is Server 2008 R2. This is not a DNS server. These two domain controllers are both GC.

    The site that works has one domain controller. It is Server 2008 R2. It is a GC, DC and DNS server.

    I do not know where to look next since I know for sure now that the NIC is not the problem and the network devices at the location where the problems PC reside are not an issue (I made sure there was no access list on the router either).

    I ran all the dcdiag and netdiag tests on all domain controllers and have found no problems. NLTEST lookup from the problemed PCs returned correct domain controller. Ping works fine too.

    Please advice.


    Thanks in advance.

    Wednesday, October 6, 2010 6:56 PM
  • Hi,

     You may want to open a new thread with this question since that will get more visibility.

     

    In addition, please describe in more detail the symptoms of your problem (it sounds different than the thread since your dcdiag/netdiag were clean where the original thread's were not).

     

    Thanks,

    Guy

    Wednesday, October 6, 2010 9:01 PM
  • I know this is old but I wanted to share my findings - this was the top Google result on my search.  I've just had this issue and found that it was related to our firewall. ICMP was being blocked which meant that Slow Link detection failed and Group Policy wasn't applied.

    Make sure that ICMP (type=0) is allowed from your domain controllers.


    Systems Engineer

    Wednesday, May 3, 2017 2:25 AM