none
Startup script working on Windows 7/2008, but not in Windows XP/2003 RRS feed

  • Question

  • Hi all,

    I've created a startup script for calling a executable file, that launch our inventory tool. Now, I'm going crazy, because this script runs fine on Windows 7/2008 computers, but doesn't appear to run in Windows XP/2003 computers.

    The funny thing here is that if I launch the startup script AFTER logon (no matter the account I used to log into the computer) from a CMD prompt opened as SYSTEM (by running the following command: at HH:MM /interactive cmd.exe), it works perfectly...

    I've enabled the "Always wait for the network at computer startup and logon" setting months ago, prior to this startup script. There's no relevant information in the event viewer or in the userenv.log (or at least, I can't see much).

    Any ideas?

     

     

     

    Monday, February 6, 2012 12:43 PM

Answers

  • Am 07.02.2012 14:06, schrieb hardcrack:
    > So, I guess my only solution is to set to not cofigured the "Always
    > wait for the network at computer startup and logon" setting, right?
     
    No, there's a different setting to configure how startup and logon
    scripts are executed (sync or async). Enable Computer configuration -
    Policies - Administrative Templates - Scripts: "Run Startup Scripts
    asynchronously". A similar setting is available in the same path under
    User configuration for logon scripts.
     
    sincerely, Martin
     

    A bissle "Experience", a bissle GMV... Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Marked as answer by hardcrack Wednesday, February 8, 2012 9:40 AM
    Tuesday, February 7, 2012 4:10 PM

All replies

  • Hi,

    Thanks for your posting.

    Please generate a Group Policy Result for your XP client and check the GPO applied status, Applied or Denied?

    And Startup script runs in the system context, before the users log on. Active Directory handles the elevation of privileges required for access your inventory tool.

    So please check also whether these XP computer accounts have privilege to access your network share.

    For more information please refer to following MS articles:

    Use Group Policy to assign computer startup scripts for 2007 Office deployment
    http://technet.microsoft.com/en-us/library/cc179134(v=office.12).aspx
    Assign Computer Startup Scripts
    http://technet.microsoft.com/en-us/library/cc770556.aspx


    Lawrence

    TechNet Community Support


    Tuesday, February 7, 2012 2:28 AM
    Moderator
  • Hi Lawrence,

    The GPO status is applied. The XP computers can access the share with no problems, note that I've checked that with a CMD prompt launched as SYSTEM the script runs fine.

    Also, it's not a timeout problem, the script it's just one line that launches an .exe, and this .exe runs for about only 1 minute.

    Regards

    Tuesday, February 7, 2012 7:45 AM
  • Am 07.02.2012 08:45, schrieb hardcrack:
    >
    > Hi Lawrence,
    >
    > The GPO status is applied. The XP computers can access the share with
    > no problems, note that I've checked that with a CMD prompt launched as
    > SYSTEM the script runs fine.
    >
    > Also, it's not a timeout problem, the script it's just one line that
    > launches an .exe, and this .exe runs for about only 1 minute.
    >
    > Regards
    >
    Does it launch this exe asynchronous? This will not work if you execute
    startup scripts synchronously - the hosting process will terminate all
    child processes when startup scripts are finished...
     
    sincerely, Martin
     

    A bissle "Experience", a bissle GMV... Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Tuesday, February 7, 2012 12:48 PM
  • Hi Martin,

    I've not configured the "Run startup scripts asynchronously" setting, but I've configured the "Always wait for the network at computer startup and logon" setting to enabled. According to http://support.microsoft.com/kb/305293/en-us, I understand that this causes to run synchronously all the startup scripts.

    So, I guess my only solution is to set to not cofigured the "Always wait for the network at computer startup and logon" setting, right?

    Tuesday, February 7, 2012 1:06 PM
  • Am 07.02.2012 14:06, schrieb hardcrack:
    > So, I guess my only solution is to set to not cofigured the "Always
    > wait for the network at computer startup and logon" setting, right?
     
    No, there's a different setting to configure how startup and logon
    scripts are executed (sync or async). Enable Computer configuration -
    Policies - Administrative Templates - Scripts: "Run Startup Scripts
    asynchronously". A similar setting is available in the same path under
    User configuration for logon scripts.
     
    sincerely, Martin
     

    A bissle "Experience", a bissle GMV... Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Marked as answer by hardcrack Wednesday, February 8, 2012 9:40 AM
    Tuesday, February 7, 2012 4:10 PM
  • Martin, thank you, that solved my problem.

    Regards

    Wednesday, February 8, 2012 9:40 AM
  • U're welcome (:
     

    A bissle "Experience", a bissle GMV... Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Wednesday, February 8, 2012 11:56 AM