microsoft software shadow copy provider service missing


  • I have a SBS 2003 server that is missing the microsoft software shadow copy provider service.  I have tried to reregister the DLLs, but it errors out on regsvr32 /i swprv.dll.  I have installed these 3 hotfixes:

    1.KB 943669

    2.KB 975928

    3.KB 979457


    Does anyone have any other suggestions?


    K Haroldsen
    Friday, March 11, 2011 1:56 AM

All replies

  • Can you give me output of following command

    vssadmin list writers





    Friday, March 11, 2011 9:48 AM
  • Here it is:

    C:\Documents and Settings\npadmin>vssadmin list writers
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001 Microsoft Corp.

    Writer name: 'MSDEWriter'
       Writer Id: {f8544ac1-0611-4fa5-b04b-f7ee00b03277}
       Writer Instance Id: {2a3303f5-e240-452e-be12-bac136432eb0}
       State: [1] Stable
       Last error: No error

    Writer name: 'Dhcp Jet Writer'
       Writer Id: {be9ac81e-3619-421f-920f-4c6fea9e93ad}
       Writer Instance Id: {29a989ba-4b29-47a8-a6d4-e4f6487e0ef9}
       State: [1] Stable
       Last error: No error

    Writer name: 'Registry Writer'
       Writer Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}
       Writer Instance Id: {d80acd49-6de4-431f-a925-ba3cf480da80}
       State: [1] Stable
       Last error: No error

    Writer name: 'COM+ REGDB Writer'
       Writer Id: {542da469-d3e1-473c-9f4f-7847f01fc64f}
       Writer Instance Id: {c0e13483-7f46-4d75-ae77-a9dc8bae04db}
       State: [1] Stable
       Last error: No error

    Writer name: 'Event Log Writer'
       Writer Id: {eee8c692-67ed-4250-8d86-390603070d00}
       Writer Instance Id: {7bd66a00-f592-49ed-b56a-ec9f3c59200c}
       State: [1] Stable
       Last error: No error

    K Haroldsen
    Friday, March 11, 2011 4:52 PM
  • So you have vss service inside your system.


    Can you take snapshots from Computer->Configure Shadow copies option?


    If yes can you describe complete problem details?



    Monday, March 14, 2011 10:10 AM
  • I cannot run a system state backup.  This is the error from NT Backup:


    Backup Status
    Operation: Backup
    Active backup destination: File
    Media name: "test.bkf created 3/10/2011 at 5:42 PM"

    Volume shadow copy creation: Attempt 1.

    Error returned while creating the volume shadow copy:0x8004230c.

    Error returned while creating the volume shadow copy:8004230c
    Aborting Backup.


    The operation did not successfully complete.


    I have attached a screen shot showing what happens when I try to look at the shadow copy config on a drive, as well as the service list that shows the missing MS shadow copy provider service.  Thanks for your help.


    Here are the screenshots:


    K Haroldsen
    Monday, March 14, 2011 6:06 PM


    8004230c means "Shadow copying the specified volume is not supported.".

    Are services enabled?

    Try the following

    Click Start, then Run and type in services.msc . In the list of services scroll down to Microsoft Software Shadow Copy Provider. Double click it, ensure Start up option is set to Automatic, click Apply then Start

    Do let me know if it helps



    Wednesday, March 16, 2011 6:34 AM
  • The service doesnt exist!  It is not in the list.  Check out the screen shots I gave you above.  I cannot enable or disable shadow copies on any drive.  They all show the same failure.  No way to uncheck it and turn it back on again.
    K Haroldsen
    Wednesday, March 16, 2011 7:06 AM
  • Are you able to see swprv.dll inside c:\Windows\system32\swprv.dll?

    send me the error message for

    regsvr32 swprv.dll.




    • Proposed as answer by alex3518 Monday, April 07, 2014 4:25 AM
    • Unproposed as answer by alex3518 Monday, April 07, 2014 4:25 AM
    Thursday, March 17, 2011 10:02 AM
  • Yes, the .dll is there.  When I try to register the dll I get this error:


    DllRegisterServer is swprv.dll failed.

    Return code was: 0x8000ffff

    K Haroldsen
    Thursday, March 17, 2011 5:37 PM
  • I'm having the same problem on my Server 2008 R2 machine.

    No providers are listed in vssadmin list providers but it shows 'Microsoft Software Shadow Copy provider 1.0' in the VSS providers in the registry.

    i get no errors when i run vssadmin list writers

    'Microsoft Software Shadow Copy provider 1.0' does not show in my services and i cannot get my backups to work.

    I cannot access my backup schedule either as it keeps coming up Windows Backup Service has stopped and i cannot find the service anywhere

    Thursday, November 10, 2011 10:59 AM
  • Did anybody ever figure this out?
    Monday, December 12, 2011 1:31 AM
  • Actions before solution found:

    • Attempted to re-register vss provider .dll files
    • Windows Server backup features uninstalled and reinstalled
    • Removed programs installed on and around the same date as the backup problem started


    • Copy the required VSS provider registry key from another machine HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Providers\{b5946137-7b9f-4925-af80-51abd60b20d5}
    • Import the registry entry onto the server with the backup problem

    After carrying out the above solution, the provider was listed in "vssadmin list providers"

    Backup now behaves as expected and no new issues have arose since

    • Proposed as answer by Adam Walton Monday, March 12, 2012 3:09 PM
    Monday, March 12, 2012 3:08 PM
  • This totally fixed the issue for me.  Thank you.
    Friday, March 16, 2012 4:13 PM
  • We eneded up calling MS support.  Here is what they had us do to fix the issue:


    1. Checked and found Microsoft
      Software Shadow Copy Provider Service was missing from services
    2. Tried to take System State
      Backup of the server, however it failed with the
    3. Checked and found that the
      Registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WSPRV entry
      is missing as well.
    4. Tried to register it using
      regsvr32 /i swprv.dll but got the error.
    5. Ran the command
      C:\Windows\System32\svchost.exe -k swprv (this will load the dll and Recreate
      the service)
    6. Found “Microsoft Software
      Shadow Copy provider service” is still not
    7. Ran the following
      1. Regsvr32
      2. Regsvr32
        C:\Windows\System32\ ES.DLL
      3. Regsvr32
        C:\Windows\System32\ EVENTCLS.DLL
      4. Regsvr32
        C:\Windows\System32\ vssui.dll
      5. Regsvr32
        C:\Windows\System32\ wbem\vsswmi.dll
      6. Regsvr32
        C:\Windows\System32\Cluster\ vsstask.dll
      7. Regsvr32
        C:\Windows\System32\Cluster\ vsstskex.dll
      8. Regsvr32
        C:\Windows\System32\ vss_ps.dll
      9. Regsvr32
        C:\Windows\System32\ vssui.dll
      10. Regsvr32
        C:\Windows\System32\ ole32.dll
      11. Regsvr32
        C:\Windows\System32\ msxml.dll
      12. Regsvr32
        C:\Windows\System32\ msxml2.dll
      13. Regsvr32
        C:\Windows\System32\ msxml3.dll
      14. Regsvr32
        C:\Windows\System32\ msxml4.dll
      15. Regsvr32 C:\Program
        files\Microsoft SQL Server\80\COM\ sqlvdi.dll
      16. Regsvr32
        C:\Windows\System32\ Vssvc.exe /Register
    8. Replaced swprv.dll from
      working machine.
    9. Found now we have swprv
      present in the registry.
    10. Ran the following
      1. C:\windows\system32 >
        regsvr32 ATL.dll
      2. C:\windows\system32 >
        regsvr32 swprv.dll
    11. Checked and found now we
      also have "Microsoft Software Shadow Copy Provider Service" under services.msc
    12. Took System State Backup of
      the server successfully.

    K Haroldsen

    Friday, March 16, 2012 4:19 PM
  • I ran all the commands , but the commands in the step 10 did the trick

    Ran the following
      • C:\windows\system32 >
        regsvr32 ATL.dll
      • C:\windows\system32 >
        regsvr32 swprv.dll


    Friday, September 21, 2012 5:29 PM